"Updates available" popup should hide when update-manager starts

Bug #33605 reported by Stuart Langridge on 2006-03-03
14
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Michael Vogt
Nominated for Jaunty by Nicholas Christian Langkjær Ipsen

Bug Description

Using a recent Dapper nightly build, the update-manager applet shows that there are updates to install by popping up a popup notification window. Clicking the update-manager icon in the notification area starts Software Updates, but does not hide the popup; it must be closed explicitly. It should hide when the app starts.

Tags: ui Edit Tag help
Changed in update-manager:
assignee: nobody → mvo
Lukas Sabota (punkrockguy318) wrote :

I can confirm this bug. Also, very similarly, the notifier doesn't notice if update-manager is already open. Both of these bugs seem to fall under the same problem, so I won't open a new bug.

Changed in update-manager:
status: Unconfirmed → Confirmed
Michael Vogt (mvo) wrote :

This bug is fixed in the latest dapper.

Thanks,
 Michael

Changed in update-manager:
status: Confirmed → Fix Released
Matthew Paul Thomas (mpt) wrote :

Reproduced in Ubuntu Gutsy.

Changed in update-manager:
status: Fix Released → New
Matthew Paul Thomas (mpt) wrote :

The notification bubble goes away about 10 seconds after Update Manager opens, but that's a long time. It should go away immediately when I click the orange star, even before Update Manager opens.

This is especially annoying if the notification appears when you are running a full screen application, like a movie or 3d game.

Duncan Lithgow (duncan-lithgow) wrote :

Lukas: the bug you mention is reported here: bug #163220
For what it's worth I also consider this a bug. I'm adding the 'ui' tag

François Ingelrest (athropos) wrote :

> The notification bubble goes away about 10 seconds after Update Manager opens, but that's a long time.

I've just tested: it took almost one minute for the notification bubble to disappear (Gutsy). There should not be any delay, it should be hidden as soon as the user clicks on the tray icon, because if it does that, then he is aware that there are some updates and by definition he does no longer need to be notified of that fact.

François Ingelrest (athropos) wrote :

Still not fixed in Hardy.

Ara Pulido (ara) wrote :

I can confirm that this is still happening in intrepid

Changed in update-manager:
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

Fixed in Jaunty, by not using a notification bubble any more.

Changed in update-manager:
status: Confirmed → Fix Committed
Przemek K. (azrael) on 2009-12-07
Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments