update-manager upgrade from up-to-date 6.06.2 LTS to 8.04.1 LTS fails

Bug #324058 reported by Lee Bradshaw on 2009-02-01
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Michael Vogt

Bug Description

Binary package hint: update-manager

1) Release is Ubuntu 6.06.2 LTS

2) update-manager 0.42.2ubuntu22.2

3) I selected System -> Administration -> Update Manager
There were no packages to update, but there is a note:
  "New Distribution release '8.04.1 LTS' is available"
I clicked on Upgrade, and eventually a dialog box pops up with
  "Could not find the release notes
   The server may be overloaded."

4) I expected the system to upgrade to 8.04.1 LTS.

I reviewed several similar bugs. I noticed that /var/lib/update-manager/meta-release contains urls that point to files that don't exist. For instance, there is a line:

ReleaseNotes: http://archive.ubuntu.com/ubuntu/dists/hardy-proposed/main/dist-upgrader-all/0.87.27/ReleaseAnnouncement

It looks like only 0.87.29, 0.87.30, and 0.87.31 are available though.

Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. Please attach the files in /var/log/dist-upgrade to this bug report as separate attachments.

Thanks in advance

Changed in update-manager:
status: New → Incomplete
Lee Bradshaw (lee-sectioniv) wrote :

That directory does not exist.

freefall ~ $ sudo ls /var/log
Password:
acpid dpkg.log.1 kern.log.3.gz scrollkeeper.log
acpid.1.gz dpkg.log.10.gz lastlog scrollkeeper.log.1
acpid.2.gz dpkg.log.11.gz lpr.log scrollkeeper.log.2
acpid.3.gz dpkg.log.12.gz mail.err syslog
acpid.4.gz dpkg.log.2.gz mail.info syslog.0
aptitude dpkg.log.3.gz mail.info.0 syslog.1.gz
aptitude.1.gz dpkg.log.4.gz mail.info.1.gz syslog.2.gz
aptitude.2.gz dpkg.log.5.gz mail.info.2.gz syslog.3.gz
aptitude.3.gz dpkg.log.6.gz mail.info.3.gz syslog.4.gz
auth.log dpkg.log.7.gz mail.info.4.gz syslog.5.gz
auth.log.0 dpkg.log.8.gz mail.info.5.gz syslog.6.gz
auth.log.1.gz dpkg.log.9.gz mail.log udev
auth.log.2.gz evms-engine.1.log mail.log.0 unattended-upgrades
auth.log.3.gz evms-engine.2.log mail.log.1.gz user.log
bootstrap.log evms-engine.3.log mail.log.2.gz user.log.0
btmp evms-engine.4.log mail.log.3.gz user.log.1.gz
btmp.1 evms-engine.5.log mail.log.4.gz user.log.2.gz
cups evms-engine.6.log mail.log.5.gz user.log.3.gz
daemon.log evms-engine.7.log mail.warn uucp.log
daemon.log.0 evms-engine.8.log mail.warn.0 vmware
daemon.log.1.gz evms-engine.9.log mail.warn.1.gz wtmp
daemon.log.2.gz evms-engine.log mail.warn.2.gz wtmp.1
daemon.log.3.gz faillog mail.warn.3.gz wvdialconf.log
debug fontconfig.log messages Xorg.0.log
debug.0 gdm messages.0 Xorg.0.log.old
debug.1.gz installer messages.1.gz Xorg.20.log
debug.2.gz kern.log messages.2.gz Xorg.20.log.old
debug.3.gz kern.log.0 messages.3.gz
dmesg kern.log.1.gz news
dpkg.log kern.log.2.gz ntop
freefall ~ $

Lee Bradshaw (lee-sectioniv) wrote :

I tried replacing the hardy section of /var/lib/update-manager/meta-release with the info from http://changelogs.ubuntu.com/meta-release. The file then points to http://archive.ubuntu.com/ubuntu/dists/hardy-proposed/main/dist-upgrader-all/0.87.30/ReleaseAnnouncement, instead of the non-existent 0.87.27 version. However update-manager seems to overwrite the meta-release file and change it back to the 0.87.27 version whenever it runs.

Lee Bradshaw (lee-sectioniv) wrote :

This version of meta-release contains urls to files that do exist and are listed in the latest http://changelogs.ubuntu.com/meta-release. However update-manager overwrites it with the version that points to the non-existent files. (Previous attachment shows the file update-manager creates.)

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please try the upgrade again? This should be fixed now.

Lee Bradshaw (lee-sectioniv) wrote :

Thanks. It worked.

Michael Vogt (mvo) on 2009-02-04
Changed in update-manager:
assignee: nobody → mvo
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers