All updates show up as "Not Authenticated" when only one is.

Bug #31706 reported by Thorne Huw Lawler on 2006-02-16
10
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Vogt

Bug Description

I keep the wine hq apt-source in my sources list. This means that when wine updates, the "Software Updates" tool shows the Wine update as "Not Authenticated!". This morning there were some kernel updates and stuff waiting for me, but when I went to apply them, it said they were *all* "Not Authenticated!". I didn't really want to install an unauthenticated Kernel, so I pulled wine out of my apt sources.list, re-updated and reloaded update-manager. The wanrings went away and everything worked just fine.
I am using the current (17/2/06) Ubuntu Breezy version of update manager, on x86-32.

Matt Zimmerman (mdz) on 2006-04-04
Changed in update-manager:
assignee: nobody → mvo
Jerome S. Gotangco (jsgotangco) wrote :

can you confirm this on dapper?

Changed in update-manager:
status: Unconfirmed → Needs Info

Jerome,

I would love to test this, but my Dapper box is currently throwing kernel
panics from somewhere in its Intel ICH7 SATA controller code. The said
hardware works perfectly under Win2k and multi-day Hitachi-Disk-Fitness
tests, so I'm confident that it's a Kernel issue.

Repeated posts to the Ubuntu Users mailing list have availed me nought but
one loon who had a bad experience with WD in 1992, and now assures me
that no WD drive can ever be trusted, regardless of testing.

If you can tell me where I might find some helpful support on an issue
like this, I would be only too happy to test this and any other bug you
care to name.

Otherwise, sadly, it will have to wait.

  Thorne Huw Lawler trouble.net.au
  In thy righteousness shall ye say eeeeew. -- The Babble of Mela.

On Wed, 28 Jun 2006, Jerome S. Gotangco wrote:

> can you confirm this on dapper?
>
> ** Changed in: update-manager (Ubuntu)
> Status: Unconfirmed => Needs Info
>
> --
> All updates show up as "Not Authenticated" when only one is.
> https://launchpad.net/bugs/31706
>

Mark Fenton (mark-fenton) wrote :

I get the same behaviour on Edgy when using the wine packages in my sources list. Often solved simply by rechecking for updates which then leaves only wine itself as unsigned (which is the expected behaviour).

update-manager 0.44.4

Changed in update-manager:
status: Needs Info → Confirmed
Mark Fenton (mark-fenton) wrote :

Further investigation when this popped up again shows the same behavior using apt from the command line, suggesting that is where this bug lies. (This time there is also no wine package in the updates to be installed). Again, running "apt-get update" to refresh the lists solves the problem and all packages are detected as signed.

apt 0.6.45ubuntu5

On my hardy and intrepid systems, this doesn't seem to be a problem anymore.

Changed in update-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers