upgrading feisty failed

Bug #310223 reported by Florian Hengartner on 2008-12-21
6
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

tried to upgrade my server with "sudo do-release-upgrade"
and then this happened:

Please report this bug against the 'update-manager' package and
include the files in /var/log/dist-upgrade/ in the bugreport.
installArchives() failed

Setting up linux-image-2.6.24-22-server (2.6.24-22.45) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.24-22-server
The provided postinst hook script [/sbin/update-grub] could not be run.
dpkg: error processing linux-image-2.6.24-22-server (--configure):
 subprocess post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-server:
 linux-image-server depends on linux-image-2.6.24-22-server; however:
  Package linux-image-2.6.24-22-server is not configured yet.
dpkg: error processing linux-image-server (--configure):
 dependency problems - leaving unconfigured
Setting up linux-image-2.6.22-16-server (2.6.22-16.60) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.22-16-server
The provided postinst hook script [/sbin/update-grub] could not be run.
dpkg: error processing linux-image-2.6.22-16-server (--configure):
 subprocess post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-ubuntu-modules-2.6.22-16-server:
 linux-ubuntu-modules-2.6.22-16-server depends on linux-image-2.6.22-16-server; however:
  Package linux-image-2.6.22-16-server is not configured yet.
dpkg: error processing linux-ubuntu-modules-2.6.22-16-server (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-ubuntu-modules-2.6.24-22-server:
 linux-ubuntu-modules-2.6.24-22-server depends on linux-image-2.6.24-22-server; however:
  Package linux-image-2.6.24-22-server is not configured yet.
dpkg: error processing linux-ubuntu-modules-2.6.24-22-server (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-2.6.24-22-server
 linux-image-server
 linux-image-2.6.22-16-server
 linux-ubuntu-modules-2.6.22-16-server
 linux-ubuntu-modules-2.6.24-22-server

--------------
lsb_release -rd
Description: Ubuntu 8.04.1
Release: 8.04

apt-cache policy update-manager
update-manager:
  Installed: (none)
  Candidate: 1:0.87.30
  Version table:
     1:0.87.30 0
        500 http://de.archive.ubuntu.com hardy-updates/main Packages
     1:0.87.24 0
        500 http://archive.ubuntu.com hardy/main Packages
     0.42.2ubuntu22 0
        100 /var/lib/dpkg/status

Jean-Baptiste Lallement (jibel) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add all the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments? Thanks in advance.

Changed in update-manager:
status: New → Incomplete

The other file is "main_pre_req.log" which I add with this comment, and there's also a file "apt.log" which is empty, thus i skip that.

the reason it fails is because "/sbin/update-grub" does not exist.
but it is specified as postinst hook in /etc/kernel-img.conf.

two things are wrong:
1. i use lilo! - why is kernel-img.conf configured to use grub?
2. when i installed grub, the path was still wrong!

to the whole mess i did this:
- download grub package from packages.ubuntu.org
- change /etc/kernel-image.conf from
   postinst_hook = /sbin/update-grub
   postrm_hook = /sbin/update-grub
to:
   postinst_hook = update-grub
   postrm_hook = update-grub
- sudo apt-get -f install

Victor Vargas (kamus) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem. Please reopen it if you encounter that this issue is still occurring in latest Ubuntu Karmic version. To reopen the bug report you can click under the Status column, and change the Status back to "New". Thanks again!

Changed in update-manager (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers