Update manager shows invalid value in "last updated" field if failed to get package list

Bug #307851 reported by Rafał Cieślak on 2008-12-14
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

I know the title doesn't explain this bug clearly, I'll give an example:

I start update-manager to update my system.
It says: System was last updated three days ago. (or somewhat like this, I use Polish translation)
I click "Check for updates".
Some strange errors appear (it really doesn't matter what errors) and it fails to get information about available updates.
Now it says: "System was last updated less than hour ago"
What??? It was last updated three days ago, as it failed to check for updates...

I use Ubuntu 8.10, update-manager in version 1:0.93.34.

XXXXXXX (yddraiggoch) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in update-manager (Ubuntu):
status: New → Incomplete
papukaija (papukaija) wrote :

"Some strange errors appear (it really doesn't matter what errors) and it fails to get information about available updates.
Now it says: 'System was last updated less than hour ago' "
--> In Jaunty it would say "System was last updated three days ago"
See bug 284541 for more information.

Victor Vargas (kamus) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem. Please reopen it if you encounter that this issue is still occurring or even better if you can check in latest Ubuntu Karmic version. To reopen the bug report you can click under the Status column, and change the Status back to "New". Thanks again!

Changed in update-manager (Ubuntu):
status: Incomplete → Invalid
papukaija (papukaija) wrote :

This is confirmed in Karmic.

Changed in update-manager (Ubuntu):
status: Invalid → Confirmed
Jamie Strandboge (jdstrand) wrote :

This is confirmed in natty.

papukaija (papukaija) on 2011-05-03
tags: added: natty
Robert Roth (evfool) wrote :

How did you confirm on Natty? I can not reproduce this by starting a check, and canceling it -> it gives me a failed to download repository information dialog, but the last updated info does not change.

papukaija (papukaija) wrote :

I just tested this on Natty and the last update time doesn't change if the update is cancelled or fails (for example if the network connection is lost during update). I'm setting this bug to 'Invalid' since the root cause is unknown. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in update-manager (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers