Kubuntu upgrade to Intrepid removes needed packages

Bug #277256 reported by Scott Kitterman on 2008-10-02
4
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
High
Unassigned
update-manager (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: update-manager

Starting with an up to date Hardy chroot with Backports enabled (so it's KDE 3.5.10, but that shouldn't matter), after removing 'obsolete' packages and the upgrade 'finishing', many packages still needed upgrading:

sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  automoc cmake gamin gnome-mime-data hspell libarchive1 libavahi-glib1 libbonobo2-0 libbonobo2-common libbonoboui2-0
  libbonoboui2-common libenchant-dev libgamin0 libgeoip1 libgif-dev libglade2-0 libgnome2-0 libgnome2-common
  libgnomecanvas2-0 libgnomecanvas2-common libgnomevfs2-0 libgnomevfs2-common libkcddb4 libkdegames4 libkeyutils-dev
  libkholidays4 libkleo4 libkpgp4 libotr2 libphonon-dev libpq-dev libqt4-dev libsoprano-dev libsqlite0 libsqlite0-dev
  libstreamanalyzer-dev libstreams-dev libvncserver0 libxtst-dev libzip1 x11proto-record-dev xsltproc
The following packages have been kept back:
  gwenview libkdegames-dev
The following packages will be upgraded:
  akregator ark dolphin gtk-qt-engine juk kaddressbook kalarm kamera kappfinder kate kcron kdebluetooth
  kdemultimedia-kio-plugins kdenetwork-filesharing kdepasswd kdepim-kresources kdepim-wizards kdesudo kfind kleopatra
  klipper kmag kmix kmousetool knetworkconf knode knotes konsole konsolekalendar kopete korganizer kppp krdc krfb kscd
  ksnapshot ksystemlog ktnef ktorrent kubuntu-docs kubuntu-konqueror-shortcuts kvkbd kwalletmanager kwin kwin-style-crystal
  software-properties-kde
46 upgraded, 42 newly installed, 0 to remove and 2 not upgraded.

Scott Kitterman (kitterman) wrote :

Marking confirmed since the same thing happened when I upgraded my laptop for real.

Changed in update-manager:
importance: Undecided → High
milestone: none → ubuntu-8.10
status: New → Confirmed
Scott Kitterman (kitterman) wrote :

Same test still produces similar results:

The following NEW packages will be installed:
  automoc cmake gamin gnome-mime-data hspell libarchive1 libavahi-glib1 libbonobo2-0 libbonobo2-common libbonoboui2-0
  libbonoboui2-common libenchant-dev libgamin0 libgeoip1 libgif-dev libglade2-0 libgnome2-0 libgnome2-common
  libgnomecanvas2-0 libgnomecanvas2-common libgnomevfs2-0 libgnomevfs2-common libkcddb4 libkdegames4 libkeyutils-dev
  libkholidays4 libkipi5 libkleo4 libkpgp4 libotr2 libphonon-dev libpq-dev libqt4-dev libsoprano-dev libsqlite0
  libsqlite0-dev libstreamanalyzer-dev libstreams-dev libvncserver0 libxtst-dev libzip1 x11proto-record-dev xsltproc
The following packages have been kept back:
  libkdegames-dev
The following packages will be upgraded:
  akregator ark dolphin gtk-qt-engine gwenview juk kaddressbook kalarm kamera kappfinder kate kcron kdebluetooth
  kdemultimedia-kio-plugins kdenetwork-filesharing kdepasswd kdepim-kresources kdepim-wizards kdesudo kfind kleopatra
  klipper kmag kmix kmousetool knetworkconf knode knotes konsole konsolekalendar kopete korganizer kppp krdc krfb kscd
  ksnapshot ksystemlog ktnef ktorrent kubuntu-docs kubuntu-konqueror-shortcuts kvkbd kwalletmanager kwin kwin-style-crystal
  software-properties-kde
47 upgraded, 43 newly installed, 0 to remove and 1 not upgraded.

Changed in kubuntu-meta:
importance: Undecided → High
status: New → Confirmed
Jonathan Riddell (jr) wrote :

Should be fixed in version 1:0.93.22?

Scott Kitterman (kitterman) wrote :

Did an upgrade last night that went fine. so I think it's fixed.

Changed in kubuntu-meta:
status: Confirmed → Fix Released
Changed in update-manager:
status: Confirmed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers