update-manager crashed with error in read()

Bug #262982 reported by Uphaar Agrawalla
6
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Fix Released
Medium
Michael Vogt

Bug Description

Binary package hint: update-manager

update-manager was downloading updates from the hardy-security and hardy-proposed repositories. Internet connection was a little unstable/slow at the time, but that shouldn't have made it crash.
The download and install process continued even after the crash, so I'm not sure if it restarts itself automatically.

ProblemType: Crash
Architecture: amd64
Date: Sat Aug 30 14:58:35 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/update-manager
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: update-manager 1:0.87.30
PackageArchitecture: all
ProcCmdline: /usr/bin/python2.5 /usr/bin/update-manager
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_IN
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/update-manager']
SourcePackage: update-manager
Title: update-manager crashed with error in read()
Uname: Linux 2.6.24-20-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin mldonkey netdev plugdev powerdev scanner video

Tags: apport-crash
Revision history for this message
Uphaar Agrawalla (uphaar) wrote :
Revision history for this message
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This is fixed in my bzr tree and it will be part of the next upload.

Changed in update-manager:
assignee: nobody → mvo
importance: Undecided → Medium
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.93.16

---------------
update-manager (1:0.93.16) intrepid; urgency=low

  [ Michael Vogt ]
  * DistUpgrade/DistUpgradeController.py:
    - automatically add "relatime" to the mount options
      of ext2/ext3
  * UpdateManager/Core/MetaRelease.py:
    - fix typo (thanks to Daniel Garcia)
  * DistUpgrade/DistUpgradeCache.py:
    - fix the removal of obsolete kernel packages when the
      old kernel abi package gets removed from -update and/or
      -security
  * UpdateManager/UpdateManager.py:
    - be more robust against server errors when fetching the
      changelogs (LP: #262982)
  * debian/control:
    - update the version dependency for python-apt, we need
      stuff from 0.7.5 (LP: #257781)
  * DistUpgrade/DistUpgradeView.py:#
    - make FuzzyTimeToStr() properly deal with plural forms
      (LP: #267234)

  [ Brian Murray ]
  * UpdateManager/UpdateManager.py:
    - preserve epoch in package version for changelogs at
      launchpad.net (LP: #270527)

 -- Michael Vogt <email address hidden> Tue, 16 Sep 2008 14:15:18 +0200

Changed in update-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers