crash gutsy -> hardy hardy 8.04.1 cdrom upgrade

Bug #253255 reported by Michael Vogt on 2008-07-30
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Critical
Colin Watson
python-apt (Ubuntu)
High
Michael Vogt
Gutsy
High
Unassigned
Hardy
Medium
Unassigned
update-manager (Ubuntu)
High
Michael Vogt
Gutsy
Undecided
Unassigned
Hardy
High
Unassigned

Bug Description

Binary package hint: update-manager

On a gutsy->hardy upgrade with the 8.04.1 cdrom in the drive the upgrade fails with a segmentation fault.

TEST CASE:
1. install stock gutsy
2. insert the hardy 8.04.1 cd into the drive
3. run apt-cdrom add
4. run "update-manager" and click on the "upgrade" button
5. watch the window vanish

6. install python-apt from gutsy-proposed
7. repeat step 4
8. verify that it does not crash

Michael Vogt (mvo) wrote :

The reason why it crashes is that the packages openssh-blacklist and openssl-blacklist have no priority information on the CD.

Changed in update-manager:
assignee: nobody → mvo
importance: Undecided → High
status: New → In Progress
Michael Vogt (mvo) wrote :

Fixed in intrepid with 0.7.7.1ubuntu1

Changed in python-apt:
assignee: nobody → mvo
importance: Undecided → High
status: New → Fix Released
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-apt - 0.7.7.1ubuntu1

---------------
python-apt (0.7.7.1ubuntu1) intrepid; urgency=low

  * python/cache.cc:
    - fix crash if Ver.PriorityType() returns NULL (LP: #253255)

 -- Michael Vogt <email address hidden> Wed, 30 Jul 2008 10:26:53 +0200

Changed in python-apt:
status: Fix Committed → Fix Released
Michael Vogt (mvo) on 2008-07-30
Changed in update-manager:
status: In Progress → Fix Committed
status: New → Invalid
status: New → In Progress
Changed in python-apt:
importance: Undecided → High
status: New → In Progress
Changed in update-manager:
importance: Undecided → High
Michael Vogt (mvo) on 2008-07-30
Changed in python-apt:
importance: Undecided → Medium
status: New → In Progress
Martin Pitt (pitti) wrote :

Accepted update-manager with workaround into hardy-proposed. Please test and give feedback here.

Changed in update-manager:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in python-apt:
status: In Progress → Fix Committed
status: In Progress → Fix Committed
Steve Beattie (sbeattie) wrote :

I was able to reproduce the segfault with a non-updated gutsy install containing python-apt 0.7.3.1ubuntu4. I then installed python-apt 0.7.3.1ubuntu4.2 from gutsy-proposed which addressed the segfault issue. Light testing of adding and removing other repositories and performing some updates showed no obvious regressions.

@mvo: Would a completely unpatched 8.04 installation work as a test case starting point for the hardy-proposed package? Or do you have another suggestion for reproducing with the hardy package?

Thanks!

Martin Pitt (pitti) wrote :

I did a test upgrade from gutsy to current hardy, using the gutsy-final python-apt. With "sudo update-manager" I get the segfault, with "sudo update-manager --proposed" the upgrade works. Thus this verifies that the update-manager workaround works, independently from the proper fix in python-apt.

Michael Vogt (mvo) wrote :

@Steve Beattie: for the verification of the python-apt in hardy a stock hardy will work (because intrepid does not yet have the workaround) so it should segfault as well when you run "update-manager -d". let me know if that does not work for you, I'm happy to assist with the verification.

Thanks a lot for verifying gutsy :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.93.2

---------------
update-manager (1:0.93.2) intrepid; urgency=low

  * DistUpgrade/DistUpgradeCache.py:
    - work around problem with packages with no priority
      (LP: #253255)
  * DistUpgrade/DistUpgradeViewGtk.py:
    - detect ctrl-c presses in the terminal and warn the
      user that it will kill the upgrade (LP: #90866)
  * DistUpgrade/DistUpgrade.cfg:
    - when being run by the sandbox-upgrader, do not
      reboot automatically after the upgrade finished
  * DistUpgrade/DistUpgradeController.py:
    - when a upgrade is cancelt due to network errors,
      inform that the downloaded files will be kept
      (LP: #242111)

 -- Michael Vogt <email address hidden> Tue, 05 Aug 2008 20:37:52 +0200

Changed in update-manager:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied update-manager to hardy-updates.

Changed in update-manager:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied python-apt to gutsy-updates, since it has been verified for gutsy.

Changed in python-apt:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

python-apt hardy-proposed copied to hardy-updates.

Changed in python-apt:
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

We should be fixing the missing priorities in cdimage as well, so that we don't have to work around this. The problem here is that there are some packages new in -updates, but cdimage is only using the release pocket's overrides files for Packages generation.

Changed in ubuntu-cdimage:
assignee: nobody → kamion
importance: Undecided → Critical
status: New → In Progress
Colin Watson (cjwatson) wrote :

revno: 1364
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Wed 2009-01-21 10:56:22 +0000
message:
  merge in override files from update pockets (LP: #253255)

Changed in ubuntu-cdimage:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers