interrupted upgrade should automatically resume

Bug #252068 reported by STEFANO on 2008-07-26
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: update-manager

When you interrupt the update, then you don't can resume the update.
For exemple stops electricity while updates, then when you turn no longer able to do the upgrade.
another example accidentally breaks the update process, then no longer able to resume (so automatic and easy, like so many other systems type Mac Os).

i know that is possible to resume, but is not easy for beginner as in other system.

Thanks

Michael Vogt (mvo) on 2008-07-28
Changed in update-manager:
importance: Undecided → Wishlist
status: New → Triaged
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

when regular updates get interrupted with ubuntu 8.04 then update-manager should be able to repair this by showing a icon in the gnome-panel. The same for release-upgrades, however this is of course tricky if there is no X working anymore :/

do you have to make thsi:

sistem admin package menager here in packaje manager you have to correct the break pakage.

good luck

Changed in update-manager:
status: Triaged → Fix Released

Thank you

________________________________
Da: Juan Sebastian Cobaleda Cano <email address hidden>
A: <email address hidden>
Inviato: Venerdì 12 dicembre 2008, 23:10:56
Oggetto: [Bug 252068] Re: interrupted upgrade should automatically resume

do you have to make thsi:

sistem admin package menager here in packaje manager you have to
correct the break pakage.

good luck

** Changed in: update-manager (Ubuntu)
       Status: Triaged => Fix Released

--
interrupted upgrade should automatically resume
https://bugs.launchpad.net/bugs/252068
You received this bug notification because you are a direct subscriber
of the bug.

Julian Alarcon (julian-alarcon) wrote :

The user Juan Sebastian Cobaleda Cano is a troll, or something. We, in the Ubuntu-Co Team are cheking all his changes in Launchpad. Sorry for the problems.

Changed in update-manager:
status: Fix Released → Confirmed
Teo (teo1978) wrote :

Bug 900884 has been marked as duplicate of this one, but let's NOT confuse two very different issues:

ONE THING is you try to upgrade, something goes wrong, and you decide not to retry immediately. Later, you should be able to resume the process. I think this is what was addressed in this report

ANOTHER THING is you try to upgrade, and you hit some very temporary error such as a network failure while downloading packages: in this case, the upgrade tool just gives an error message and exit. Instead, it should give an option to retry, without restarting from scratch. I mean like when you are copying a bunch of files and one fails: you are always given the option to retry or skip. Here skipping doesn't make sense, but retrying does. THIS is what 900884 was about.

I'm talking about a release upgrade (it's not clear if this was the case for the original report).

By the way, importance "wishlist" is ridiculous. Having to abort a procedure just because of a minor temporary failure like a network failure is unacceptable.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers