hardy upgrade fails: "essential package would have to be removed"

Bug #237243 reported by paul fox on 2008-06-04
2
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

i'm running gutsy 7.10 (which was upgraded from feisty which was upgraded from edgy).

i ran:
   apt-get update
   apt-get upgrade
   apt-get dist-upgrade
   do-release-upgrade

which gave the message:

  Could not calculate the upgrade
  A unresolvable problem occurred while calculating the upgrade.

as requested further in the message, i've attached the /var/dist-upgrade directory.

paul fox (pgf-launchpad) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Please run "do-release-upgrade -m desktop". The default mode of the cli application is server mode and that behaves slightly different than a server upgrade.

Changed in update-manager:
status: New → Incomplete
paul fox (pgf-launchpad) wrote :

this worked. perhaps do-release-upgrade could grow a manpage, or at least some more text in the usage message that describes the default behavior, and why one would use "-m desktop".

many thanks.

Changed in update-manager:
status: Incomplete → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Thanks for following up. I'm closing this report due to your last comment. Don't hesitate to submit any new bug.

Changed in update-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers