Upgrade manager: show reasons for package removals

Bug #235574 reported by Johann Petrak on 2008-05-28
2
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

When upgrade manager prepares the upgrade from Gutsy to Hardy, it shows 1) that some non-standard repositories were disabled and 2) shows a list of packages that will get removed along with packages that will get installed.

Unfortunately, this list does not say *why* packages will get removed, if other packages that replace them will get installed, or if the reason for removal is that they come from a non-standard repository.
In my case the upgrade was listing 110 packages as removal candidates. It is very hard for the user to decide if this is acceptable or if some key packages will be missing and whether those can be replaced with something new at a later time.
Also, the list of packages to be removed and installed cannot be copy pasted, so it is not possible to show the list in a forum or to a knowledgable friend to get advice.

Changed in update-manager:
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers