Update Manager fails Xubuntu 7.10 to 8.04 LTS if universe is not enabled

Bug #235113 reported by Paul Welsh on 2008-05-27
50
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

Updating from Xubuntu 7.10 to 8.04 LTS using Update Manager (release-upgrader version '0.87.27') fails. main.log reports:

2008-05-26 23:25:58,306 ERROR failed to mark 'xubuntu-desktop' for install (E:Unable to correct problems, you have held broken packages.)
2008-05-26 23:26:35,314 ERROR Dist-upgrade failed: 'Can't upgrade required meta-packages'

I attach the files from /var/log/dist-upgrade as requested by Update Manager.

Hardware is a Compaq Evo N110 laptop with a PIII processor and 256Mb RAM. I installed from the Live CD and have made few, if any, changes.

Paul Welsh (paul-welshfamily) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This error is caused by the fact that xubuntu moved from "main" to "universe". I'm not sure what the right fix here is. We could automatically transition people by enabling universe but I leave that to the xubuntu community to decide.

Changed in update-manager:
importance: Undecided → Medium
status: New → Confirmed
Changed in update-manager:
status: Confirmed → Triaged

Michael, would it be possible to implement your proposed fixed but require the user to acknowledge the change with the ability to cancel the upgrade cleanly?

rmx77 (remix77) wrote :

I've the same problem... any fixes??

Changed in update-manager (Ubuntu):
assignee: nobody → rmx77 (remix77)
Charlie Kravetz (charlie-tca) wrote :

rmx77: you assigned this to yourself as the the individual working the bug to fix it. If you are not working to fix it, but instead are simply trying to report that you are experiencing the bug, please do not assign anyone to it. There are no known fixes to this at the present time except to install xubuntu-desktop before attempting an upgrade. Also, Xubuntu was moved from main to universe during the development cycle of the 8.04, so if universe isn't enabled, the upgrade will fail.

rmx77 (remix77) on 2009-12-17
Changed in update-manager (Ubuntu):
assignee: rmx77 (remix77) → nobody
rmx77 (remix77) wrote :

Tnx Charlie Kravetz... i've solve the bug and i've updated to 8.04 LTS.

Marking as Invalid since 7.10 has entered EOL.

Changed in update-manager (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers