Attempted upgrade to 8.04 fails, then all upgrades fail

Bug #230591 reported by Ian Lowrie on 2008-05-15
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

First I had tried to upgrade to 8.04LTS, but this failed and reported possible problem with
Could not calculate the upgrade

A unresolvable problem occurred while calculating the upgrade.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.

I then tried to simply upgrade 7, but got a message headed:
Not all updates can be installed
so I tried partial upgrade, but that got a message:
Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.
which aborts upgrade...

files from /var/log/dist-upgrade/ attached

Richard Seguin (sectech) wrote :

It almost looks as though the ubuntu-desktop meta package wasn't installed before you did your upgrade...

What kind of error message do you get if you try 'sudo apt-get install ubuntu-desktop' ?

Changed in update-manager:
status: New → Incomplete

sudo apt-get install ubuntu-desktop gives

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

After a couple of reboots, and removing the driver for the GEForce card, the system permitted me to upgrade. I dont know enough about the driver to guess what happened, although it was provided by the manufacturer I think.

Anyway, I am happy with 8.04 so far!!!

Richard Seguin (sectech) wrote :

Could you look in synaptic to see if the ubuntu-desktop meta package was installed?

Richard Seguin (sectech) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in update-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments