Dist-upgrade from Gutsy to Hardy: losing packages

Bug #229508 reported by Zoubidoo on 2008-05-12
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

I lost some packages during a dist-upgrade update that I believe I shouldn't have.

I use some additional repositories like medibuntu and backports. These extra repositories have newer versions of some packages that are in the main ubuntu repositories. Dist-upgrade removes the extra repositories before the upgrade and drops packages that are both in core repositories and the extra repositories. I think this behaviour is undesirable.

Here is a specific example that probably applies to other packages too. Take the vim package. Adding the extra repositories gave me a newer version of vim. After the dist-upgrade to Hardy vim was behaving strangely and I couldn't work out what was going on. I lost a couple of hours figuring out whether new vim had bugs. It turned out vim was dropped in the upgrade and I was left running vim-tiny. dist-upgrade had decided it wasn't to upgrade vim.

I would suggest that normal behaviour is: if an installed package is both in the core repositores and in the extra repositories it should not be dropped during dist-upgrade.

Ralph Janke (txwikinger) wrote :

Thanks for reporting this issue and helping to make Ubuntu better.

Could you please provide the files in the directory "/var/log/dist-upgrade"

Thanks

Changed in update-manager:
assignee: nobody → txwikinger
status: New → Incomplete

> Could you please provide the files in the directory '/var/log/dist-
> upgrade'
>
> Thanks

dist-upgrade files as requested.

Cheers,

Parker

_________________________________________________________________
Free Windows Live software. Chat, search, share pics and more
http://get.live.com/

Ralph Janke (txwikinger) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in update-manager:
assignee: txwikinger → nobody
importance: Undecided → Medium
status: Incomplete → Triaged
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

The log indicates that you ran a CD upgrade without network. This may cause the experienced behavior because the upgrader will not be able to upgrade the packages that got earlier installed with network support. The full vim package is not on the CD for space reasons.

I would be interessted about the result of the upgrade with network support. I will add a note to the question that asks about the network support that some packages may be left alone in that case to avoid problems like the one you experienced.

Cheers,
 Michael

Michael Vogt (mvo) wrote :

When re-reading the note about the network usage, it seems that its not very clear that without it, the network is not used at all. I will also clarify this.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.91.7

---------------
update-manager (1:0.91.7) intrepid; urgency=low

  * DistUpgrade/DistUpgradeController.py:
    - add logging for kept packages
    - make the "use-network" question on cdrom upgrades
      more clear (LP: #229508)
    - do not just exit on upgrades with errors but show
      a proper finished message
  * DistUpgrade/DistUpgradeApport.py:
    - only run apport-{gtk,qt} if DISPLAY is set
  * DistUpgrade/DistUpgradeView{Gtk,KDE}.py:
    - do not show a error dialog for folloup errors from
      earlier errors (thanks to Alexander Sack for the report)

 -- Michael Vogt <email address hidden> Wed, 02 Jul 2008 13:10:56 +0200

Changed in update-manager:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers