Ubuntu

The meta-release file should be moved to archive.ubuntu.com to let the mirrors carry it

Reported by Stefano Rivera on 2008-05-08
86
This bug affects 15 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: update-manager

The upgrade manager needs to download http://changelogs.ubuntu.com/meta-release before it will display an Upgrade button.

For firewalled machines with a local mirror and machines requiring NTLM-authenticated proxy access, there is never an "upgrade" button. Even if there is a complete local mirror.

Another problem with this as reported in some duplicates is that the release upgrade available notification appears when the meta-release file is updated on changelogs.ubuntu.com, but if users click the button and their preferred mirror is not (yet) up-to-date, they get can not fetch errors.

Observed on the Gutsy->Hardy upgrade. We run a local FTP mirror, and our users have not been getting the option to upgrade, because outside connections to port 80 are firewalled. (NTLM proxies preferred). We worked around this by setting up a special proxy for meta-release.

Preferably the meta-release file should be moved to archive.ubuntu.com where the mirrors can carry it, and update-manager can get it from a local mirror. If this isn't possible, a configurable location would at least help our users.

I've discussed this with mvo, he agrees that this should be solved.

Andreas Moog (amoog) on 2008-08-20
Changed in update-manager:
status: New → Confirmed

Any chance this can be fixed before the Intrepid release? After Hardy's release I had to fix quite a few of our users' machines after botched upgrades due to them trying every trick they could find on the internet to force the upgrade.

tags: added: intrepid2jaunty
anatoly techtonik (techtonik) wrote :

It could be possible to move http://changelogs.ubuntu.com to the http://archive.ubuntu.com/ubuntu/changelogs - this way you would also be view changelogs in update manager from local mirror.

Stefano Rivera (stefanor) wrote :

> Preferably the meta-release file should be moved to archive.ubuntu.com where the mirrors can carry it, and
> update-manager can get it from a local mirror. If this isn't possible, a configurable location would at least help
> our users.

Just a note:
It has been configurable, in /etc/update-manager/meta-release since jaunty.

Rolf Leggewie (r0lf) on 2010-02-17
tags: removed: gutsy2hardy
Rolf Leggewie (r0lf) wrote :

Can this ticket be closed as fxed, then?

Changed in update-manager (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
Stefano Rivera (stefanor) wrote :

> Can this ticket be closed as fxed, then?

It's still not particularly friendly to our newbie users, but I guess it's closable.

anatoly techtonik (techtonik) wrote :

Still, is it possible to fall back to changelogs carried by archive if http://changelogs.ubuntu.com/ is not available?

Rolf Leggewie (r0lf) wrote :

Stefano, do you have an idea how this could be dealt with more elegantly?

The initial report asked for at least a configuration option which seems to be available now. In that sense, this ticket could be set to fixed. If there is anything reasonable that could be done to improve on this, please let us know.

Stefano Rivera (stefanor) wrote :

> Stefano, do you have an idea how this could be dealt with more elegantly?

> The initial report asked for at least a configuration option which seems to be available now. In that sense, this ticket
> could be set to fixed. If there is anything reasonable that could be done to improve on this, please let us know.

One could have a GUI tool to select changelog mirrors, but afaik we are the only people who mirror changelogs.ubuntu.com so that would be a bit silly.

In my mind, the logical solution is to get the upgrade meta-data from the mirror. That way everything would just work for everyone.

Rolf Leggewie (r0lf) wrote :

Stefano, I believe the kind of change you are looking for is usually tracked in http://rt.ubuntu.com (I find that kind of strange and regrettable not to have everything in LP). user/pw is ubuntu/ubuntu.

I will close the ticket here as fixed, the situation is configurable now. If you feel strongly enough about moving changelogs, please open a ticket on RT.

Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
Stefano Rivera (stefanor) wrote :

Opened a RT ticket: https://rt.ubuntu.com//Ticket/Display.html?id=9459
Such a change would require modifications to update-manager, though.

Jonathan Davies (jpds) on 2010-03-08
Changed in update-manager (Ubuntu):
status: Fix Released → Triaged
Rolf Leggewie (r0lf) on 2010-03-08
Changed in update-manager (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
Robert Roth (evfool) on 2011-08-11
Changed in update-manager (Ubuntu):
importance: Undecided → Low
summary: - Update-manager requires connectivity to changelog.ubuntu.com - mirrors
- alone aren't sufficient
+ The meta-release file should be moved to archive.ubuntu.com to let the
+ mirrors carry it.
summary: The meta-release file should be moved to archive.ubuntu.com to let the
- mirrors carry it.
+ mirrors carry it
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.