Updating problem after upgrading from 7.10 to 8.04

Bug #227459 reported by Alister on 2008-05-06
6
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Unassigned

Bug Description

I upgraded from 7.10 to 8.04 via the update manager.

All went well until the end of the install when the process did not seem to finish correctly. All packages were installed, then I got a message saying there was a problem upgrading VirtualBox, which could be resolved later.

I closed the error box, and the update window then closed without 'Cleaning Up' or prompting me to restart.

So I restarted as there was nothing else I could do, and Ubuntu booted up ok.

However, I am unable to update, as I get this error message in both the Update Manager and Terminal (after sudo apt-get update):

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

I tried running dpkg --configure -a as suggested, but got this:

gzip: stdout: No space left on device
update-initramfs: failed for /boot/initrd.img-2.6.24-16-generic
dpkg: subprocess post-installation script returned error exit status 1

Can anyone out there help me out on this issue, or will I have to do a fresh install?

I cannot open Synaptic Package Manager either because of the same message.

I tried:

sudo update-manager -c

but got this message:

current dist not found in meta-release file

Also, at the Grub boot-up the old kernel is still there as a choice. I presume this should have been removed after the upgrade?

Thanks for any advice.

Pedro Villavicencio (pedro) wrote :

it seems that you don't have enough space in your disc, can you check with df -hT ? thanks.

Changed in update-manager:
importance: Undecided → Low
status: New → Incomplete
Alister (alibignell) wrote :

Hi Pedro

Here is the output of df -hT

/dev/sda6 ext3 9.2G 3.2G 5.6G 37% /
varrun tmpfs 1005M 240K 1005M 1% /var/run
varlock tmpfs 1005M 0 1005M 0% /var/lock
udev tmpfs 1005M 72K 1005M 1% /dev
devshm tmpfs 1005M 12K 1005M 1% /dev/shm
lrm tmpfs 1005M 38M 968M 4% /lib/modules/2.6.24-16-generic/volatile
/dev/sda5 ext3 46M 40M 3.6M 92% /boot
/dev/sda7 ext3 59G 5.1G 51G 10% /home
/dev/sda1 fuseblk 75G 60G 15G 81% /media/sda1
/dev/sda2 vfat 4.6G 4.0G 616M 87% /media/sda2

i had set up the partition sizes as recommended on other forums, so am a bit surprised if I have run out of room!
Do I need to manually remove 7.10?

Thanks for your help.

Alister (alibignell) wrote :

The issue was indeed because of not enough space left in /boot, which may have appeared obvious to some but has been part of my continuing learning experience with ubuntu.

Here is what I did in case it is useful for someone in the same boat.
I copied all the files in /boot related to the old kernel version into a folder on my /home drive and then removed each one from /boot using sudo rm form Terminal.

After removing these files I then tried dpkg --configure -a again and this finally allowed the rest of the upgrade to complete. I then ran sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoclean
sudo apt-get autoremove

From what I had read elsewhere this seemed the correct process, but any comments from someone with more experience would be appreciated.

However, even after running the autoclean and autoremove commands, the previous kernel files were not removed.

Is this normal, or should they have been removed when the upgrade was completed? Otherwise I guess you end up with whole backlog of old versions and have to expand your /boot partition each time!

Sorry if this has ended up in the wrong place, I'm still learning with this whole process.

Jerzy Mansarliński (jmansar) wrote :

Hello. The previous kernel files are not automatically removed for safety reason. If the new kernel work wrong, you can always use the old one. So you need to remove old kernels manually using package manager.

It is not a bug in Ubuntu, so I am closing this bug report. Feel free to continue to report any other bugs you may find.

Changed in update-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions