update-manager fails to upgrade 7.10 -> 8.04

Bug #227197 reported by Toni Honkala on 2008-05-06
8
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Michael Vogt
Nominated for Intrepid by Martin Pitt
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Ubuntu alternate 8.04 LTS desktop i386 CD fails to upgrade 7.10.

TEST CASE:
1. install gutsy
2. install language-support-fi
3. insert the hardy alternate CD
4. click on upgrade without network
5. verify that it fails

6. get a daily CD with the new upgrader (not available yet)
7. insert the hardy alternate CD
8. clcik on upgrade without network
9. verify that it works

My present ubuntu 7.10 is clean, except it has
*voikko proofreading for Finnish
*closed drivers for audio and video (codecs for mp3, wma, etc., installed via the Ubuntu's Adde/Remove -functionality)

Error information given by the upgrade program in Finnish:
Tarvittavia päivitykseen liittyviä tarkistuksia ei voitu tehdä

Päivitystä määriteltäessä tapahtui ratkaisematon ongelma:

 Tämä voi johtua:
 * Päivittämisestä Ubuntun julkaisemattomaan kehitysversioon
 * Ubuntun kehitysversion käyttämisestä
 * Ubuntuun kuulumattomien, epävirallisten ohjelmapakettien käyttämisestä

Jos kyse ei ole näistä, ilmoita tämä ohjelmavirhe paketille "update-manager" ja sisällytä kansion /var/log/dist-upgrade/ tiedostot virheraporttiin.

Toni Honkala (toni-honkala) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

It looks like the problem is that the CD does not contain the required voikko package. Please try to (temporarely) remove it or allow the upgrader to use the network and let me know if that works. I will change the code so that on CD upgrades, it will be less strict about languages than it is on networked upgrades.

Changed in update-manager:
status: New → Incomplete
Michael Vogt (mvo) wrote :

Could you please download http://people.ubuntu.com/~mvo/update-manager/release-upgrader-0.87.27-test1.tar.gz
and unpack it into a temporary directory (e.g. ~/test-upgrade) then please run:
$ mount /cdrom
$ sudo ./hardy --cdrom /cdrom

and let me know if that works ? Click "don't use network" just as you did in the previous one that failed please.

Thanks,
 Michael

Michael Vogt (mvo) wrote :

The proposed fix:

=== modified file 'DistUpgrade/DistUpgradeCache.py'
--- DistUpgrade/DistUpgradeCache.py 2008-04-29 13:56:43 +0000
+++ DistUpgrade/DistUpgradeCache.py 2008-05-06 12:13:25 +0000
@@ -284,7 +284,8 @@

         # only enforce section if we have a network. Otherwise we run
         # into CD upgrade issues for installed language packs etc
- if bool(self.config.get("Options","withNetwork")):
+ network = self.config.get("Options","withNetwork")
+ if network == "True":
             logging.debug("Running KeepInstalledSection rules")
             # now the keepInstalledSection code
             for section in self.config.getlist("Distro","KeepInstalledSection"):

=== modified file 'debian/changelog'
--- debian/changelog 2008-04-30 20:42:54 +0000
+++ debian/changelog 2008-05-06 12:13:58 +0000
@@ -1,3 +1,10 @@
+update-manager (1:0.87.27) hardy-proposed; urgency=low
+
+ * DistUpgrade/DistUpgradeCache.py:
+ - fix bug in withNetwork value propergation (LP: #227197)
+
+ -- Michael Vogt <email address hidden> Tue, 06 May 2008 14:13:58 +0200
+

Changed in update-manager:
status: New → In Progress
Michael Vogt (mvo) wrote :

I commited a fix for this in intrepid

Changed in update-manager:
status: Incomplete → Fix Committed
Michael Vogt (mvo) wrote :

@Toni: we are preparing new CDs with a fix for this problem.

description: updated
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in update-manager:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Although not all fixed bugs have been verified, four tests from Brian showed that update-manager is still able to upgrade from dapper and gutsy, and fixed some bugs. Due to the urgency of some bugs I have copied this to hardy-updates now.

Changed in update-manager:
status: Fix Committed → Fix Released
assignee: nobody → mvo
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.91

---------------
update-manager (1:0.91) intrepid; urgency=low

  * DistUpgrade/DistUpgradeCache.py:
    - fix bug in withNetwork value propergation (LP: #227197)
  * DistUpgrade/DistUpgradeController.py:
    - fix bug with sources.list rewriting when mixed
      deb http://unknown-miror\ndeb-src http://known-mirror
      entries are used (#221730)
  * UpdateManager/Common/utils.py:
    - fix inhibit path (LP: #140754), thanks to
      Andreas Dalsgaard
  * DistUpgrade/DistUpgradeViewText.py:
    - use sensible-pager first and fallback to "more" if
      that is not available (thanks to Mithrandir)
  * DistUpgradeView{Gtk,KDE,Text}.py:
    - only overwrite the DEBIAN_FRONTEND if it is not set
      already (thanks to Guy Sheffer)
  * UpdateManagerHildon/UpdateManagerHildon.py:
    - add hildon support (thanks to Tollef Fog Heen and
      Emmet Hikory)

 -- Michael Vogt <email address hidden> Wed, 21 May 2008 18:01:07 +0200

Changed in update-manager:
status: Fix Committed → Fix Released
Vladimir Hidalgo (vlad88sv) wrote :

Hi!, I have more or less this same issue, with my copy on Ubuntu 8.10 Alternate, doing 'sudo /media/cdrom/cdromupgrade' runs but it crash at first step.

I downloaded http://people.ubuntu.com/~mvo/update-manager/release-upgrader-0.87.27-test2.tar.gz and then ran 'sudo ./hardy --cdrom /media/cdrom'.

Now it seems to run until step 2 when an error says something about it can't calculate the update (sorry my dialog is in Spanish).

BTW, http://people.ubuntu.com/~mvo/update-manager/release-upgrader-0.87.27-test1.tar.gz crashed at the same first step.

I attached the files in /var/log/dist-upgrade/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers