Failed to lock /var/cache/apt/archives/lock

Bug #224539 reported by Jonas on 2008-04-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
ferdyeka

Bug Description

Binary package hint: update-manager

Hello,

I started kubuntu upgrade from 7.10 to 8.04. Upgrade was downloading slow and I had to switch off my PC. I closed upgrade manager in the middle of package download. After I started again I got this error message: Failed to lock /var/cache/apt/archives/lock

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This might be a temporary problem. Could you please check if it works if you wait a bit longer? There may be some background downloading going on for example.

Changed in update-manager:
status: New → Incomplete
Jonas (jon-stekas) wrote :

After I canceled download I restarted coputer so nothing should work in background. I removed file from /var/cache/apt/archives/partial directory and everything was ok. So I guess problem was in unfinished package.

Jonathan Thomas (echidnaman) wrote :

Closing as it seemed to be a temporary issue.

Changed in update-manager:
status: Incomplete → Invalid
Changed in update-manager (Ubuntu):
status: Invalid → Confirmed
sirovsky (david-sirovsky) wrote :

I got this error during this (quite different though) scenario:

1. Applications => Ubuntu Software Center => ... Install some new app ...
2. At the same time (during download):
3. System => Administration => Hardware Drivers => ... Activate some new driver ...
4. This message is received.

Then:

5. Cancel the app download
6. Retry (3)
7. The driver was activated OK this time

ferdyeka (momon-diie) on 2011-04-22
Changed in update-manager (Ubuntu):
assignee: nobody → ferdyeka (momon-diie)
oriman (n-launchpad-tribla-com) wrote :

It effects me as well with Ubuntu 9.04.
The Update Manager offers me [Partial Upgrade]. I click it, wait for the downloading to finish, and get a screen that offers me to [Start Upgrade]. I click it and immediately receive this error message.

I tried to run the Update-Manager as root but got the same error.

A [Retry] button would be good, allowing me to try and remove this lock before the Update Manager starts to undo all changes.

Is there a work-around?

Edward Donovan (edward.donovan) wrote :

I'm gonna close this, marking it as Invalid. Any program that does apt work can have this 'failed to lock error', but there's no bug evident here. These are temporary problems, from running two package tools at once, or a process not exiting, or at worst a temporary file needing to be removed.

These reports show imperfections in the the packaging system that could be made into wishlist bugs:

- Jonas fixed his temporary problem. Ideally users would not have to manually clean up files to get past this.
- sirovsky was trying to do two package tasks at once. Perhaps error messages could make that clearer.
- oriman: did this continue? if this is reproducible for you, you might re-open this bug.

The error messages and cleanups could be improved, but receiving the "failed to lock" message isn't a particular breakage in update manager. Thanks.

Changed in update-manager (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers