update manager stops when update check is asked manually

Bug #224303 reported by kex on 2008-04-29
6
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

after updating from 7.10 to 8.04LTS

When starting update manager from the system menu, it looks normal. When I press "check updates" (or whatever it is called in English), the window turns gray, and stops responding.

kex@xpc:~$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

kex@xpc:~$ apt-cache policy update-manager
update-manager:
  Asennettu: 1:0.87.24
  Ehdokas: 1:0.87.24
  Versiotaulukko:
 *** 1:0.87.24 0
        500 http://fi.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Processes:
 6275 ? Sl 0:05 /usr/bin/python2.5 /usr/bin/update-manager
 6287 ? S 0:00 /usr/bin/gksu --desktop /usr/share/applications/update-manager.desktop -- /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 50331651 --update-at-startup
 6288 ? Ss 0:00 /usr/bin/sudo -H -S -p GNOME_SUDO_PASS -u root -- /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 50331651 --update-at-startup

kex (kex-iki) wrote :
kex (kex-iki) wrote :
kex (kex-iki) wrote :
kex (kex-iki) wrote :

just an additional note. Killing the GNOME_SUDO_PASS process immediately returns to the update manager window, which becomes responsive again.

kex (kex-iki) wrote :

addditional info I found:

kex@xpc:~$ G_DEBUG=fatal_criticals update-manager
current dist not found in meta-release file
current dist not found in meta-release file

(I upgraded one day before 8.04 was released)

What was peculiar is that when starting from command line, like this, sudo actually worked.

So I tried to update dist, but it said it is up to date already. And crashed when exiting:

kex@xpc:~$ sudo G_DEBUG=fatal_criticals update-manager --dist-upgrade
sudo: unable to resolve host xpc
ERROR:root:not handled expection:
Traceback (most recent call last):

  File "/usr/bin/update-manager", line 94, in <module>
    if controler.askDistUpgrade():

  File "/usr/lib/python2.5/site-packages/DistUpgrade/DistUpgradeController.py", line 818, in askDistUpgrade
    self.cache.requiredDownload)

  File "/usr/lib/python2.5/site-packages/DistUpgrade/DistUpgradeViewGtk.py", line 537, in confirmChanges
    self.confirmChangesMessage += "\n\n<b>%s</b>" % \

AttributeError: 'DistUpgradeViewGtk' object has no attribute 'confirmChangesMessage'

ERROR:root:failed to import apport python module, can't report bug: No module named python_hook

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Can you always reproduce this (will "check" always hang?). Does "/usr/bin/sudo -H -S -u root -- /usr/sbin/synaptic --non-interactive -update-at-startup" work for you?

Changed in update-manager:
status: New → Incomplete
kex (kex-iki) wrote :

yes, it always hangs.

the command line

kex@xpc:~$ G_DEBUG=fatal_criticals /usr/bin/sudo -H -S -u root -- /usr/sbin/synaptic --non-interactive --update-at-startup
sudo: unable to resolve host xpc
kex@xpc:~$

opens the synaptic window, and another smaller one where there is a progress bar advancing, and then closes both of them. When starting the update manager from the menu, it shows that the packets have been updated less than an hour ago.

Btw. a related thing seems that I sometimes I cannot start the synaptic package manager from the menu at all. Sometimes it does start. This (synaptic) bug I cannot reproduce reliably, it sometimes does not start, sometimes does.

kex (kex-iki) wrote :

I think I found where the symptom comes from.

I had only host name but not domain set up in the network settings. This results in sudo giving a warning in the text mode, but still working. For starting from menu, it means sudo simply does not work.

kex (kex-iki) wrote :

the update of sudo that appeared yesterday or the day before seems to have fixed the problem.

Daniel Ribeiro (danielm-lia) wrote :

I have the same problem, but was from a fresh instalation!

Daniel Ribeiro (danielm-lia) wrote :

Sorry about 2 messages.
I think this is not update-manager, because synaptic not works from menu too. Likes to see sudo or gksu bug.

Daniel Ribeiro (danielm-lia) wrote :

This is really a gksu or sudo bug. My system is up to date. If i put in a terminal gksu any_comand_here, nothing happens. If i try the su mode (with -w), they asks for the password of root.

This is the output for gksu -d gedit
:~$ gksu -d gedit
No ask_pass set, using default!
xauth: /tmp/libgksu-MnZ9Qv/.Xauthority
STARTUP_ID: gksu/gedit/5920-0-acerola_TIME612798
cmd[0]: /usr/bin/sudo
cmd[1]: -H
cmd[2]: -S
cmd[3]: -p
cmd[4]: GNOME_SUDO_PASS
cmd[5]: -u
cmd[6]: root
cmd[7]: --
cmd[8]: gedit
buffer: --
buffer: --
buffer: --
*********** (the line above repeated a lot of times)*********
brute force GNOME_SUDO_PASS ended...
No password prompt found; we'll assume we don't need a password.
------------------------------------------------------------------------------------------------------------------------------------------------------------------------

If i try
:~$ sudo -H -S -p some_password_here -u root -- gedit
the answer is:
some_password_here
and the process continue until i press ctrl+c, the the message above apears:
sudo: pam_authenticate: Conversation error

Jayson Rowe (jayson.rowe) wrote :

Since it's been a very long time since any additional info was added to this bug, I'm just checking to see if this is still an issue, and find out what additional work should be done on this bug.

kex (kex-iki) wrote :

for me, it was the broken "su". After the update I already mentioned, no problems.

 This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in update-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers