package update-manager failed to install or upgrade

Bug #223864 reported by Basia on 2008-04-28
8
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

update-manager didn't upgrade from feisty to heron

ProblemType: Package
Architecture: i386
Date: Mon Apr 28 21:18:37 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)

Package: update-manager 1:0.87.24
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.87.24 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)
Uname: Linux 2.6.24-16-generic i686

Basia (barbara-trzeciak) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Please attach the files in /var/log/dist-upgrade to this bugreport.
 Thanks Michael

Changed in update-manager:
status: New → Incomplete
piagent (piagent) wrote :

From Gusty 7.10 (all upgrade installed) to Hardy 8.04 AMD 800mhz i386

had no action after it got to checking database. Detail switch ghosted. Switched to command line

    sudo aptitude install update-manager-core
    sudo do-release-upgrade
    .....
    Calculating the changes

    Could not calculate the upgrade

    A unresolvable problem occurred while calculating the upgrade.

    This can be caused by:
    * Upgrading to a pre-release version of Ubuntu
    * Running the current pre-release version of Ubuntu
    * Unofficial software packages not provided by Ubuntu

    If none of this applies, then please report this bug against the
    'update-manager' package and include the files in
    /var/log/dist-upgrade/ in the bugreport.

    Restoring original system state

    Aborting
    Reading package lists: Donem gutsy-backports/universe Packages: 95
    Reading state information: Done
    Reading state information: Done
    Reading state information: Done

piagent (piagent) wrote :

additional file

piagent (piagent) wrote :
Michael Vogt (mvo) wrote :

Thanks for the logs.

It looks like you run "do-release-upgrade" to perform a desktop ugprade. Please run "do-release-upgrade -m desktop" (see http://wiki.ubuntu.com/UpdateManagerFaq for details). Please let me know if that worked.

  • unnamed Edit (1.9 KiB, text/html; charset=ISO-8859-1)

Thanks for Your answer.
I restarted my system then did "apt-get upgrade", and now everything seem to
be ok - update manager works.

2008/4/30 Michael Vogt <email address hidden>:

> Thanks for the logs.
>
> It looks like you run "do-release-upgrade" to perform a desktop ugprade.
> Please run "do-release-upgrade -m desktop" (see
> http://wiki.ubuntu.com/UpdateManagerFaq for details). Please let me
> know if that worked.
>
> --
> package update-manager failed to install or upgrade
> https://bugs.launchpad.net/bugs/223864
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "update-manager" in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: update-manager
>
> update-manager didn't upgrade from feisty to heron
>
> ProblemType: Package
> Architecture: i386
> Date: Mon Apr 28 21:18:37 2008
> DistroRelease: Ubuntu 8.04
> ErrorMessage: ErrorMessage: SystemError in cache.commit(): E:Sub-process
> /usr/bin/dpkg returned an error code (1)
>
> Package: update-manager 1:0.87.24
> PackageArchitecture: all
> SourcePackage: update-manager
> Title: package update-manager 1:0.87.24 failed to install/upgrade:
> ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg
> returned an error code (1)
> Uname: Linux 2.6.24-16-generic i686
>

--
Pozdrawiam,
Barbara Trzeciak

piagent (piagent) wrote :

Oh, yah! Sweet!

Thank you Michael Vogt the "do-release-upgrade -m desktop" did the trick.
I still don't understand why the GUI update manager got stuck. I moved too quickly to command line so I could see what was going on with the GUI .... not thinking to look at the logs that the GUI produced.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for following up. I'm closing this report due to your last comment. Don't hesitate to submit any new bug.

Changed in update-manager:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers