Comment 0 for bug 223419

jihoon (jihoon) wrote :

Binary package hint: update-manager

po/ko.po does not have translation for msgid "y", "n", "d".
Also it has wrong translation for "Continue [yN] ".
This makes it impossible to upgrade from Dapper to Hardy using do-release-upgrade from console
(Since I am unable to input "y" to continue upgrading)

Here's patch that addressed this problem.

--- cut here ---
--- update-manager-0.81.2.orig/po/ko.po 2007-10-13 01:35:59.000000000 +0900
+++ update-manager-0.81.2/po/ko.po 2008-04-28 11:45:45.000000000 +0900
@@ -918,28 +918,28 @@
 #: ../DistUpgrade/DistUpgradeViewText.py:184
 #, fuzzy
 msgid "Continue [yN] "
-msgstr "계속(_C)"
+msgstr "계속 [yN]"

 #: ../DistUpgrade/DistUpgradeViewText.py:164
 #, fuzzy
 msgid "Details [d]"
-msgstr "자세히"
+msgstr "자세히 [d]"

 #. TRANSLATORS: the "y" is "yes"
 #: ../DistUpgrade/DistUpgradeViewText.py:168
 #: ../DistUpgrade/DistUpgradeViewText.py:186
 msgid "y"
-msgstr ""
+msgstr "y"

 #. TRANSLATORS: the "n" is "no"
 #: ../DistUpgrade/DistUpgradeViewText.py:171
 msgid "n"
-msgstr ""
+msgstr "n"

 #. TRANSLATORS: the "d" is "details"
 #: ../DistUpgrade/DistUpgradeViewText.py:174
 msgid "d"
-msgstr ""
+msgstr "d"

--- cut here ---