po/ko.po: "y"/"n"/"d" not translated. unable to answer anything with do-release-upgrade command

Bug #223419 reported by jihoon on 2008-04-28
8
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Michael Vogt
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

TEST CASE:
1. install gutsy server in korean (or install language-pack-ko and run "export LANGUAGE=ko")
2. run "do-release-upgrade"
3. when offered to continue (in korean) press "y"
4. verify that it does not work

5. run "do-release-upgrader --proposed"
6. when offered to continue press "y"
7. verify that it works now

po/ko.po does not have translation for msgid "y", "n", "d".
Also it has wrong translation for "Continue [yN] ".
This makes it impossible to upgrade from Dapper to Hardy using do-release-upgrade from console
(Since I am unable to input "y" to continue upgrading)

Here's patch that addressed this problem.

--- cut here ---
--- update-manager-0.81.2.orig/po/ko.po 2007-10-13 01:35:59.000000000 +0900
+++ update-manager-0.81.2/po/ko.po 2008-04-28 11:45:45.000000000 +0900
@@ -918,28 +918,28 @@
 #: ../DistUpgrade/DistUpgradeViewText.py:184
 #, fuzzy
 msgid "Continue [yN] "
-msgstr "계속(_C)"
+msgstr "계속 [yN]"

 #: ../DistUpgrade/DistUpgradeViewText.py:164
 #, fuzzy
 msgid "Details [d]"
-msgstr "자세히"
+msgstr "자세히 [d]"

 #. TRANSLATORS: the "y" is "yes"
 #: ../DistUpgrade/DistUpgradeViewText.py:168
 #: ../DistUpgrade/DistUpgradeViewText.py:186
 msgid "y"
-msgstr ""
+msgstr "y"

 #. TRANSLATORS: the "n" is "no"
 #: ../DistUpgrade/DistUpgradeViewText.py:171
 msgid "n"
-msgstr ""
+msgstr "n"

 #. TRANSLATORS: the "d" is "details"
 #: ../DistUpgrade/DistUpgradeViewText.py:174
 msgid "d"
-msgstr ""
+msgstr "d"

--- cut here ---

jihoon (jihoon) on 2008-04-28
Changed in update-manager:
assignee: nobody → eungkyu
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I have the following translations in po/ko.po:

#: ../DistUpgrade/DistUpgradeViewText.py:148
#: ../DistUpgrade/DistUpgradeViewText.py:172
msgid "Continue [yN] "
msgstr "계속 [yN] "

#: ../DistUpgrade/DistUpgradeViewText.py:148
msgid "Details [d]"
msgstr "상세 정보 [d]"

#. TRANSLATORS: the "y" is "yes"
#: ../DistUpgrade/DistUpgradeViewText.py:152
#: ../DistUpgrade/DistUpgradeViewText.py:176
msgid "y"
msgstr "예"

#. TRANSLATORS: the "n" is "no"
#: ../DistUpgrade/DistUpgradeViewText.py:155
msgid "n"
msgstr "아니오"

This is with the latest update-manager 0.87.24. That one is used during dapper->hardy upgrades. You can get/view the source at
https://code.edge.launchpad.net/~ubuntu-core-dev/update-manager/main

Thanks,
 MIchael

Changed in update-manager:
importance: Undecided → High
milestone: none → ubuntu-8.04.1
status: New → Confirmed
milestone: ubuntu-8.04.1 → none
status: Confirmed → Incomplete
jihoon (jihoon) wrote :

OK. I see where the problem is now.

Under Korean language environment, the upgrade process asks for confirmation with the following message.
msgid "Continue [yN] "
msgstr "계속 [yN] "

But, the function that compares the user-input answer ( DistUpgrade/DistUpgradeViewText.py:confirmChanges() ) compares the string with _("Y") and _("N"), which gets substituted with "예" and "아니오".

So, the user has no idea that he/she should answer with korean word equivalent of "y"/"n", instead of the literal string "y"/"n".

I think ko.po should be patched to keep "y"/"n" strings as is. (not translating it to korean word of "예"/"아니오") as below.

--- cut here ---
#. TRANSLATORS: the "y" is "yes"
#: ../DistUpgrade/DistUpgradeViewText.py:152
#: ../DistUpgrade/DistUpgradeViewText.py:176
msgid "y"
msgstr "y"

#. TRANSLATORS: the "n" is "no"
#: ../DistUpgrade/DistUpgradeViewText.py:155
msgid "n"
msgstr "n"
--- cut here ---

Eungkyu Song (eungkyu) wrote :

I can confirm and I corrected the translation in launchpad.

Someone should apply new translation to package.
Why am I assigned to this bug? I'm not a maintainer but a translator

jihoon (jihoon) wrote :

>>Why am I assigned to this bug? I'm not a maintainer but a translator

sorry, that's my bad. I wasn't familiar with the launchpad interface and must have hit the wrong buttons trying to find who the translator was.

Sorry for the inconvenience this has caused you.

jihoon (jihoon) on 2008-04-29
Changed in update-manager:
assignee: eungkyu → nobody
jihoon (jihoon) on 2008-05-06
Changed in update-manager:
status: Incomplete → Confirmed
Michael Vogt (mvo) wrote :

Thanks for looking into this.

I proposed the following patch and will ask to get this into hardy-updates:

=== modified file 'debian/changelog'
--- debian/changelog 2008-05-06 12:29:54 +0000
+++ debian/changelog 2008-05-06 12:38:33 +0000
@@ -2,6 +2,8 @@

   * DistUpgrade/DistUpgradeCache.py:
     - fix bug in withNetwork value propergation (LP: #227197)
+ * po/ko.po:
+ - fix translation (LP: #223419)

  --

=== modified file 'po/ko.po'
--- po/ko.po 2008-04-02 08:44:34 +0000
+++ po/ko.po 2008-05-06 12:37:34 +0000
@@ -1014,12 +1014,12 @@
 #: ../DistUpgrade/DistUpgradeViewText.py:152
 #: ../DistUpgrade/DistUpgradeViewText.py:176
 msgid "y"
-msgstr "예"
+msgstr "y"

 #. TRANSLATORS: the "n" is "no"
 #: ../DistUpgrade/DistUpgradeViewText.py:155
 msgid "n"
-msgstr "아니오"
+msgstr "n"

 #. TRANSLATORS: the "d" is "details"
 #: ../DistUpgrade/DistUpgradeViewText.py:158

Michael Vogt (mvo) on 2008-05-09
description: updated
Michael Vogt (mvo) on 2008-05-09
description: updated
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in update-manager:
status: New → Fix Committed
jihoon (jihoon) wrote :

> 5. run "do-release-upgrader --proposed"

above command does not work. (Testing under Gutsy)
'do-release-upgrade --proposed' also does not work

$ sudo do-release-upgrade --proposed
Usage: do-release-upgrade [options]

do-release-upgrade: error: no such option: --proposed

Brian Murray (brian-murray) wrote :

I've verified that update-manager version 0.87.27 in hardy-proposed allows one to enter y/n/d for the Korean language. I did this manually downloading update-manager_0.87.27.tar.gz, extracting the tarball and executing 'sudo ./do-release-upgrade --proposed' since '--proposed' is not an option with update-manager version 0.81.3 in gutsy-updates.

Martin Pitt (pitti) wrote :

Although not all fixed bugs have been verified, four tests from Brian showed that update-manager is still able to upgrade from dapper and gutsy, and fixed some bugs. Due to the urgency of some bugs I have copied this to hardy-updates now.

Changed in update-manager:
status: Fix Committed → Fix Released
Michael Vogt (mvo) on 2008-06-16
Changed in update-manager:
assignee: nobody → mvo
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers