Gutsy->Hardy upgrade fails with ubuntustudio installed

Bug #219659 reported by Matthias Rosenkranz on 2008-04-19
36
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Vogt
Hardy
Undecided
Michael Vogt
Intrepid
Medium
Michael Vogt

Bug Description

Binary package hint: update-manager

TEST CASE (once update-manager enters hardy-proposed)
1. install ubuntustudio-desktop on a gutsy system (ubuntu-desktop, ubuntu-sounds gets removed)
2. remove ubuntustudio-desktop
3. run "update-manager"
4. click on "upgrade to 8.04 lts"
5. verify that the upgrade fails

6. run "update-manager -p"
7. click on "upgrade to 8.04 lts"
8. verify that the upgrade works (its enough to show that it can be calculated)

I tried to upgrade to Hardy RC from a current Gutsy installation (64bit version) today, which also has bits and pieces of ubuntustudio installed (not the full Studio distribution). To upgrade I used "update-manager --devel-release" but it fails reproducibly with the message:
  Can't install 'ubuntu-desktop'
  It was impossible to install a required package. Please report this as a bug.

Attached are the logs from /var/log/dist-upgrade. From the logs it looks like there is a problem with the ubuntustudio packages but I am no expert. Would be nice to get it fixed before the final release. Let me know if this is caused by a broken installation or otherwise how I can help to trace it.

Matthias Rosenkranz (rose) wrote :
Matthias Rosenkranz (rose) wrote :
Matthias Rosenkranz (rose) wrote :

For the records: this can be fixed by manually installing the ubuntu-sounds package before upgrading to Hardy. This solved the problem for me.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

ubuntustudio-sounds conflicts with ubuntu-sounds. The later is a dependency of ubuntu-desktop. This means that ubuntu-desktop and ubuntustudio-desktop can not be installed togehter.

Michael Vogt (mvo) wrote :

I fixed this in my latest update-manager bzr tree and it will be part of the next upload.

Changed in ubuntustudio-sounds:
importance: Undecided → Medium
milestone: none → ubuntu-8.04.1
Michael Vogt (mvo) wrote :

Diff for the change:

=== modified file 'DistUpgrade/DistUpgrade.cfg'
--- DistUpgrade/DistUpgrade.cfg 2008-03-18 12:31:29 +0000
+++ DistUpgrade/DistUpgrade.cfg 2008-04-28 14:54:37 +0000
@@ -24,7 +24,7 @@

 # information about the individual meta-pkgs
 [ubuntu-desktop]
-KeyDependencies=gdm, gnome-panel, ubuntu-artwork
+KeyDependencies=gdm, gnome-panel, ubuntu-artwork, ubuntu-sounds
 # those pkgs will be marked remove right after the distUpgrade in the cache
 PostUpgradeRemove=xscreensaver, gnome-cups-manager
 ForcedObsoletes=desktop-effects

=== modified file 'debian/changelog'
--- debian/changelog 2008-04-25 13:35:49 +0000
+++ debian/changelog 2008-04-28 14:55:37 +0000
@@ -5,6 +5,9 @@
       initialized (#221023)
   * DistUpgrade/mirrors.cfg:
     - added missing russion mirror (LP: #221730)
+ * DistUpgrade/DistUpgrade.cfg:
+ - better detection to missing dependencies to fix
+ ubuntustudio-desktop upgrade problem (#219659)

  --

description: updated
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test.

Changed in update-manager:
assignee: nobody → mvo
status: New → Fix Committed
assignee: nobody → mvo
milestone: ubuntu-8.04.1 → intrepid-alpha-1
status: New → In Progress
Michael Vogt (mvo) on 2008-04-29
Changed in update-manager:
status: In Progress → Fix Committed

Mr. Pitt,
I am new to this bug process. How do I test this? I have already removed the
UbuntuStudio theme from my system.

Thanks!
Ed

On Tue, April 29, 2008 8:01 am, Martin Pitt said:
> Accepted into hardy-proposed, please test.
>
> ** Tags added: verification-needed
>
> ** Changed in: update-manager (Ubuntu Hardy)
> Assignee: (unassigned) => Michael Vogt (mvo)
> Status: New => Fix Committed
>
> ** Changed in: update-manager (Ubuntu Intrepid)
> Assignee: (unassigned) => Michael Vogt (mvo)
> Status: New => In Progress
> Target: ubuntu-8.04.1 => intrepid-alpha-1
>
> --
> Gutsy->Hardy upgrade fails with ubuntustudio installed
> https://bugs.launchpad.net/bugs/219659
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Ed Covert
<email address hidden>

Martin Pitt (pitti) wrote :

Ed, see the "TEST CASE:" in the description for a recipe how to reproduce this and test the fix. I expect that this is done by the sru-verification team or by Michael, but of course anyone else is welcome to test it as well. Thank you!

Ed Covert (ebcovert3) wrote :

Oh ok. Thanks!

On Tue, April 29, 2008 9:17 am, Martin Pitt said:
> Ed, see the "TEST CASE:" in the description for a recipe how to
> reproduce this and test the fix. I expect that this is done by the sru-
> verification team or by Michael, but of course anyone else is welcome to
> test it as well. Thank you!
>
> --
> Gutsy->Hardy upgrade fails with ubuntustudio installed
> https://bugs.launchpad.net/bugs/219659
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Ed Covert
<email address hidden>

Brian Murray (brian-murray) wrote :

I followed the test case provided and was unable to upgrade from Gutsy to Hardy with update-manager version 0.87.24. I then used the version of update-manager from -propsed, 0.87.25, and was able to complete the upgrade to Hardy Heron.

Martin Pitt (pitti) wrote :

Although not all fixed bugs have been verified, four tests from Brian showed that update-manager is still able to upgrade from dapper and gutsy, and fixed some bugs. Due to the urgency of some bugs I have copied this to hardy-updates now.

Changed in update-manager:
status: Fix Committed → Fix Released
Michael Vogt (mvo) on 2008-06-16
Changed in update-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments