cannot calculate upgrade

Bug #219531 reported by phread59 on 2008-04-19
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Upgrade manager will not update files. Error message comes up "cannot calculate update". I am attempting a partial upgrade. Message states to add "files in /var/log/dist-upgrade/ ". There are some updates available. At log in a prompt to update comes up but cannot accomplish this. This bug showed about a week ago and seemed to vanish. I assumed the bug was fixed. This week a new update shows up and it fails to install again. thank you for your help in advance.

Mark Shuman

Gutsy 7.10 32 bit Ubuntu

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Please attach the files in /var/log/dist-upgrade to this report.

Changed in update-manager:
status: New → Incomplete
Paul (paulwillems) wrote :

I discovered the same problem when upgrading from 7.10 to 8.04.
Please find attached the files stored in /var/log/dist-upgrade/
Hope this might help.

Best regards,

Paul WIllems

Nigel (nigel-grimsley) wrote :

I have the same problem updating from Gusty to Hardy, but add that in the few weeks before the update was released, I already had an updating some packages.

I attach the /var/log/dist-upgrade files.

Nigel Grimsley

Nigel (nigel-grimsley) wrote :
Nigel (nigel-grimsley) wrote :
Nigel (nigel-grimsley) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please retry the upgrade? This should be fixed with the latest version of update-manager in hardy-updates.

Dear michael,

Thanks for fixing the bug. At this moment 3 pc's are running smoothly but I didn't need to upgrade it from 7.10 to 8.04 anymore so it is hard to test it right now. Soon I can install a 7.10 version and try it again. At the time I was facing this problem I was able to fix it by myself. A general solution was needed. Thanks for fixing the bug.

But I discovered something else wrt the update manager on different pc's. Even from friends and family. May be this has something to do with this, may be not.
At a sudden moment we were not able anymore to use the update manager at all!! The update manager hangs and the process need to be killed manually by its processid.
I discovered also why but not the rootcause of this problem.
The file /etc/hosts contains a few things about the localhost. However at 4 different pc's I saw a mistake in the second line of this file. For example:
There was a line called "127.0.1.1 paul-laptop.home" By removing the ".home" the problem appears to be solved.
Please don't ask me why this domain name was filled out but after removing this domainname it is working again.

I you prefer that I make another bugreport from this please let me know.

Best regards,

Paul Willems

---- Michael Vogt <email address hidden> schrijft:
> Thanks for your bugreport.
>
> Could you please retry the upgrade? This should be fixed with the latest
> version of update-manager in hardy-updates.
>
> --
> cannot calculate upgrade
> https://bugs.launchpad.net/bugs/219531
> You received this bug notification because you are a direct subscriber
> of the bug.

KickAssClown (kickassclown) wrote :

I was trying to upgrade from 7.10 Ubuntu following a CD install while under XFCE. (I installed xubuntu-desktop and used synaptic-manager to mark packages for upgrade)

I was given the error message:
Could not calculate the upgrade

A unresolvable problem occurred while calculating the upgrade.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.

KickAssClown (kickassclown) wrote :

More files.

KickAssClown (kickassclown) wrote :

term.log is empty.

Bug was reproduced consistently after system reboot and repeated upgrade attempts.

Dimitrios Symeonidis (azimout) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Dimitrios Symeonidis (azimout) wrote :

Closing as fix released, as per your last comment

Changed in update-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers