dist-upgrade fails if /tmp is non-executable (mounted as noexec)

Bug #219518 reported by François Marier on 2008-04-19
38
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: update-manager

On a Gutsy system where /tmp is non-executable (mounted with the noexec flag), update-manager refuses to upgrade to Hardy with the following error message on the command-line:

  extracting '/tmp/tmp71EIa8/hardy.tar.gz'
  authenticate '/tmp/tmp71EIa8/hardy.tar.gz' against '/tmp/tmp71EIa8/hardy.tar.gz.gpg'
  Traceback (most recent call last):
    File "/usr/lib/python2.5/site-packages/UpdateManager/UpdateManager.py", line 915, in on_button_dist_upgrade_clicked
      fetcher.run()
    File "/usr/lib/python2.5/site-packages/UpdateManager/Core/DistUpgradeFetcherCore.py", line 220, in run
      self.runDistUpgrader()
    File "/usr/lib/python2.5/site-packages/UpdateManager/DistUpgradeFetcher.py", line 51, in runDistUpgrader
      os.execv(self.script,[self.script]+self.run_options)
  OSError: [Errno 13] Permission non accordée

(Note that it works fine when upgrading normal packages.)

I suggest two things:
  1- Check to see if the file can be executed and returning a more user-friendly error message when it isn't.
  2- Create a temporary directory in the current directory as a fallback when /tmp cannot be used.

Of course, it would be nice if it did work (see #2), but I would also consider this problem solved if a nice (graphical) error message was displayed to the user (see #1).

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This is indeed a problem, unfortunately we will not be able to fix it for hardy (too close to the release) but we will add a note into the release-notes.

Changed in update-manager:
importance: Undecided → Medium
milestone: none → later
status: New → Confirmed
kenw (kenw) wrote :

Just a comment - when running the graphical version from a menu it fails silently - the app just disappears and it wasn't until I ran it from a shell that I could see what was wrong.

Changed in update-manager:
status: Confirmed → Triaged
Michael Vogt (mvo) on 2008-07-17
Changed in update-manager:
assignee: nobody → mvo
milestone: later → none
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.91.10

---------------
update-manager (1:0.91.10) intrepid; urgency=low

  * UpdateManager/Core/DistUpgradeFetcherCore.py:
    - improved error handling for people who run
      /tmp with noexec (LP: #219518)
  * DistUpgrade/ReleaseAnnouncement:
    - fixes in the announcement text (thanks to
      Brian Murray, LP: #250693)
  * DistUpgrade/removal_blacklist.cfg:
    - remove nvidia-glx from the removal blacklist,
      the naming schema changed in intrepid and the
      old packages need to go way (LP: #249329)

 -- Michael Vogt <email address hidden> Tue, 22 Jul 2008 12:04:34 +0200

Changed in update-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers