Activity log for bug #2068809

Date Who What changed Old value New value Message
2024-06-08 18:35:01 Tormod Volden bug added bug
2024-06-10 07:01:50 Nathan Teodosio merge proposal linked https://code.launchpad.net/~tormodvolden/update-manager/+git/update-manager/+merge/467152
2024-07-02 11:56:45 Sebastien Bacher update-manager (Ubuntu): status New Fix Committed
2024-07-02 11:56:48 Sebastien Bacher update-manager (Ubuntu): importance Undecided Low
2024-07-02 12:20:35 Sebastien Bacher bug added subscriber Sebastien Bacher
2024-07-02 22:03:58 Launchpad Janitor update-manager (Ubuntu): status Fix Committed Fix Released
2024-07-08 12:05:45 Sebastien Bacher description When clicking on a package from a PPA in update-manager, the "Changes for XXX versions:" section will say: "This update does not come from a source that supports changelogs." and on the console it dumps: ERROR:root:Unable to find a valid PPA candidate URL. The reason is that in _extract_ppa_changelog_uri() in /usr/lib/python3/dist-packages/UpdateManager/Core/MyCache.py it checks only for ppa.launchpad.net but nowadays the URI will contain ppa.launchpadcontent.net instead. With the below patch it will correctly display the changelogs: --- /usr/lib/python3/dist-packages/UpdateManager/Core/MyCache.py.orig 2024-04-16 11:56:33.000000000 +0200 +++ /usr/lib/python3/dist-packages/UpdateManager/Core/MyCache.py 2024-06-08 20:33:51.462435498 +0200 @@ -338,7 +338,7 @@ class MyCache(DistUpgrade.DistUpgradeCac cdt = self[name].candidate for uri in cdt.uris: - if urlsplit(uri).hostname != "ppa.launchpad.net": + if urlsplit(uri).hostname not in ("ppa.launchpad.net", "ppa.launchpadcontent.net"): continue match = re.search("http.*/(.*)/(.*)/ubuntu/.*", uri) if match is not None: * Impact When clicking on a package from a PPA in update-manager, the "Changes for XXX versions:" section will say: "This update does not come from a source that supports changelogs." Which seems a side effect of https://blog.launchpad.net/ppa/new-domain-names-for-ppas , the code filter on ppa.launchpad.net in the url where those are using ppa.launchpadcontent.net now * Test case - enable a ppa including an update for a package you have installed - start update-manager and select that package - check the long description at the bottom it should display the changelog entry for the update * Regression potential The change is in the _extract_ppa_changelog_uri() function so a potential issue would impact updates coming from a ppa. Verify that those are correctly listed and include a valid description ----------------------------------------------- The reason is that in _extract_ppa_changelog_uri() in /usr/lib/python3/dist-packages/UpdateManager/Core/MyCache.py it checks only for ppa.launchpad.net but nowadays the URI will contain ppa.launchpadcontent.net instead. With the below patch it will correctly display the changelogs: --- /usr/lib/python3/dist-packages/UpdateManager/Core/MyCache.py.orig 2024-04-16 11:56:33.000000000 +0200 +++ /usr/lib/python3/dist-packages/UpdateManager/Core/MyCache.py 2024-06-08 20:33:51.462435498 +0200 @@ -338,7 +338,7 @@ class MyCache(DistUpgrade.DistUpgradeCac          cdt = self[name].candidate          for uri in cdt.uris: - if urlsplit(uri).hostname != "ppa.launchpad.net": + if urlsplit(uri).hostname not in ("ppa.launchpad.net", "ppa.launchpadcontent.net"):                  continue              match = re.search("http.*/(.*)/(.*)/ubuntu/.*", uri)              if match is not None: