[7.10 to 8.04 beta] Could not calculate the upgrade

Bug #205205 reported by Pratul Kalia on 2008-03-22
10
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Pratul Kalia

Bug Description

Binary package hint: update-manager

Running 7.10, upgrading to 8.04 beta. Upgrade stops midway and generated the following error...

======
Could not calculate the upgrade

A unresolvable problem occurred while calculating the upgrade.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.
======

Including files in /var/log/dist-upgrade as a tarball in the attachments. Files contained are
- apt.log
- main.log
- term.log

Pratul Kalia (lut4rp) wrote :
Topher (hunt-topher) wrote :

Is this a duplicate of Bug #157763?

Pratul Kalia (lut4rp) wrote :

No I dont think so. Checking the apt.log, I found it breaks due to ubuntustudio-default-settings package. I will try upgrading after removing this package (as it is optional)

KatieQuarles (quarles-katie) wrote :

I'm getting the same message on my vaio vgn-s360, but get different errors in the apt.log

any ideas?

KatieQuarles (quarles-katie) wrote :

the problem seems to have fixed itself. maybe it was a questionable internet connection.

Nick Ellery (nick.ellery) wrote :

Pratul, does this error still take place when upgrading to the stable version of Hardy?

Changed in update-manager:
status: New → Incomplete
Pratul Kalia (lut4rp) wrote :

No, the bug was solved. Actually, it occurs if ubuntu-desktop package is not installed from synaptics. The package was removed in my case as I had used the ubuntu-studio-sounds package. Once, the ubuntu-desktop package is re-selected, the installer gives no error.

Changed in update-manager:
assignee: nobody → lut4rp
status: Incomplete → Invalid
doubledoux (tagudat) wrote :

Hi Pratul,
Still get the same error - none of the recommendation/fixes worked in my case.
Thomas

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers