upgrade-manager -d fails, without configuring packages

Bug #197199 reported by pokkets on 2008-03-01
6
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

also related bug 193879
Yesterday I did a sudo update-manager -d from ubuntu ultimate 1.7, 7.10 with xclient script,gnome, and kde to hardy alpha 5. I had also installed edubuntu,gobuntu enlightenment, ichthux, and gobuntu. Because I am getting a new laptop, I wanted to try and find out about as many distros as I could before I made a permanent installation on the new one. The one I have has windows hardware, including graphics, sound and wireless cards. The ultimate 1.7 had a graphics program envy which because of the windows graphics card would not install the drivers. There is a canon mpc190 program in windows but but windows cannot communicate with it. so it is inactive.I have the system loaded with applications, mainly games, because I wanted to check the range. and I've found some of the best programs by accident.
The upgrade download continued until there were about 20 files to go and gave some forbidden 403 errors. These seemed to be solved when I switched servers. The programs were then installed.
The first suggestion was to send an error report regarding cupsys, there were some pango warnings about georgian fonts. Other failures included things that seemed like hewlett packard program failures, which i thought I could remove intending to install the printer on windows. (I'm letting my brother have this one.) there were things like desktops that were dependent on cupsys. Pulse audio failed I thought because of the sound card. There were also things like ubuntu standard, linux-restricted modules-2.6.24.10-restricted klogd sysklodgd and ubuntu minimal. After 9 hours hardy had had enough and spat the dummy. It refused to clean up after itself and suggested I do it myself. So I decided to play around with it and put it in a tarball when I couldn't get ndiswrapper-1.51 to work -it seemed to work with hardy a3 off the installed off the live disk, but maybe that one wasn't as confused. I'm sure most of these problems will be solved with hardware that isn't so windows biased, but I thought maybe something in the var/log distupgrade will help. The apt.log section of the upfrade is 7000 lines long, but there is a summary in an apt-get install build essential I ran to install the ndiswrapper. It was already installed but it gave me the summary. I've put in the var/log/distUpgrade folder I'm going to archive. I've got hardy in a tgz on another disk if you want anything.

pokkets (pokkets1) wrote :
Parthan SR (parth-technofreak) wrote :

Thanks for filing the bug. But Ubuntu Ultima seems to be a project registered in Launchpad (https://edge.launchpad.net/ubuntu.ultimate) about 8 months ago. Am not sure whether filing a bug in Ubuntu Ultima over Ubuntu will be appropriate. Probably you should use the project's own bug report option (https://edge.launchpad.net/ubuntu.ultimate/+filebug) to report this bug. As this bug doesn't seem to be appropriate for Ubuntu's update-manager, am closing this bug as invalid.

Changed in update-manager:
status: New → Invalid
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please tell me what version of the package "sysv-rc" is installed on your system (you can find this out via synaptic or apt-cache show sysv-rc)?

thanks,
 Michael

pokkets (pokkets1) wrote :

My gutsy system has
sysv-rc 2.86.ds1-38 and
sysv-rc-conf 0.99-6 in case it helps I'll go into Hardy and see what is there
I managed to restore the tar Hardy system, over the original Ultimate 1.7 live disk and boot it on a USB.
I'm still having no luck with the wireless, and I get maybe two chances to change the network preferences before it tells me I am not allowed to do it, but I can keep coming back to gutsy with updates if there are any
I did an apt-get autoremove to get rid of some lib files and cupsys crashed, but as soon as I can work wireless I might be able to get upgrades. Because wireless on hardy is down, I might try wep. I did a copy-paste of the apt-cache show sysv-rc on hardy I'll attach it

pokkets (pokkets1) wrote :

This last comment before the 'bug' is put to sleep. Unless you have any more questions, advice, or directions.
If there are bugs I'll check synaptics for a ubuntu logo I know with what I loaded on my system I was asking for trouble. I'm sure when I get new hardware that isn't locked on windows many 'bugs' will disappear. The hardy system on usb is operational. The fact i can USB boot now seems to have made the bug worthwhile to a point. I'll trim some of the fat from the hardy system. As far as I know Ultimate compiler Thee Mahn has been busy with gutsy. ultimate hardy is way off. There is likely however to be an automatic ubuntu distro upgrade in update-manager when Hardy is released in April, which will be over anything that is a particularly ultimate package. That's what happened when a previous version of ultimate went from feisty to gutsy, before ultimate gutsy was released. Of course there is an ultimate-upgrade icon on the desktop, but as far as I know it's only an icon at the moment. When the upgrade was done, repoubuntu.info source in 3rd party was disabled. When I last looked it was down due to high traffic volume. Meanwhile, I'm foldingproteinsathome. I

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers