Comment 8 for bug 193879

pokkets (pokkets1) wrote :

Maybe this is more than one bug, but I'll leave that with you.
This time debian 4.0r2etch was involved
I've another solved part of the problem I think Xscript can upgrade kde packages unless something in conflict has to be removed, however adept will in a kde session. Adept won't upgrade gnome for the same reason. xscript doesn't want to get involved. I may have invited this with alien upgrades,
Default session is Xscript
This is how it went today
Tried kubuntu upgrade again, after removing envy. It said there was no upgrade, but there were no errors.
reinstalled disks to sources. Left disk sources ticked got another update, packages weren't ticked. 11 I think. Went to kde session, some packages upgraded in adept, reported some packages failed to upgrade. Went into gnome session. 7 packages ticked, busybox, sysvinit, brightside, initramfs-tools, initscripts sysvinit-utils
 sysvinit failed to upgrade, because it tried to overwrite /usr/share/man/man1/mesg.1.gz which is also in package sysvutils
Terminal details:
Errors were encountered while processing /cdrom/pool/main/sysvinit-utils_2.86.ds1_i386.deb
E: Sub-process /usr/bin/dpkg returned error code (1)
the update failed.
Tried again when unmarking svsvinit it auto unmarked sysvinit-utils and init scripts.
Busybox, brightside, and initramfs-tools were updated.
The packages from the debian disk seem to conflict with each other, but I don't need them on my system, they probably aren't supposed to be there.
Once the third party sources are unmarked, the system is up to date