update manager shows wrong number of available updates

Bug #191387 reported by Data on 2008-02-12
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

This bug happens to me on an up-to-date version of Hardy alpha 4.

Steps to reproduce:
- Do not install all available updates (In my case, there were 4 packages I didn't update).
- Close update-manager and wait until more updates become available.
- Then start update-manager again and click on "Check" to check for new updates.
- When new updates are available, update-manager will show them correctly, however,
the heading still says "You can install 4 updates" although a lot more updates are available. (Of course, the 4 comes from the 4 updates being available previously)

Data (ubuntuaddress) wrote :

Here is a screenshot of update-manager showing a lot of updates but says "You can install 4 updates"

Murat Gunes (mgunes) wrote :

Thanks for your report. I've marked it as a duplicate of bug #105644, which has been previously reported. If you can provide information that it's not actually the same bug even though the symptoms are the same, please unmark it as a duplicate.

Data (ubuntuaddress) wrote :

Thanks Murat, I hadn't actually found that other bug report before. However, after reading it carefully I have come to the conclusion that this bug is not the same as bug #105644.

Bug #105644 is about update-manager showing a number of updates that is TOO HIGH due to further dependencies being counted but not shown in the list of updates.

This Bug, however, is about the number of updates being TOO LOW because it is not refreshed after further updates have become available.

So, I hope it is OK, if I unmark it as a duplicate. If you still think it's the same bug, you'll have to mark it again as duplicate (and I would probably have to apologize for causing you inconveniences ;-) )

Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in update-manager:
status: New → Incomplete
Data (ubuntuaddress) wrote :

Well, I do not know, if that bug still occurs, as it is not trivial to trigger it (Steps to reproduce are above). I will, however test it within the next few days (as soon as new updates become available).

Data (ubuntuaddress) wrote :

Just unsuccessfully tried to trigger the bug again with the latest version of ubuntu jaunty alpha 3. I am not a 100% sure that the bug is gone for good, but I guess that's enough evidence to close the bug report. If I encounter the bug again anytime soon, I will re-open the bureport.

Changed status from Incomplete to Fix Released.

Changed in update-manager:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers