update-manager: clicks do not toggle checkboxes for "Remove old kernels"

Bug #1912718 reported by Mingun
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Fix Released
High
William Wilson
Focal
Fix Released
Undecided
William Wilson
Groovy
Fix Released
Undecided
William Wilson
Hirsute
Fix Released
High
William Wilson

Bug Description

[Impact]
This is a regression from bug 1902025, causing kernels to not be autoremove{d,able} anymore

[Test case]

Have system with old kernels around.

Check that kernels are listed as auto removable in update-manager.

[Where problems could occur]
Clean revert of 1902025, so will revert us to the state from before that

[Original bug report]
Before introducing bug https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1910556 that bug didn't exist -- I can toggle these checkboxes and they will checked by default.

After fix of https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1910556 checkboxes for "Remove old kernels" are not checked anymore by default and I can't check them. If I run update-manager from console, nothing logged.

Screenshot and video when I trying to click on checkboxes attached.

System info:
$ lsb_release -rd
Description: Ubuntu 20.04.1 LTS
Release: 20.04
$ LANG=C apt-cache policy update-manager update-manager-core
update-manager:
  Installed: 1:20.04.10.3
  Candidate: 1:20.04.10.3
  Version table:
 *** 1:20.04.10.3 500
        500 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
        500 http://ru.archive.ubuntu.com/ubuntu focal-updates/main i386 Packages
        500 http://ru.archive.ubuntu.com/ubuntu focal-proposed/main amd64 Packages
        500 http://ru.archive.ubuntu.com/ubuntu focal-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:20.04.9 500
        500 http://ru.archive.ubuntu.com/ubuntu focal/main amd64 Packages
        500 http://ru.archive.ubuntu.com/ubuntu focal/main i386 Packages
update-manager-core:
  Installed: 1:20.04.10.3
  Candidate: 1:20.04.10.3
  Version table:
 *** 1:20.04.10.3 500
        500 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
        500 http://ru.archive.ubuntu.com/ubuntu focal-updates/main i386 Packages
        500 http://ru.archive.ubuntu.com/ubuntu focal-proposed/main amd64 Packages
        500 http://ru.archive.ubuntu.com/ubuntu focal-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:20.04.9 500
        500 http://ru.archive.ubuntu.com/ubuntu focal/main amd64 Packages
        500 http://ru.archive.ubuntu.com/ubuntu focal/main i386 Packages

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: update-manager 1:20.04.10.3
ProcVersionSignature: Ubuntu 5.4.0-59.65-generic 5.4.78
Uname: Linux 5.4.0-59-generic x86_64
NonfreeKernelModules: qnx4 hfsplus hfs minix ntfs jfs intel_rapl_msr intel_rapl_common x86_pkg_temp_thermal intel_powerclamp coretemp snd_hda_codec_realtek snd_hda_codec_generic ledtrig_audio snd_hda_codec_hdmi snd_hda_intel snd_intel_dspcfg snd_hda_codec snd_hda_core i915 mei_hdcp rapl intel_cstate mei_me eeepc_wmi mei asus_wmi sparse_keymap wmi_bmof mac_hid r8169 lpc_ich realtek i2c_i801 wmi
ApportVersion: 2.20.11-0ubuntu27.14
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: GNOME
Date: Fri Jan 22 09:21:11 2021
InstallationDate: Installed on 2020-11-24 (58 days ago)
InstallationMedia: Ubuntu 18.04.3 LTS "Bionic Beaver" - Release amd64 (20190805)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: Upgraded to focal on 2020-11-25 (57 days ago)

Related branches

Revision history for this message
Mingun (alexander-sergey) wrote :
Revision history for this message
Mingun (alexander-sergey) wrote :
tags: added: rls-ff-incoming
tags: added: regression-update
Revision history for this message
Julian Andres Klode (juliank) wrote :

This is a regression from bug 1902025

Changed in update-manager (Ubuntu):
importance: Undecided → High
Changed in update-manager (Ubuntu Hirsute):
status: New → Fix Committed
Changed in update-manager (Ubuntu Groovy):
status: New → In Progress
Changed in update-manager (Ubuntu Focal):
status: New → In Progress
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Mingun, or anyone else affected,

Accepted update-manager into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.10.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Groovy):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-groovy
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Mingun, or anyone else affected,

Accepted update-manager into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.04.10.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
Julian Andres Klode (juliank) wrote :

I installed some old kernels on focal live disc, marked them auto, started update-manager, and I saw a non-selectable Ubuntu base section below the autoremovable kernel headline.

Updating update-manager to 1:20.04.10.4 from proposed makes it work again

description: updated
tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (update-manager/1:20.04.10.4)

All autopkgtests for the newly accepted update-manager (1:20.04.10.4) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

ubuntu-release-upgrader/1:20.04.30 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#update-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Mingun, or anyone else affected,

Accepted update-manager into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.04.10.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed-focal
removed: verification-done-focal
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (update-manager/1:20.04.10.4)

All autopkgtests for the newly accepted update-manager (1:20.04.10.4) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

ubuntu-release-upgrader/1:20.04.30 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#update-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:21.04.6

---------------
update-manager (1:21.04.6) hirsute; urgency=medium

  * Avoid crash from OEM enablement when using synaptic backend
  * Revert 21.04.5, 21.04.4, and 21.04.3 changes, except the livepatch
    dialog stuff. (LP: #1912718)

 -- Julian Andres Klode <email address hidden> Fri, 29 Jan 2021 12:41:16 +0100

Changed in update-manager (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Julian Andres Klode (juliank) wrote :

We verified that bit in #6, the change in .5 is very isolated in the oem function, so not re-verifying

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Julian Andres Klode (juliank) wrote :

Actually did reverify it after all :)

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.10.4

---------------
update-manager (1:20.10.4) groovy; urgency=medium

  * Revert to 1:20.10.1 (LP: #1912718)

 -- Julian Andres Klode <email address hidden> Fri, 29 Jan 2021 12:53:08 +0100

Changed in update-manager (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for update-manager has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.04.10.5

---------------
update-manager (1:20.04.10.5) focal; urgency=medium

  * UpdateManager/backend/__init__.py: Really make commit_oem a no-op in the
    base class to avoid crash when people force synaptic backend (LP: #1913732)
  * Fix typo in previous changelog

update-manager (1:20.04.10.4) focal; urgency=medium

  * Revert previous change to UpdateList.py, as it breaks kernel
    autoremoval (LP: #1912718)
  * UpdateManager/backend/__init__.py: Make commit_oem a no-op in the base
    class to avoid crash when people force synaptic backend (LP: #1913732)

 -- Julian Andres Klode <email address hidden> Fri, 29 Jan 2021 17:43:01 +0100

Changed in update-manager (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Robie Basak (racb) wrote :

I found myself affected by this. I had 1:20.04.10.3 presumably because update-manager 1:20.04.10.5 is phased at 50%. Fixed manually:

Upgrade: update-manager-core:amd64 (1:20.04.10.3, 1:20.04.10.5), update-manager:amd64 (1:20.04.10.3, 1:20.04.10.5), python3-update-manager:amd64 (1:20.04.10.3, 1:20.04.10.5)

So the fix looks good to me too, and will be resolved for everyone when phasing hits 100%. Thanks!

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Mingun, or anyone else affected,

Accepted update-manager into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.10.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Groovy):
status: Fix Released → Fix Committed
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Mingun, or anyone else affected,

Accepted update-manager into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.04.10.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Focal):
status: Fix Released → Fix Committed
tags: added: verification-needed-focal
removed: verification-done-focal
Revision history for this message
William Wilson (jawn-smith) wrote :

The verification passed for focal. The portion of the image highlighted in green shows that the check boxes are working for kernel packages staged for autoremoval.

Revision history for this message
William Wilson (jawn-smith) wrote :

The verification passed for groovy. The attached image shows that the check boxes are working for kernel packages staged for autoremoval.

tags: added: verification-done verification-done-focal verification-done-groovy
removed: verification-needed verification-needed-focal verification-needed-groovy
Changed in update-manager (Ubuntu Focal):
assignee: nobody → William Wilson (jawn-smith)
Changed in update-manager (Ubuntu Groovy):
assignee: nobody → William Wilson (jawn-smith)
Changed in update-manager (Ubuntu Hirsute):
assignee: nobody → William Wilson (jawn-smith)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.10.5

---------------
update-manager (1:20.10.5) groovy; urgency=medium

  * UpdateManager/Core/UpdateList.py: change to a regex from a static list
    of packages to be grouped under Ubuntu Base (LP: #1902025)
  * Clean up apt cache binary files left behind by tests
  * Rename meta_pkgs to ubuntu_base_pkgs to make it more clear to the
    reader which packages should be included
  * Add tests in to ensure Ubuntu base packages are not grouped when
    staged for removal (LP: #1912718)
  * Fix crash caused by adding apt package objects to a list of
    strings (LP: #1913476)

 -- William 'jawn-smith' Wilson <email address hidden> Wed, 10 Feb 2021 14:22:58 -0600

Changed in update-manager (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.04.10.6

---------------
update-manager (1:20.04.10.6) focal; urgency=medium

  * UpdateManager/Core/UpdateList.py: change to a regex from a static list
    of packages to be grouped under Ubuntu Base (LP: #1902025)
  * Clean up apt cache binary files left behind by tests
  * Rename meta_pkgs to ubuntu_base_pkgs to make it more clear to the
    reader which packages should be included
  * Add tests in to ensure Ubuntu base packages are not grouped when
    staged for removal (LP: #1912718)

 -- William 'jawn-smith' Wilson <email address hidden> Wed, 10 Feb 2021 14:39:27 -0600

Changed in update-manager (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers