hwe kernel not scoped under "Ubuntu Base"

Bug #1902025 reported by Dimitri John Ledkov
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Fix Released
Low
William Wilson
Focal
Fix Released
Medium
William Wilson
Groovy
Fix Released
Medium
William Wilson
Hirsute
Fix Released
Low
William Wilson

Bug Description

linux-image-generic-hwe-20.04
linux-headers-generic-hwe-20.04
linux-generic-hwe-20.04

Are all listed as standalone updates in update manager, instead they should be grouped under Ubuntu Base.

[Impact]

 * When running update-manager, hwe kernel packages and some other
   kernel packages were not appearing under Ubuntu Base as they should

 * This was causing the section "Other Updates" to appear cluttered

 * Backporting to stable releases because of the visual impact to users

[Test Case]

 * If no updates for kernel related packages are available, downgrade some
   kernel related packages such as the hwe packages listed in this bug
   report

 * Run update-manager and observe that the kernel packages are not
   grouped under Ubuntu Base

[Where problems could occur]

 * Packages that don't belong under Ubuntu Base could be grouped under
   Ubuntu Base if the new regex is too generic.

 * Packages that do belong under Ubuntu Base could be missed if the regex
   does not account for them

[Other info]

 * In the future it would be best if new packages do not begin with the
   string "linux-" unless they are related to the kernel. This will
   prevent these packages from being accidentally grouped under
   Ubuntu Base

 * Currently there are a few "linux-*" packages that do not belong under
   Ubuntu Base, such as linux-show-player and linux-sound-base.

Related branches

Revision history for this message
Dimitri John Ledkov (xnox) wrote :
tags: added: champagne
Changed in update-manager (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
Brian Murray (brian-murray) wrote :

See _get_linux_packages() in UpdateManager/Core/UpdateList.py, there are no versioned kernel packages or hwe packages in there.

Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
tags: added: fr-897
tags: removed: champagne
Changed in update-manager (Ubuntu Hirsute):
assignee: nobody → William Wilson (jawn-smith)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:21.04.3

---------------
update-manager (1:21.04.3) hirsute; urgency=medium

  [ Brian Murray ]
  * UpdateManager/Dialogs.py: do not mention livepatch settings when the
    interface is not installed, thanks to Sebastien Bacher for the patch.
    (LP: #1807900)
  * UpdateManager/backend/__init__.py: Resolve unbound local error crash with
    oem package lists. Thanks to Thomas Bechtold for the patch.

  [ William Wilson ]
  * UpdateManager/Core/UpdateList.py: change to a regex from a static list
    of packages to be grouped under Ubuntu Base (LP: #1902025)

 -- Brian Murray <email address hidden> Fri, 08 Jan 2021 08:41:47 -0800

Changed in update-manager (Ubuntu Hirsute):
status: Triaged → Fix Released
Changed in update-manager (Ubuntu Focal):
status: New → Triaged
Changed in update-manager (Ubuntu Groovy):
status: New → Triaged
Changed in update-manager (Ubuntu Focal):
milestone: none → focal-updates
importance: Undecided → Medium
Changed in update-manager (Ubuntu Groovy):
importance: Undecided → Medium
description: updated
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

A thing to note: the current regex will also match packages like linux-firmware-raspi2. But then again, I think this still fits in the Ubuntu Base section.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Also, I'm always a bit confused with update-manager's versioning scheme, since for instance for focal it's 20.04.10.x, where sometimes (like for groovy) it continues using the 20.10.x base versioning. But I assume you as the maintainers know best which versioning is the correct one.

Changed in update-manager (Ubuntu Groovy):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-groovy
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Dimitri, or anyone else affected,

Accepted update-manager into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Dimitri, or anyone else affected,

Accepted update-manager into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.04.10.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
William Wilson (jawn-smith) wrote :

The verification passed for groovy. This image shows the initial bug, installation of the proposed package, and the bug fixed afterwards

Revision history for this message
William Wilson (jawn-smith) wrote :

The verification passed for focal.

This image shows the initial bug, installation of the proposed package, and the bug fixed afterwards. In addition to showing that the hwe packages are scoped under Ubuntu Base, it also shows the following other kernel packages being re-scoped under Ubuntu base:

Header files related to Linux kernel version 5.8.0
Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
Linux kernel headers for version 5.8.0 on 64 bit x86 SMP
Signed kernel image generic

The non kernel related packages from the "Other updates" section such as PAM modules and language packs for Thunderbird are not re-scoped under Ubuntu Base, as expected

tags: added: verification-done verification-done-focal verification-done-groovy
removed: verification-needed verification-needed-focal verification-needed-groovy
Revision history for this message
William Wilson (jawn-smith) wrote :

This image demonstrates that the linux-show-player package mentioned earlier is not grouped under Ubuntu Base, as expected.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.10.2

---------------
update-manager (1:20.10.2) groovy; urgency=medium

  * UpdateManager/Core/UpdateList.py: change to a regex from a static list
    of packages to be grouped under Ubuntu Base (LP: #1902025)

 -- William Wilson <email address hidden> Wed, 13 Jan 2021 08:35:34 -0600

Changed in update-manager (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for update-manager has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.04.10.3

---------------
update-manager (1:20.04.10.3) focal; urgency=medium

  [ Julian Andres Klode ]
  * UpdateManager/backend/__init__.py: Fix unbound local variables regression
    introduced by the previous SRU (See LP 1910556), and correct comment

  [ William Wilson ]
  * UpdateManager/Core/UpdateList.py: change to a regex from a static list
    of packages to be grouped under Ubuntu Base (LP: #1902025)

update-manager (1:20.04.10.2) focal; urgency=medium

  [ Iain Lane & Julian Andres Klode ]
  * Support post install enablement of OEM-enabled devices (LP: #1908050)

 -- Brian Murray <email address hidden> Wed, 13 Jan 2021 08:35:58 -0800

Changed in update-manager (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Julian Andres Klode (juliank) wrote :

This update caused a regression in bug 1912718 as it now matches versioned kernel packages, whereas it only should match meta packages, causing there to be a group in the autoremovable kernel section which prevents things from being clicked.

Revision history for this message
Julian Andres Klode (juliank) wrote :

Reverting this change, so setting the bug back to triaged.

Changed in update-manager (Ubuntu Hirsute):
status: Fix Released → Triaged
Changed in update-manager (Ubuntu Focal):
status: Fix Released → Triaged
Changed in update-manager (Ubuntu Groovy):
status: Fix Released → Triaged
Changed in update-manager (Ubuntu Groovy):
assignee: nobody → William Wilson (jawn-smith)
Changed in update-manager (Ubuntu Focal):
assignee: nobody → William Wilson (jawn-smith)
tags: removed: verification-done verification-done-focal verification-done-groovy
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:21.04.8

---------------
update-manager (1:21.04.8) hirsute; urgency=medium

  [ Brian Murray ]
  * Clean up apt cache binary files created by the unit tests thanks to
    William Wilson for the patch.

  [ William Wilson ]
  * Changing to a regex from a static list of packages to be included under
    "Ubuntu Base". This regex expands the list of packages under "Ubuntu Base"
    to include all kernel packages as well as binary packages built by
    linux-meta source packages (LP: #1902025)

 -- Brian Murray <email address hidden> Thu, 04 Feb 2021 10:42:55 -0800

Changed in update-manager (Ubuntu Hirsute):
status: Triaged → Fix Released
Revision history for this message
William Wilson (jawn-smith) wrote :

Attached is an SRU for groovy. It groups all kernel packages under Ubuntu base while safely avoiding the issues in LP: #1912718 and LP: #1913476. It also introduces a new test for the scenario in LP: #1912718 and cleans up binary files left behind by tests.

Revision history for this message
Brian Murray (brian-murray) wrote :

I've sponsored the groovy debdiff for review by the SRU team.

Revision history for this message
William Wilson (jawn-smith) wrote :

Attached is an SRU for focal. It groups all kernel packages under Ubuntu base while safely avoiding the issues in LP: #1912718 and LP: #1913476. It also introduces a new test for the scenario in LP: #1912718 and cleans up binary files left behind by tests.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

eh, this SRU seems to be missing the reference to LP: #1913476 in its .changes, even though the fix for it is included. Will reject and re-upload with a modified changelog (+ accept). Please be sure to include all bug links in the changelog.

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Dimitri, or anyone else affected,

Accepted update-manager into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.10.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Groovy):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-groovy
Revision history for this message
Brian Murray (brian-murray) wrote : Re: [Bug 1902025] Re: hwe kernel not scoped under "Ubuntu Base"

On Mon, Feb 15, 2021 at 01:13:12PM -0000, Łukasz Zemczak wrote:
> eh, this SRU seems to be missing the reference to LP: #1913476 in its
> .changes, even though the fix for it is included. Will reject and re-
> upload with a modified changelog (+ accept). Please be sure to include
> all bug links in the changelog.

This bug wasn't included because it is a consequence of the code fixing
bug 1902025 being incorrect and since the fix for that bug never landed
in Groovy including it seemed unnecessary to me.

--
Brian Murray

Revision history for this message
Brian Murray (brian-murray) wrote :

I've sponsored the focal debdiff without the reference to 1913476 for the reasons I've stated in comment #22.

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Dimitri, or anyone else affected,

Accepted update-manager into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.04.10.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
William Wilson (jawn-smith) wrote :

The verification passed for focal. The attached image shows linux kernel packages not grouped under Ubuntu base with version 1:20.04.10.5, and the packages correctly grouped with version 1:20.04.10.6. The section highlighted in green shows that the kernel packages are not grouped under "Unused kernel updates to be removed" and that the check boxes are functional. This demonstrates that the regression in LP: #1912718 is not present in version 1:20.04.10.6.

Revision history for this message
William Wilson (jawn-smith) wrote :

The verification passed for groovy. The attached image shows linux kernel packages not grouped under Ubuntu base with version 1:20.10.4, and the packages correctly grouped with version 1:20.10.5.

tags: added: verification-done verification-done-focal verification-done-groovy
removed: verification-needed verification-needed-focal verification-needed-groovy
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.10.5

---------------
update-manager (1:20.10.5) groovy; urgency=medium

  * UpdateManager/Core/UpdateList.py: change to a regex from a static list
    of packages to be grouped under Ubuntu Base (LP: #1902025)
  * Clean up apt cache binary files left behind by tests
  * Rename meta_pkgs to ubuntu_base_pkgs to make it more clear to the
    reader which packages should be included
  * Add tests in to ensure Ubuntu base packages are not grouped when
    staged for removal (LP: #1912718)
  * Fix crash caused by adding apt package objects to a list of
    strings (LP: #1913476)

 -- William 'jawn-smith' Wilson <email address hidden> Wed, 10 Feb 2021 14:22:58 -0600

Changed in update-manager (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.04.10.6

---------------
update-manager (1:20.04.10.6) focal; urgency=medium

  * UpdateManager/Core/UpdateList.py: change to a regex from a static list
    of packages to be grouped under Ubuntu Base (LP: #1902025)
  * Clean up apt cache binary files left behind by tests
  * Rename meta_pkgs to ubuntu_base_pkgs to make it more clear to the
    reader which packages should be included
  * Add tests in to ensure Ubuntu base packages are not grouped when
    staged for removal (LP: #1912718)

 -- William 'jawn-smith' Wilson <email address hidden> Wed, 10 Feb 2021 14:39:27 -0600

Changed in update-manager (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers