version upgrade fails without a warning if a package is kept

Bug #188797 reported by TimBaldwin on 2008-02-04
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

As the title says: if a package is kept, the version upgrade process (both through the update-manager gui and from do-release-upgrade) fails without providing the user with any useful explanation...

Instead, you should get something like:
"Package xyz is kept back on your system, which makes a version upgrade impossible. Please unlock this package and start the upgrade process again."

TimBaldwin (tbaldwin) wrote :

Actually, let me attach a tarball containing the contents of /usr/share/update-manager.

Tim

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please include the logs from /var/log/dist-upgrade ?

Thanks,
 Michael

Changed in update-manager:
status: New → Incomplete
Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in update-manager:
status: Incomplete → Invalid
TimBaldwin (tbaldwin) wrote :

Apologies -- I had replied to your question via email thinking that it would be reflected back onto the forum, but clearly it is a one-way street from forum to email but not the other way (no doubt this is documented somewhere had I thought to check).

Ah, so there is more logging I could have use to troubleshoot the problem
myself. See attached for a tarball containing all files in that directory. A
quick grep turned up:

# grep -i error /var/log/dist-upgrade/*
/var/log/dist-upgrade/apt.log:Installing libgpg-error0 as dep of libxslt1.1
/var/log/dist-upgrade/apt.log:Installing liberror-perl as dep of twiki
/var/log/dist-upgrade/apt.log:ERROR:root:IOError in cache.commit(): 'Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gimp/gimp_2.2.13-1ubuntu4.3_amd64.deb Could not resolve 'security.ubuntu.com'
/var/log/dist-upgrade/apt.log:ERROR:root:IOError in cache.commit(): 'Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gimp/gimp_2.2.13-1ubuntu4.3_amd64.deb Could not resolve 'security.ubuntu.com'
/var/log/dist-upgrade/apt.log:ERROR:root:IOError in cache.commit(): 'Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gimp/gimp_2.2.13-1ubuntu4.3_amd64.deb Could not resolve 'security.ubuntu.com'
/var/log/dist-upgrade/apt.log:ERROR:root:giving up on fetching after maximum retries
/var/log/dist-upgrade/apt.log:ERROR:root:gor error from PostInstallScript ./apt-autoinst-fixup.py ([Errno 2] No such file or directory: './apt-autoinst-fixup.py')
/var/log/dist-upgrade/main.log:2008-02-04 11:47:28,544 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

Thanks,

Tim

Brian Murray (brian-murray) wrote :

This may have something to do with packages you have installed from feisty-backports. I am confirming this for you. I did notice this your logs - "2008-02-04 11:47:28,544 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'"

Changed in update-manager:
importance: Undecided → Medium
status: Invalid → Confirmed
TimBaldwin (tbaldwin) wrote :

Aha -- nfs-common was held back (because of a change in dependencies), which was holding the whole upgrade back. After updating that one package, the whole upgrade process went through fine (other than a slight hiccough with xscreensaver locking me out out my X session, but nothing too traumatic).

Thanks very much for all your help.

Tim

Dimitrios Symeonidis (azimout) wrote :

I still think the update-manager should warn you about the reason it failed to upgrade your system...

description: updated
Changed in update-manager:
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers