[SRU] AptUrl GTK window stuck on screen after install completed

Bug #1874591 reported by jkelol111 [Nam] on 2020-04-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Marcus Tomlinson
Focal
High
Marcus Tomlinson

Bug Description

[Impact]

After installing a package from an AptURL, the apturl-gtk window remains stuck on screen in greyed out state. Clicking the close button does nothing.

Screenshot is attached below.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: apturl 0.5.2ubuntu19
ProcVersionSignature: Ubuntu 5.4.0-26.30-generic 5.4.30
Uname: Linux 5.4.0-26-generic x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Fri Apr 24 09:51:36 2020
InstallationDate: Installed on 2020-04-22 (1 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
SourcePackage: apturl
UpgradeStatus: Upgraded to focal on 2020-04-23 (0 days ago)

[Test Case]

- Use an AptURL (like apt:chromium-browser)
- apturl-gtk launches, and prompts for app installation
- I click install and enter my credentials
- A window pops up with the download and install progress
- Installation for the package completes and the install progress window disappears
- The apturl-gtk window is greyed out and stuck.

[Regression Potential]

The fix consists of a couple hasattr() safety checks (see linked branch). These ensure that snap updates occur only in the updater and not in other dialogs such as the apturl installer. I'd say regression potential is relatively low. There are only a couple of use cases effected here and I've tested them thoroughly.

Related branches

jkelol111 [Nam] (jkelol111) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?
* Could you add your 'journalctl -b 0' log after getting the issue?

This will help us to find and resolve the problem.

Changed in apturl (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
jkelol111 [Nam] (jkelol111) wrote :

1. I could reproduce it again with chromium-browser (apt:chromium-browser), which suggests this issue isn't one-off

2. Steps:
- Use an AptURL (like apt:chromium-browser)
- apturl-gtk launches, and prompts for app installation
- I click install and enter my credentials
- A window pops up with the download and install progress
- Installation for the package completes and the install progress window disappears
- The apturl-gtk window is greyed out and stuck.

3. journalctl logs pertaining the installation progress attached.

jkelol111 [Nam] (jkelol111) wrote :

The stuck window for apt:chromium-browser attached.

Sebastien Bacher (seb128) wrote :

Thanks! The log has that error

 File "/usr/lib/python3/dist-packages/UpdateManager/backend/__init__.py", line 232, in update_status
GLib.idle_add(self.label_details.set_label, status)
AttributeError: 'InstallBackendAptdaemon' object has no attribute 'label_details'

Which is likely the issue

Changed in apturl (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Confirmed by doing (random app example)

$ xdg-open apt:gtranslator

The code seems to have been added in r2865 / https://code.launchpad.net/~marcustomlinson/update-manager/update-manager/+merge/380060

Changed in apturl (Ubuntu):
status: New → Confirmed
assignee: nobody → Marcus Tomlinson (marcustomlinson)
Changed in apturl (Ubuntu):
status: Confirmed → In Progress
summary: - AptUrl GTK window stuck on screen after install completed
+ [SRU] AptUrl GTK window stuck on screen after install completed
description: updated
Changed in apturl (Ubuntu):
importance: Low → High
Changed in update-manager (Ubuntu):
importance: Undecided → High
assignee: nobody → Marcus Tomlinson (marcustomlinson)
status: New → In Progress
no longer affects: apturl (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.04.12

---------------
update-manager (1:20.04.12) groovy; urgency=medium

  * Fix hang in apturl-gtk. (LP: #1874591)
  * Fix crash in snap updates when refreshing the cache fails. (LP: #1880987)

 -- Marcus Tomlinson <email address hidden> Thu, 28 May 2020 10:11:51 +0100

Changed in update-manager (Ubuntu):
status: In Progress → Fix Released
Changed in update-manager (Ubuntu Focal):
assignee: nobody → Marcus Tomlinson (marcustomlinson)
importance: Undecided → High
status: New → In Progress
Changed in update-manager (Ubuntu Eoan):
status: New → Confirmed
Changed in update-manager (Ubuntu Bionic):
status: New → Confirmed
Changed in update-manager (Ubuntu Eoan):
status: Confirmed → Invalid
Changed in update-manager (Ubuntu Bionic):
status: Confirmed → Invalid
no longer affects: update-manager (Ubuntu Eoan)
no longer affects: update-manager (Ubuntu Bionic)

Hello jkelol111, or anyone else affected,

Accepted update-manager into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.04.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Brian Murray (brian-murray) wrote :

I tested this using update-manager version 1:20.04.10 and installed chromium-browser via the apt url in the bug report. After the installation completed the apturl-gtk dialog went away.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Łukasz Zemczak (sil2100) wrote :

I suppose you meant 1:20.04.10.1, right? Since 1:20.04.10 is the current version in the release pocket. Since I trust your verification, I assume it was just a typo.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.04.10.1

---------------
update-manager (1:20.04.10.1) focal; urgency=medium

  * UpdateManager/UpdateManager.py: when refreshing the cache and encountering
    an error return rather than trying to use the undefined cache which causes
    crashes. Additionally, don't present the dialog with a "Try Again" button
    which won't do anything. (LP: #1826213)
  * Fix hang in apturl-gtk. (LP: #1874591)
  * Fix crash in snap updates when refreshing the cache fails. (LP: #1880987)

 -- Brian Murray <email address hidden> Wed, 03 Jun 2020 10:18:00 -0700

Changed in update-manager (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers