[SRU] update-manger intermittently hangs during snap updates

Bug #1874469 reported by Marcus Tomlinson on 2020-04-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Marcus Tomlinson
Focal
High
Marcus Tomlinson

Bug Description

[Impact]

Every so often update-manager can hang during snap updates. When this occurs the application must be force closed.

[Test Case]

Repeating the following will eventually cause a hang on "Installing snap-store snap".

`
sudo apt -y install gnome-software
sudo apt-mark auto gnome-software

snap remove snap-store

update-manager
`

[Regression Potential]

The fix is trivial (see linked branch), in fact, GLib.idle_add() was applied correctly elsewhere, it was just missed here.

Related branches

Changed in update-manager (Ubuntu):
status: New → In Progress
assignee: nobody → Marcus Tomlinson (marcustomlinson)
importance: Undecided → High
description: updated

Hello Marcus, or anyone else affected,

Accepted update-manager into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.04.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal

I've upgraded update-manager from 1:20.04.9 to 1:20.04.10 in an up-to-date focal amd64 VM, and have verified that the issue is resolved.

tags: added: verification-done-focal
removed: verification-needed-focal
Mathew Hodson (mhodson) on 2020-04-24
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.04.10

---------------
update-manager (1:20.04.10) focal; urgency=medium

  * Fix intermittent hang during snap updates (LP: #1874469).

 -- Marcus Tomlinson <email address hidden> Thu, 23 Apr 2020 16:14:21 +0100

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
Changed in update-manager (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers