Do not offer an upgrade from i386 systems

Bug #1845690 reported by Brian Murray
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned
Bionic
High
Unassigned
Focal
Undecided
Unassigned
update-manager (Ubuntu)
High
Brian Murray
Bionic
High
Brian Murray
Focal
High
Brian Murray

Bug Description

Impact
------
Ubuntu 18.04 users on a system with a host architecture of i386 will be offered to upgrade to Ubuntu 20.04 only to later be told by ubuntu-release-upgrader that they can not upgrade to 20.04. Rather than have people experience this we'd like to SRU update-manager to notify users of the fact that they will not be able to upgrade to 20.04.

Test Case
---------
1) On an 18.04 i386 system set Prompt=lts in /etc/update-manager/release-upgrades
2) run update-manager -d
3) observe a notification about a new release of ubuntu and see the release announcement
4) start the upgrade and observe a dialog telling you that you system can't upgrade
5) wonder why you wasted so much time trying to upgrade

With the version of update-manager in -proposed you will instead be immediately presented with a dialog that says "Sorry, there are no more upgrades for this system".

Regression Potential
--------------------
While not strictly speaking a regression this dialog is not translated but we think it is better that be notified that there are no upgrades rather than being lead to believe that they can upgrade only to be told no.

Original Description
--------------------
Given that there will not be a full set of i386 packages for Ubuntu 19.10 and that it will not be possible to upgrade to Ubuntu 19.10 it'd be best if the new release dialog were not displayed for systems with an apt architecture of i386. The message should indicate how long they will continue to receive updates for and present information about reinstalling using amd64 (if that's possible). These changes will need to SRU'ed to both Ubuntu 18.04 and Ubuntu 19.04.

Related branches

Revision history for this message
Brian Murray (brian-murray) wrote :

One way to present this information would be to create a new class of Dialog in UpdateManager/Dialogs.py which is raised, from UpdateManager/UpdateManager.py, if the apt architecture is i386.

tags: added: bionic disco
Changed in update-manager (Ubuntu):
status: New → Triaged
importance: Undecided → High
tags: added: id-5d8e3e863fa74665c1f0b314
Revision history for this message
Matthew Paul Thomas (mpt) wrote :
Changed in update-manager (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
Revision history for this message
Brian Murray (brian-murray) wrote :

While the additional dialog will not show up in update-manager on systems running 20.04 (because we have no install media for i386 and ubuntu-release-upgrader already prevents i386 users from upgrading) I have emailed the ubuntu-translators list regarding the additional strings be added.

https://lists.ubuntu.com/archives/ubuntu-translators/2020-April/007630.html

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.04.4

---------------
update-manager (1:20.04.4) focal; urgency=medium

  * Fix pycodestyle and pyflakes autopkgtests.

 -- Marcus Tomlinson <email address hidden> Tue, 07 Apr 2020 14:26:10 +0100

Changed in update-manager (Ubuntu Focal):
status: In Progress → Fix Released
description: updated
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Brian, or anyone else affected,

Accepted update-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:18.04.11.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Revision history for this message
Brian Murray (brian-murray) wrote :

I tested this using update-manager version 1:18.04.11.11 from bionic-proposed and I immediately received the message about no more upgrades being available for the system. See the attached screenshot for proof!

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (update-manager/1:18.04.11.11)

All autopkgtests for the newly accepted update-manager (1:18.04.11.11) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

update-manager/1:18.04.11.11 (ppc64el, amd64, armhf, s390x, arm64, i386)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#update-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Brian, or anyone else affected,

Accepted update-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:18.04.11.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
removed: verification-done verification-done-bionic
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (update-manager/1:18.04.11.11)

All autopkgtests for the newly accepted update-manager (1:18.04.11.11) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

update-manager/1:18.04.11.11 (amd64, i386, ppc64el, arm64, s390x, armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#update-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Brian Murray (brian-murray) wrote :

I tested this again using update-manager version 1:18.04.11.12 from bionic-proposed and I immediately received the message about no more upgrades being available for the system. See the attached screenshot for proof!

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:18.04.11.12

---------------
update-manager (1:18.04.11.12) bionic; urgency=medium

  * Resolve pep8 failures.

update-manager (1:18.04.11.11) bionic; urgency=medium

  * UpdateManager/UpdateManager.py: Do not offer to upgrade systems running on
    an i386 host architecture to another release. (LP: #1845690)

 -- Brian Murray <email address hidden> Tue, 21 Apr 2020 07:27:24 -0700

Changed in update-manager (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for update-manager has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Chris Guiver (guiverc) wrote :

I just booted a Lubuntu 18.04.5 (i386) QA-test install for support & testing purposes.

(QA) Install was performed 2020-Sept-08, but on login the first pop-up was an offer to upgrade the system to 20.04. This system hasn't been touched since the QA install back in 8-Sept.

I've seen many reports (support, askubu etc) claiming the same.

Changed in ubuntu-release-upgrader (Ubuntu Focal):
status: New → Invalid
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Revision history for this message
Brian Murray (brian-murray) wrote :

Actually let's just use a new bug for this.

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: Triaged → Invalid
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Brian Murray (brian-murray) wrote :

The new bug for this issue is bug 1901725.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers