Ubuntu System on USB Drive Breaks with Updates Requiring Restarts

Bug #1815225 reported by Wade on 2019-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

First, please forgive me if I do not report this issue correctly. I'm new here and don't generally live in the Launchpad world. (I've tried this at askUbuntu.com, and it was suggested I come here.)

In brief: I have a 2006 Dell Inspiron (32 bit) with a (slow) 40 GB hard drive running Ubuntu 14.04 LTS. Having the system exactly the way I want it, I used the application "Systemback" to install the system on a (fast) 128 GB USB drive, which, being bootable, worked exactly the same as if I booted from the hard drive. So I started using the faster 128 USB drive exclusively.

Now typically, Software Updater, if not requiring a restart, updated the running USB drive just fine. But one day, after Software Updater did an update that required a restart, this happened:
the GRUB 2 bootloader the USB drive that was booted from, AND ALSO the GRUB 2 bootloader on the laptop's hard drive got broken, to the point where neither was bootable, taking me to the dreaded "grub rescue" command line when trying to boot either one. (Thankfully, I had a second USB drive with my Ubuntu system on it, and was able to install it from there to both the laptop's hard drive and the other now-ruined USB drive to bring them back to a pre-broken, normal existence.)

With that background, I ask: Can Ubuntu's updates that require restarts merely work with the drive that was booted from, and not any affect any others (including an unmounted hard drive that was not booted from) ?

If so, then anyone could get a Linux the way they want that they can take anywhere, bootable from any computer, AND update-able from any computer, bypassing all need for hard drives of any sort. No longer would people need to even buy laptops with hard drives or even operating systems. They could simply buy a smaller, cheaper, hard-drive-less and OS-less device that runs merely by plugging an Ubuntu Linux USB drive into it as "the system".

Thank you very much for your time!

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-165-generic 3.13.0-165.215
ProcVersionSignature: Ubuntu 3.13.0-165.215-generic 3.13.11-ckt39
Uname: Linux 3.13.0-165-generic i686
ApportVersion: 2.14.1-0ubuntu3.29
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: noname 2014 F.... pulseaudio
CurrentDesktop: Unity
Date: Fri Feb 8 12:12:35 2019
HibernationDevice: RESUME=UUID=230fdc83-e7b8-40a5-8731-075b72792c69
InstallationDate: Installed on 2018-12-31 (39 days ago)
InstallationMedia:

IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Dell Inc. ME051
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-165-generic root=UUID=7cfb23c6-b380-495e-9e1c-813436961fef ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-165-generic N/A
 linux-backports-modules-3.13.0-165-generic N/A
 linux-firmware 1.127.24
RfKill:

SourcePackage: linux
UpgradeStatus: Upgraded to trusty on 2018-12-31 (39 days ago)
WifiSyslog:

dmi.bios.date: 12/22/2005
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0TD535
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd12/22/2005:svnDellInc.:pnME051:pvr:rvnDellInc.:rn0TD535:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: ME051
dmi.sys.vendor: Dell Inc.

Wade (wade41) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Brad Figg (brad-figg) on 2019-02-08
tags: added: bjf-tracking
Wade (wade41) wrote :

I remembered some additional information I should have put in the original post:

First: Just to be sure, I wanted to reiterate that the 128 GB USB drive was not just a "boot drive". It was an exact duplicate of the entire Ubuntu system from my laptop, and worked the exact same way (Trash function and all).

Second: As noted, the update from Software Updater that required a restart broke both (1) the GRUB 2 bootloader on the (booted) USB drive, AND (2) the GRUB 2 bootloader on the (unmounted) laptop's hard drive.

When I said they were broken to the point where neither was bootable, taking me to the dreaded "grub_rescue" command line when trying to boot either one, I should have added the following regarding the errors given:

1) When trying to boot from the USB drive (during the restart), the error was similar to "trying to read outside hd0" (hd0 = the hard drive, I believe), before I was put at grub_rescue command line. (To note, I have seen that same error at other *unrelated* times, but at those times, it acted more like a warning pause before simply continuing to the login screen.)

2) Then removing the USB drive and attempting to simply boot up from the hard drive instead, I got an error similar to "cannot find (or locate) device such-and-such" before being put at grub_rescue. I believe the "such-and-such" was the UUID of the USB drive that was being run from when the update that required a restart came up. So even though trying to boot up from the hard drive at that point, it still knew something about the previously-booted USB drive that was active during the restart-requiring-update; and it didn't like that it couldn't find that USB drive, so grub_rescue ensued.

That's it. Thank you again!

Wade (wade41) wrote :

Sorry, one last thing. If this issue is not an issue in later versions than 14.04 LTS, due to later-introduced hot patching for example (so that restarts are never required for updates), that would be considered a reasonable solution, and I would just upgrade to Version 16 or 18 as needed. Thank you.

Wade (wade41) wrote :

Sorry... I should have said if this is no longer an issue in later **32-bit** versions... because hot patching might must be for 64 bit versions, which wouldn't help in this case. Thanks.

no longer affects: update (Ubuntu)
Wade (wade41) wrote :

Please note: This bug also applies to Ubuntu 18.04 (in addition to 14.04 as originally reported).

But, there is a workaround which God Himself led me to (Praise Him!).

Because the laptop's hard drive was malfunctioning, God said if I removed it and then used the 128 GB flash drive as described above, then updates, even those including restarts, would work just fine.

And so I did. I removed the old 40 GB hard drive, and booted with the 128 flash drive. Then I ran Software Updater, which then required a restart. The updating-restart worked smoothly. I ran Software Updater once more, and it showed the system (on the 128 GB flash drive) was up-to-date.

I did notice previously that with the hard drive still in the laptop, even unmounted while booted with the 128 GB flash drive, the hard drive would always be /dev/sda. With the hard drive removed, the flash drive finally became /dev/sda, which is what I believe solved this Updater issue.

This is why I said earlier, and would still love for this to happen: Ubuntu should consider going this direction: having the "system" on a flash drive which people could take anywhere, bootable from any computer, AND update-able from any computer. Then they could convince a company to sell a device that is smaller, cheaper, hard-drive-less, and OS-less, which runs merely by plugging an Ubuntu USB drive into it as "the system". If Ubuntu would then work with MagicJack to get their great internet phone app to work with Linux, people could have both a real computer AND an internet (wifi) phone that they could take with them. Because let's face it: no one can "Libre Office" on a phone ! Check out a device like the GPD Pocket 2, and imagine it without a hard drive or an operating system. It would be perfect, replacing the need for cell phones for many, many people.

Thank you for the hearing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers