Add a reminder to enable Livepatch

Bug #1787553 reported by Andrea Azzarone on 2018-08-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Andrea Azzarone
Bionic
Medium
Unassigned

Bug Description

[Impact]
We should remind user about the possibility to enable Livepatch because at the moment we only suggest to do so in gnome-initial-setup.

Note that there is a new string, but launchpad already has translations from cosmic and those are going to be included in the next bionic langpack export

[Test Case]
Please note that the reminder will not be shown the first 3 times you start update-manager.

1. Make sure that the computer is full updated and no restart is required
2. Make sure Livepatch is disabled (you can use cli or software-properties-gtk)
3. Open update-manager
4. Make sure no reminder is shown
5. Close update-manager
5. Repeat (3-5) two times more.

Now you're ready to go:

1. Open update-manager
2. Make sure a reminder to enable livepatch is shown
3. Close update-manager
4. Enable Livepatch
5. Open update-manager
6. Make sure the reminder is no longer shown

[Regression Potential]
Please make sure the message "%d Livepatch updates applied since the last restart." is correctly shown if livepatch updates has been applied.

[Original Bug Report]

"In cases where the updates-complete confirmation wasn’t complicated by other things (such as telling you that you need to restart this time), it could extend to invite you to set up Livepatch.

One option would be to omit this invitation until the third or fourth update. By then people would have a better understanding of the benefit; and they might also have set up an Ubuntu One account for other purposes, easing the setup.

The “Settings & Livepatch…” button would take you to the normal update settings UI that includes Livepatch... !

Related branches

Andrea Azzarone (azzar1) on 2018-08-17
Changed in update-manager (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Andrea Azzarone (azzar1)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:18.10.7

---------------
update-manager (1:18.10.7) cosmic; urgency=medium

  * Fix PEP8 regression from 18.10.4 to allow autopkgtest to pass
  * Fix unused import of subprocess in Dialogs.py

 -- Julian Andres Klode <email address hidden> Thu, 06 Sep 2018 09:10:39 +0200

Changed in update-manager (Ubuntu):
status: In Progress → Fix Released
Andrea Azzarone (azzar1) on 2018-09-07
description: updated
description: updated
Brian Murray (brian-murray) wrote :

Won't this display the message on the 4th, 5th, 6th, and every time after that you launch update-manager? That seems really naggy.

Changed in update-manager (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Incomplete
Andrea Azzarone (azzar1) wrote :

@brian-murray Yes, that's the intended design (suggested by @mpt).

Matthew Paul Thomas (mpt) wrote :

Brian, this change adds one sentence to the update success notification, and one extra word to an existing button. It does not add any buttons, it does not make the notification appear more often than it otherwise would, and it does not require any more (or less obvious) clicks to dismiss than it otherwise would. Unless I’m missing some unintended change, I don’t see how it’s “really naggy”.

Brian Murray (brian-murray) wrote :

Ah, I didn't realize that it was adding text to an existing dialog. Sorry about that!

Hello Andrea, or anyone else affected,

Accepted update-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:18.04.11.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Bionic):
status: Incomplete → Fix Committed
tags: added: verification-needed verification-needed-bionic
Andrea Azzarone (azzar1) wrote :

Hi,

I installed update-manager from bionic-proposed:

```
$ apt-cache policy update-manager
update-manager:
  Installed: 1:18.04.11.7
  Candidate: 1:18.04.11.7
```

I followed the test case and it succeeded. In particular:
- the reminder did NOT show the first 3 times I opened update-manager
- the reminder showed up the 4th+ times
- the reminder did not show once I enabled canonical-livepatch
- the "Livepatch and settings..." correctly redirected me to software-properties-gtk
- Booting with kernel 4.15.0-38.41-generic I correctly got the message: "11 Livepatch updates applied since last restart"

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:18.04.11.7

---------------
update-manager (1:18.04.11.7) bionic; urgency=medium

  * Add a reminder to enable Livepatch (LP: #1787553).
  * Build-Depends on python3-distro-info.

 -- Andrea Azzarone <email address hidden> Fri, 07 Sep 2018 10:41:28 +0200

Changed in update-manager (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Andrea, or anyone else affected,

Accepted update-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:18.04.11.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Bionic):
status: Fix Released → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-done verification-done-bionic
Sebastien Bacher (seb128) wrote :

the new 1:18.04.11.8 version still works as it should

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
MikeR (mike-rechtman) wrote :

As a lowly user:
Please allow me to agree with Brian's remark about "naggy"
I have been using Ubuntu since Warty, and I prefer all my updates to be done manually, by me.
The constant appearance when ending update-manager of a "Tip" recommending Livepatch is aesthetically unappealing, and suggests a "hard sell".
Please allow some way for the few users who do not intend to install Livepatch to stop being poked by this constant -- and useless -- reminder.

Any useful response would be gratefully accepted.

Changed in update-manager (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers