update-manager crashed with AttributeError in resize_to_standard_width(): 'UpdateManager' object has no attribute 'signal_changed'

Bug #1774131 reported by Jean-Baptiste Lallement on 2018-05-30
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned
Bionic
Undecided
Unassigned

Bug Description

Crashes on Cosmic when launched by update-notifier.

errors.u.c https://errors.ubuntu.com/problem/76971c92f002117650d5630a6b13a8ba683e2343

(which is not bug 1269397 for Cosmic)

update-notifier.desktop[6220]: Traceback (most recent call last):
update-notifier.desktop[6220]: File "/usr/lib/python3/dist-packages/UpdateManager/UpdateManager.py", line 100, in <lambda>
update-notifier.desktop[6220]: self.resize_to_standard_width())
update-notifier.desktop[6220]: File "/usr/lib/python3/dist-packages/UpdateManager/UpdateManager.py", line 141, in resize_to_standard_width
update-notifier.desktop[6220]: GObject.signal_handler_block(ctx, self.signal_changed)
update-notifier.desktop[6220]: AttributeError: 'UpdateManager' object has no attribute 'signal_changed'
update-notifier.desktop[6220]: Traceback (most recent call last):
update-notifier.desktop[6220]: File "/usr/lib/python3/dist-packages/UpdateManager/UpdateManager.py", line 100, in <lambda>
update-notifier.desktop[6220]: self.resize_to_standard_width())
update-notifier.desktop[6220]: File "/usr/lib/python3/dist-packages/UpdateManager/UpdateManager.py", line 141, in resize_to_standard_width
update-notifier.desktop[6220]: GObject.signal_handler_block(ctx, self.signal_changed)
update-notifier.desktop[6220]: AttributeError: 'UpdateManager' object has no attribute 'signal_changed'
update-notifier.desktop[6220]: Traceback (most recent call last):
update-notifier.desktop[6220]: File "/usr/lib/python3/dist-packages/UpdateManager/UpdateManager.py", line 100, in <lambda>
update-notifier.desktop[6220]: self.resize_to_standard_width())
update-notifier.desktop[6220]: File "/usr/lib/python3/dist-packages/UpdateManager/UpdateManager.py", line 141, in resize_to_standard_width
update-notifier.desktop[6220]: GObject.signal_handler_block(ctx, self.signal_changed)
update-notifier.desktop[6220]: AttributeError: 'UpdateManager' object has no attribute 'signal_changed'

ProblemType: Crash
DistroRelease: Ubuntu 18.10
Package: update-manager 1:18.10.1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.10-0ubuntu2
Aptdaemon:

Architecture: amd64
CrashCounter: 1
CurrentDesktop: ubuntu:GNOME
Date: Wed May 30 08:33:32 2018
ExecutablePath: /usr/bin/update-manager
ExecutableTimestamp: 1527516232
InstallationDate: Installed on 2014-07-15 (1414 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140520)
InterpreterPath: /usr/bin/python3.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/update-manager --no-update --no-focus-on-map
ProcCwd: /home/j-lallement
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3
PythonArgs: ['/usr/bin/update-manager', '--no-update', '--no-focus-on-map']
PythonDetails: /usr/bin/python2.7, Python 2.7.15, python-minimal, 2.7.15~rc1-1
SourcePackage: update-manager
Title: update-manager crashed with AttributeError in resize_to_standard_width(): 'UpdateManager' object has no attribute 'signal_changed'
UpgradeStatus: Upgraded to cosmic on 2018-03-24 (66 days ago)
UserGroups: adm cdrom dip docker kvm libvirt libvirtd lpadmin lxd plugdev sambashare sudo

Jean-Baptiste Lallement (jibel) wrote :
information type: Private → Public
description: updated
tags: removed: need-duplicate-check
Changed in update-manager (Ubuntu):
importance: Undecided → Medium
description: updated
Brian Murray (brian-murray) wrote :

Looking at a couple of crash reports from different releases in the bucket we can see the DuplicateSignature is the same.

https://errors.ubuntu.com/oops/0df57774-6459-11e8-b827-fa163ed44aae

DuplicateSignature
/usr/bin/update-manager:AttributeError:<lambda>:resize_to_standard_width

https://errors.ubuntu.com/oops/b5eba116-1aca-11e8-aaf0-fa163e839e11

DuplicateSignature
/usr/bin/update-manager:AttributeError:<lambda>:resize_to_standard_width

Brian Murray (brian-murray) wrote :

My bad that was for the apport bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Willem Hobers (whobers) wrote :

Testing Xubuntu 18.10

tags: added: rls-cc-incoming
tags: added: bionic
Brian Murray (brian-murray) wrote :

This also seems to affect to Ubuntu 18.04 and should be fixed there.

Jan Wester (j-vester) wrote :
Download full text (68.2 KiB)

I agree with Brian Murray. I am running ubuntu 18.04 and have this crash all the time now. I did not see it before I switched to nvidia 390 drivers on this machine. But can not say for sure, if this happened at the same time doing the switch.

ProblemType: Crash
CrashCounter: 1
CurrentDesktop: ubuntu:GNOME
Date: Tue Jun 5 08:47:05 2018
ExecutablePath: /usr/bin/update-manager
ExecutableTimestamp: 1527516792
InterpreterPath: /usr/bin/python3.6
ProcCmdline: /usr/bin/python3 /usr/bin/update-manager
ProcCwd: /export/home/janw
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=sv_SE.UTF-8
 SHELL=/bin/tcsh
ProcMaps:
 00400000-007c1000 r-xp 00000000 08:08 20978791 /usr/bin/python3.6
 009c0000-009c1000 r--p 003c0000 08:08 20978791 /usr/bin/python3.6
 009c1000-00a5d000 rw-p 003c1000 08:08 20978791 /usr/bin/python3.6
 00a5d000-00a8f000 rw-p 00000000 00:00 0
 023f9000-031c0000 rw-p 00000000 00:00 0 [heap]
 7f6020000000-7f602004b000 rw-p 00000000 00:00 0
 7f602004b000-7f6024000000 ---p 00000000 00:00 0
 7f6028000000-7f6028021000 rw-p 00000000 00:00 0
 7f6028021000-7f602c000000 ---p 00000000 00:00 0
 7f602c000000-7f602c021000 rw-p 00000000 00:00 0
 7f602c021000-7f6030000000 ---p 00000000 00:00 0
 7f6030394000-7f6030413000 r-xp 00000000 08:08 20972927 /usr/lib/x86_64-linux-gnu/libgmp.so.10.3.2
 7f6030413000-7f6030613000 ---p 0007f000 08:08 20972927 /usr/lib/x86_64-linux-gnu/libgmp.so.10.3.2
 7f6030613000-7f6030614000 r--p 0007f000 08:08 20972927 /usr/lib/x86_64-linux-gnu/libgmp.so.10.3.2
 7f6030614000-7f6030615000 rw-p 00080000 08:08 20972927 /usr/lib/x86_64-linux-gnu/libgmp.so.10.3.2
 7f6030615000-7f6030648000 r-xp 00000000 08:08 20978824 /usr/lib/x86_64-linux-gnu/libhogweed.so.4.4
 7f6030648000-7f6030847000 ---p 00033000 08:08 20978824 /usr/lib/x86_64-linux-gnu/libhogweed.so.4.4
 7f6030847000-7f6030848000 r--p 00032000 08:08 20978824 /usr/lib/x86_64-linux-gnu/libhogweed.so.4.4
 7f6030848000-7f6030849000 rw-p 00033000 08:08 20978824 /usr/lib/x86_64-linux-gnu/libhogweed.so.4.4
 7f6030849000-7f603087d000 r-xp 00000000 08:08 20974610 /usr/lib/x86_64-linux-gnu/libnettle.so.6.4
 7f603087d000-7f6030a7c000 ---p 00034000 08:08 20974610 /usr/lib/x86_64-linux-gnu/libnettle.so.6.4
 7f6030a7c000-7f6030a7e000 r--p 00033000 08:08 20974610 /usr/lib/x86_64-linux-gnu/libnettle.so.6.4
 7f6030a7e000-7f6030a7f000 rw-p 00035000 08:08 20974610 /usr/lib/x86_64-linux-gnu/libnettle.so.6.4
 7f6030a7f000-7f6030a90000 r-xp 00000000 08:08 20978826 /usr/lib/x86_64-linux-gnu/libtasn1.so.6.5.5
 7f6030a90000-7f6030c90000 ---p 00011000 08:08 20978826 /usr/lib/x86_64-linux-gnu/libtasn1.so.6.5.5
 7f6030c90000-7f6030c91000 r--p 00011000 08:08 20978826 /usr/lib/x86_64-linux-gnu/libtasn1.so.6.5.5
 7f6030c91000-7f6030c92000 rw-p 00012000 08:08 20978826 /usr/lib/x86_64-linux-gnu/lib...

Adam Conrad (adconrad) wrote :

update-manager (1:18.10.2) cosmic; urgency=medium

  * Fix my spelling mistake in the previous upload. Oops.

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 07 Jun 2018 23:35:04 -0700

This is fixed by the above cosmic upload, but it still needs an upload to fix bionic-proposed.

Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released

Hello Jean-Baptiste, or anyone else affected,

Accepted update-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:18.04.11.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-manager (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Jan Wester (j-vester) wrote :

I tested the tar-file and it looks like it is working without crashes. Looking forward to getting it into the repositories soon. I am running 18.04

Jan Wester (j-vester) wrote :

forgot to say i tested the
update-manager-18.04.11.2

Marking verification-done since it was verified as fixed in comments #10, #11.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic

Verification-done with update-manager/1:18.04.11.2 on bionic:

I verified that the restart CPU does not show 100% CPU usage, and it does show without crashing update-manager. AFAICT this is fixed correctly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:18.04.11.2

---------------
update-manager (1:18.04.11.2) bionic; urgency=medium

  * Fix my embarassing typo that makes update-manager report crashes, when
    instanciating the "reboot" dialog and mangling signals. (LP: #1774131)

update-manager (1:18.04.11.1) bionic; urgency=medium

  * Block style context changed signal while enforcing the main window's
    constant size. Thanks to Thomas Waldmann and Sebastien Bacher for the
    initial analysis of this bug. (LP: #1637180)

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 08 Jun 2018 11:50:10 -0700

Changed in update-manager (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers