Xubuntu [Gutsy Gibbon] Update Manager Fails

Bug #177226 reported by Mastadon on 2007-12-18
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

When I log in to Xubuntu 7.10 [Gutsy Gibbon], I get a message from the Update Manager that there are updates available for a number of my installed packages. Attempt #1 at updating failed, saying that there has been an error and asked if I would report the bug along with the contents of the /var/log/dist-upgrade log files. There is only one file, apt.log, and its contents are:

<block>
Installing samba-common as dep of smbclient
Installing gnome-games-data as dep of gnome-games
Installing gnome-cards-data as dep of gnome-games-data
Installing libpango1.0-0 as dep of gnome-system-tools
Installing busybox as dep of initramfs-tools
Installing sysvinit-utils as dep of initscripts
Starting
Starting 2
Investigating upstart
Package upstart has broken dep on sysvinit
  Considering sysvinit 5102 as a solution to upstart 30
  Removing upstart rather than change sysvinit
Investigating upstart-compat-sysv
Package upstart-compat-sysv has broken dep on upstart
  Considering upstart 30 as a solution to upstart-compat-sysv 17
  Removing upstart-compat-sysv rather than change upstart
Investigating upstart-logd
Package upstart-logd has broken dep on upstart
  Considering upstart 30 as a solution to upstart-logd 8
  Removing upstart-logd rather than change upstart
Investigating system-services
Package system-services has broken dep on upstart
  Considering upstart 30 as a solution to system-services 8
  Removing system-services rather than change upstart
Investigating startup-tasks
Package startup-tasks has broken dep on upstart
  Considering upstart 30 as a solution to startup-tasks 8
  Removing startup-tasks rather than change upstart
Investigating apparmor
Package apparmor has broken dep on upstart-compat-sysv
  Considering upstart-compat-sysv 17 as a solution to apparmor 5
  Removing apparmor rather than change upstart-compat-sysv
Investigating ubuntu-minimal
Package ubuntu-minimal has broken dep on startup-tasks
  Considering startup-tasks 8 as a solution to ubuntu-minimal 4
  Removing ubuntu-minimal rather than change startup-tasks
Investigating apparmor-utils
Package apparmor-utils has broken dep on apparmor
  Considering apparmor 5 as a solution to apparmor-utils 2
  Removing apparmor-utils rather than change apparmor
Done
Starting
Starting 2
Investigating udev
Package udev has broken dep on libdevmapper1.02
  Considering libdevmapper1.02 10002 as a solution to udev 33
  Removing udev rather than change libdevmapper1.02
Investigating initramfs-tools
Package initramfs-tools has broken dep on udev
  Considering udev 33 as a solution to initramfs-tools 33
    Reinst Failed because of udev
  Removing initramfs-tools rather than change udev
Investigating volumeid
Package volumeid has broken dep on initramfs-tools
  Considering initramfs-tools 33 as a solution to volumeid 17
  Removing volumeid rather than change initramfs-tools
Investigating hal
Package hal has broken dep on udev
  Considering udev 33 as a solution to hal 10
  Removing hal rather than change udev
Investigating linux-image-2.6.22-14-generic
Package linux-image-2.6.22-14-generic has broken dep on initramfs-tools
  Considering initramfs-tools 33 as a solution to linux-image-2.6.22-14-generic 6
  Removing linux-image-2.6.22-14-generic rather than change initramfs-tools
Investigating console-setup
Package console-setup has broken dep on initramfs-tools
  Considering initramfs-tools 33 as a solution to console-setup 4
  Removing console-setup rather than change initramfs-tools
Investigating pcmciautils
Package pcmciautils has broken dep on udev
  Considering udev 33 as a solution to pcmciautils 4
  Removing pcmciautils rather than change udev
Investigating gnome-mount
Package gnome-mount has broken dep on hal
  Considering hal 10 as a solution to gnome-mount 3
  Removing gnome-mount rather than change hal
Investigating usplash
Package usplash has broken dep on initramfs-tools
  Considering initramfs-tools 33 as a solution to usplash 3
  Removing usplash rather than change initramfs-tools
Investigating libgphoto2-2
Package libgphoto2-2 has broken dep on udev
  Considering udev 33 as a solution to libgphoto2-2 3
  Removing libgphoto2-2 rather than change udev
Investigating linux-ubuntu-modules-2.6.22-14-generic
Package linux-ubuntu-modules-2.6.22-14-generic has broken dep on linux-image-2.6.22-14-generic
  Considering linux-image-2.6.22-14-generic 6 as a solution to linux-ubuntu-modules-2.6.22-14-generic 2
  Removing linux-ubuntu-modules-2.6.22-14-generic rather than change linux-image-2.6.22-14-generic
Investigating linux-restricted-modules-2.6.22-14-generic
Package linux-restricted-modules-2.6.22-14-generic has broken dep on linux-image-2.6.22-14-generic
  Considering linux-image-2.6.22-14-generic 6 as a solution to linux-restricted-modules-2.6.22-14-generic 2
    Reinst Failed because of linux-image-2.6.22-14-generic
  Removing linux-restricted-modules-2.6.22-14-generic rather than change linux-image-2.6.22-14-generic
Investigating xubuntu-artwork-usplash
Package xubuntu-artwork-usplash has broken dep on initramfs-tools
  Considering initramfs-tools 33 as a solution to xubuntu-artwork-usplash 1
  Removing xubuntu-artwork-usplash rather than change initramfs-tools
Investigating thunar-volman
Package thunar-volman has broken dep on gnome-mount
  Considering gnome-mount 3 as a solution to thunar-volman 1
  Removing thunar-volman rather than change gnome-mount
Investigating linux-restricted-modules-generic
Package linux-restricted-modules-generic has broken dep on linux-restricted-modules-2.6.22-14-generic
  Considering linux-restricted-modules-2.6.22-14-generic 2 as a solution to linux-restricted-modules-generic 1
  Removing linux-restricted-modules-generic rather than change linux-restricted-modules-2.6.22-14-generic
Investigating network-manager
Package network-manager has broken dep on hal
  Considering hal 10 as a solution to network-manager 1
  Removing network-manager rather than change hal
Investigating linux-image-generic
Package linux-image-generic has broken dep on linux-image-2.6.22-14-generic
  Considering linux-image-2.6.22-14-generic 6 as a solution to linux-image-generic 1
  Removing linux-image-generic rather than change linux-image-2.6.22-14-generic
Investigating xfce4-session
Package xfce4-session has broken dep on hal
  Considering hal 10 as a solution to xfce4-session 1
  Removing xfce4-session rather than change hal
Investigating update-notifier
Package update-notifier has broken dep on hal
  Considering hal 10 as a solution to update-notifier 0
  Removing update-notifier rather than change hal
Investigating network-manager-gnome
Package network-manager-gnome has broken dep on network-manager
  Considering network-manager 1 as a solution to network-manager-gnome 0
  Removing network-manager-gnome rather than change network-manager
Investigating linux-generic
Package linux-generic has broken dep on linux-image-generic
  Considering linux-image-generic 1 as a solution to linux-generic 0
  Removing linux-generic rather than change linux-image-generic
Investigating hal-cups-utils
Package hal-cups-utils has broken dep on hal
  Considering hal 10 as a solution to hal-cups-utils 0
  Removing hal-cups-utils rather than change hal
Investigating nvidia-glx-new
Package nvidia-glx-new has broken dep on nvidia-kernel-100.14.19
  Considering linux-restricted-modules-2.6.22-14-xen 0 as a solution to nvidia-glx-new 0
  Removing nvidia-glx-new rather than change nvidia-kernel-100.14.19
Investigating xubuntu-desktop
Package xubuntu-desktop has broken dep on gnome-mount
  Considering gnome-mount 3 as a solution to xubuntu-desktop 0
  Removing xubuntu-desktop rather than change gnome-mount
Investigating grub
Package grub has broken dep on volumeid
  Considering volumeid 17 as a solution to grub 0
  Removing grub rather than change volumeid
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 3 as a solution to libsane 3
  Removing libsane rather than change libgphoto2-2
Investigating hpijs
Package hpijs has broken dep on libsane
  Considering libsane 3 as a solution to hpijs 2
  Removing hpijs rather than change libsane
Investigating foomatic-db-hpijs
Package foomatic-db-hpijs has broken dep on hpijs
  Considering hpijs 2 as a solution to foomatic-db-hpijs 1
  Removing foomatic-db-hpijs rather than change hpijs
Investigating hplip
Package hplip has broken dep on libsane
  Considering libsane 3 as a solution to hplip 0
  Removing hplip rather than change libsane
Done
Starting
Starting 2
Investigating hpijs
Package hpijs has broken dep on libsane
  Considering libsane 1 as a solution to hpijs 10000
  Added libsane to the remove list
  Fixing hpijs via keep of libsane
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 0 as a solution to libsane 1
  Added libgphoto2-2 to the remove list
  Fixing libsane via keep of libgphoto2-2
Investigating libgphoto2-2
Package libgphoto2-2 has broken dep on udev
  Considering udev 3 as a solution to libgphoto2-2 0
  Removing libgphoto2-2 rather than change udev
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 0 as a solution to libsane 1
  Added libgphoto2-2 to the remove list
  Fixing libsane via keep of libgphoto2-2
Investigating libgphoto2-2
Package libgphoto2-2 has broken dep on udev
  Considering udev 3 as a solution to libgphoto2-2 0
  Removing libgphoto2-2 rather than change udev
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 0 as a solution to libsane 1
  Added libgphoto2-2 to the remove list
  Fixing libsane via keep of libgphoto2-2
Investigating libgphoto2-2
Package libgphoto2-2 has broken dep on udev
  Considering udev 3 as a solution to libgphoto2-2 1
  Removing libgphoto2-2 rather than change udev
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 3 as a solution to libsane 1
  Removing libsane rather than change libgphoto2-2
Investigating hpijs
Package hpijs has broken dep on libsane
  Considering libsane 3 as a solution to hpijs 10000
  Added libsane to the remove list
  Fixing hpijs via keep of libsane
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 3 as a solution to libsane 10000
  Added libgphoto2-2 to the remove list
  Fixing libsane via keep of libgphoto2-2
Investigating libgphoto2-2
Package libgphoto2-2 has broken dep on udev
  Considering udev 3 as a solution to libgphoto2-2 10000
  Added udev to the remove list
  Fixing libgphoto2-2 via keep of udev
Investigating udev
Package udev has broken dep on volumeid
  Considering volumeid 0 as a solution to udev 10000
  Added volumeid to the remove list
Package udev has broken dep on initramfs-tools
  Considering initramfs-tools 0 as a solution to udev 10000
  Added initramfs-tools to the remove list
Package udev has broken dep on libdevmapper1.02
  Considering libdevmapper1.02 2 as a solution to udev 10000
  Will not break libdevmapper1.02 as stated in Breaks field in udev
  Fixing udev via keep of volumeid
  Fixing udev via keep of initramfs-tools
Investigating udev
Package udev has broken dep on libdevmapper1.02
  Considering libdevmapper1.02 2 as a solution to udev 10000
  Will not break libdevmapper1.02 as stated in Breaks field in udev
Done
ERROR:root:Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'
Installing busybox as dep of initramfs-tools
Installing sysvinit-utils as dep of initscripts
Starting
Starting 2
Investigating upstart
Package upstart has broken dep on sysvinit
  Considering sysvinit 5102 as a solution to upstart 30
  Removing upstart rather than change sysvinit
Investigating upstart-compat-sysv
Package upstart-compat-sysv has broken dep on upstart
  Considering upstart 30 as a solution to upstart-compat-sysv 17
  Removing upstart-compat-sysv rather than change upstart
Investigating upstart-logd
Package upstart-logd has broken dep on upstart
  Considering upstart 30 as a solution to upstart-logd 8
  Removing upstart-logd rather than change upstart
Investigating system-services
Package system-services has broken dep on upstart
  Considering upstart 30 as a solution to system-services 8
  Removing system-services rather than change upstart
Investigating startup-tasks
Package startup-tasks has broken dep on upstart
  Considering upstart 30 as a solution to startup-tasks 8
  Removing startup-tasks rather than change upstart
Investigating apparmor
Package apparmor has broken dep on upstart-compat-sysv
  Considering upstart-compat-sysv 17 as a solution to apparmor 5
  Removing apparmor rather than change upstart-compat-sysv
Investigating ubuntu-minimal
Package ubuntu-minimal has broken dep on startup-tasks
  Considering startup-tasks 8 as a solution to ubuntu-minimal 4
  Removing ubuntu-minimal rather than change startup-tasks
Investigating apparmor-utils
Package apparmor-utils has broken dep on apparmor
  Considering apparmor 5 as a solution to apparmor-utils 2
  Removing apparmor-utils rather than change apparmor
Done
Starting
Starting 2
Investigating udev
Package udev has broken dep on libdevmapper1.02
  Considering libdevmapper1.02 10002 as a solution to udev 33
  Removing udev rather than change libdevmapper1.02
Investigating initramfs-tools
Package initramfs-tools has broken dep on udev
  Considering udev 33 as a solution to initramfs-tools 33
    Reinst Failed because of udev
  Removing initramfs-tools rather than change udev
Investigating volumeid
Package volumeid has broken dep on initramfs-tools
  Considering initramfs-tools 33 as a solution to volumeid 17
  Removing volumeid rather than change initramfs-tools
Investigating hal
Package hal has broken dep on udev
  Considering udev 33 as a solution to hal 10
  Removing hal rather than change udev
Investigating linux-image-2.6.22-14-generic
Package linux-image-2.6.22-14-generic has broken dep on initramfs-tools
  Considering initramfs-tools 33 as a solution to linux-image-2.6.22-14-generic 6
  Removing linux-image-2.6.22-14-generic rather than change initramfs-tools
Investigating console-setup
Package console-setup has broken dep on initramfs-tools
  Considering initramfs-tools 33 as a solution to console-setup 4
  Removing console-setup rather than change initramfs-tools
Investigating pcmciautils
Package pcmciautils has broken dep on udev
  Considering udev 33 as a solution to pcmciautils 4
  Removing pcmciautils rather than change udev
Investigating gnome-mount
Package gnome-mount has broken dep on hal
  Considering hal 10 as a solution to gnome-mount 3
  Removing gnome-mount rather than change hal
Investigating usplash
Package usplash has broken dep on initramfs-tools
  Considering initramfs-tools 33 as a solution to usplash 3
  Removing usplash rather than change initramfs-tools
Investigating libgphoto2-2
Package libgphoto2-2 has broken dep on udev
  Considering udev 33 as a solution to libgphoto2-2 3
  Removing libgphoto2-2 rather than change udev
Investigating linux-ubuntu-modules-2.6.22-14-generic
Package linux-ubuntu-modules-2.6.22-14-generic has broken dep on linux-image-2.6.22-14-generic
  Considering linux-image-2.6.22-14-generic 6 as a solution to linux-ubuntu-modules-2.6.22-14-generic 2
  Removing linux-ubuntu-modules-2.6.22-14-generic rather than change linux-image-2.6.22-14-generic
Investigating linux-restricted-modules-2.6.22-14-generic
Package linux-restricted-modules-2.6.22-14-generic has broken dep on linux-image-2.6.22-14-generic
  Considering linux-image-2.6.22-14-generic 6 as a solution to linux-restricted-modules-2.6.22-14-generic 2
  Removing linux-restricted-modules-2.6.22-14-generic rather than change linux-image-2.6.22-14-generic
Investigating xubuntu-artwork-usplash
Package xubuntu-artwork-usplash has broken dep on initramfs-tools
  Considering initramfs-tools 33 as a solution to xubuntu-artwork-usplash 1
  Removing xubuntu-artwork-usplash rather than change initramfs-tools
Investigating thunar-volman
Package thunar-volman has broken dep on gnome-mount
  Considering gnome-mount 3 as a solution to thunar-volman 1
  Removing thunar-volman rather than change gnome-mount
Investigating linux-restricted-modules-generic
Package linux-restricted-modules-generic has broken dep on linux-restricted-modules-2.6.22-14-generic
  Considering linux-restricted-modules-2.6.22-14-generic 2 as a solution to linux-restricted-modules-generic 1
  Removing linux-restricted-modules-generic rather than change linux-restricted-modules-2.6.22-14-generic
Investigating network-manager
Package network-manager has broken dep on hal
  Considering hal 10 as a solution to network-manager 1
  Removing network-manager rather than change hal
Investigating linux-image-generic
Package linux-image-generic has broken dep on linux-image-2.6.22-14-generic
  Considering linux-image-2.6.22-14-generic 6 as a solution to linux-image-generic 1
  Removing linux-image-generic rather than change linux-image-2.6.22-14-generic
Investigating xfce4-session
Package xfce4-session has broken dep on hal
  Considering hal 10 as a solution to xfce4-session 1
  Removing xfce4-session rather than change hal
Investigating update-notifier
Package update-notifier has broken dep on hal
  Considering hal 10 as a solution to update-notifier 0
  Removing update-notifier rather than change hal
Investigating network-manager-gnome
Package network-manager-gnome has broken dep on network-manager
  Considering network-manager 1 as a solution to network-manager-gnome 0
  Removing network-manager-gnome rather than change network-manager
Investigating linux-generic
Package linux-generic has broken dep on linux-image-generic
  Considering linux-image-generic 1 as a solution to linux-generic 0
  Removing linux-generic rather than change linux-image-generic
Investigating hal-cups-utils
Package hal-cups-utils has broken dep on hal
  Considering hal 10 as a solution to hal-cups-utils 0
  Removing hal-cups-utils rather than change hal
Investigating xubuntu-desktop
Package xubuntu-desktop has broken dep on gnome-mount
  Considering gnome-mount 3 as a solution to xubuntu-desktop 0
  Removing xubuntu-desktop rather than change gnome-mount
Investigating grub
Package grub has broken dep on volumeid
  Considering volumeid 17 as a solution to grub 0
  Removing grub rather than change volumeid
Investigating nvidia-glx-new
Package nvidia-glx-new has broken dep on nvidia-kernel-100.14.19
  Considering linux-restricted-modules-2.6.22-14-xen 0 as a solution to nvidia-glx-new -1
  Removing nvidia-glx-new rather than change nvidia-kernel-100.14.19
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 3 as a solution to libsane 3
  Removing libsane rather than change libgphoto2-2
Investigating hpijs
Package hpijs has broken dep on libsane
  Considering libsane 3 as a solution to hpijs 2
  Removing hpijs rather than change libsane
Investigating foomatic-db-hpijs
Package foomatic-db-hpijs has broken dep on hpijs
  Considering hpijs 2 as a solution to foomatic-db-hpijs 1
  Removing foomatic-db-hpijs rather than change hpijs
Investigating hplip
Package hplip has broken dep on libsane
  Considering libsane 3 as a solution to hplip 0
  Removing hplip rather than change libsane
Done
Starting
Starting 2
Investigating hpijs
Package hpijs has broken dep on libsane
  Considering libsane 1 as a solution to hpijs 10000
  Added libsane to the remove list
  Fixing hpijs via keep of libsane
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 0 as a solution to libsane 1
  Added libgphoto2-2 to the remove list
  Fixing libsane via keep of libgphoto2-2
Investigating libgphoto2-2
Package libgphoto2-2 has broken dep on udev
  Considering udev 3 as a solution to libgphoto2-2 0
  Removing libgphoto2-2 rather than change udev
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 0 as a solution to libsane 1
  Added libgphoto2-2 to the remove list
  Fixing libsane via keep of libgphoto2-2
Investigating libgphoto2-2
Package libgphoto2-2 has broken dep on udev
  Considering udev 3 as a solution to libgphoto2-2 0
  Removing libgphoto2-2 rather than change udev
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 0 as a solution to libsane 1
  Added libgphoto2-2 to the remove list
  Fixing libsane via keep of libgphoto2-2
Investigating libgphoto2-2
Package libgphoto2-2 has broken dep on udev
  Considering udev 3 as a solution to libgphoto2-2 1
  Removing libgphoto2-2 rather than change udev
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 3 as a solution to libsane 1
  Removing libsane rather than change libgphoto2-2
Investigating hpijs
Package hpijs has broken dep on libsane
  Considering libsane 3 as a solution to hpijs 10000
  Added libsane to the remove list
  Fixing hpijs via keep of libsane
Investigating libsane
Package libsane has broken dep on libgphoto2-2
  Considering libgphoto2-2 3 as a solution to libsane 10000
  Added libgphoto2-2 to the remove list
  Fixing libsane via keep of libgphoto2-2
Investigating libgphoto2-2
Package libgphoto2-2 has broken dep on udev
  Considering udev 3 as a solution to libgphoto2-2 10000
  Added udev to the remove list
  Fixing libgphoto2-2 via keep of udev
Investigating udev
Package udev has broken dep on volumeid
  Considering volumeid 0 as a solution to udev 10000
  Added volumeid to the remove list
Package udev has broken dep on initramfs-tools
  Considering initramfs-tools 0 as a solution to udev 10000
  Added initramfs-tools to the remove list
Package udev has broken dep on libdevmapper1.02
  Considering libdevmapper1.02 2 as a solution to udev 10000
  Will not break libdevmapper1.02 as stated in Breaks field in udev
  Fixing udev via keep of volumeid
  Fixing udev via keep of initramfs-tools
Investigating udev
Package udev has broken dep on libdevmapper1.02
  Considering libdevmapper1.02 2 as a solution to udev 10000
  Will not break libdevmapper1.02 as stated in Breaks field in udev
Done
ERROR:root:Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'
</block>

Attempt #2
====================================

I tried again in order to write down more specifics on error messages. I hit the "Check" button to see what updates are available and got the following warning:

<block>
An error occured.
The following details are provided:

W: GPG error: http://ftp.de.debian.org etch Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A70DAF536070D3A1 NO_PUBKEY B5D0C804ADB11277
</block>

Fine. I hit the "Close" button and move on. Now, I get the original warning again:

<block>
Not all upgrades can be installed.
Run a partial upgrade, to install as many updates as possible.

This can be caused by:
* a previous upgrade which didn't complete
*Unofficial software packages not provided by Ubuntu
*Normal changes of a pre-release version of Ubuntu
</block>

I do have unofficial packages installed, and certainly, at least one previous upgrade did not complete. So, I move on with the partial upgrade by clicking the "Partial Upgrade" button. I enter my administrative password and a progress message appears. In the first step, I get this:

<block>
Could not calculate the upgrade.
An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade in the bug report.
</block>

This is the same error I got in Attempt #1, so things are failing consistently. The contents of the lone file are listed above.

There you go. Enjoy!

Don

Chris Hanning (hanningnz) wrote :

10 minutes after my last comment to this bug I clicked on the update-icon and this time declined a partial upgrade. I then clicked on the 'Install' button in the Update Manager window and it updated smbclient, samba-common and libsmbclient from 2.2 to 2.3 The final comments in the Applied changes window stated "Processing triggers for libc6...
ldconfig deferred processing now taking place"

initramfs-tools and initscripts remain 'greyed-out' in the Update Manager window and were not upgraded.

I'm a bull in a china shop and really don't have much knowledge of what I am doing. Thank god I'm not system manager at a critical establishment!
I hope this helps...

apt.log was unchanged from my last post

Chris

Thanks, Chris. Yeah, I'm pretty new at this and am trashing my own china
shop over here. Anyway, declining the partial upgrade and moving on did the
trick. So, while I'm under way with a current system, I'm still kind of
curious about what that failure meant. Thanks again.

Don

On Dec 18, 2007 5:52 PM, Chris Hanning <email address hidden> wrote:

> 10 minutes after my last comment to this bug I clicked on the update-icon
> and this time declined a partial upgrade. I then clicked on the 'Install'
> button in the Update Manager window and it updated smbclient, samba-common
> and libsmbclient from 2.2 to 2.3 The final comments in the Applied changes
> window stated "Processing triggers for libc6...
> ldconfig deferred processing now taking place"
>
> initramfs-tools and initscripts remain 'greyed-out' in the Update
> Manager window and were not upgraded.
>
> I'm a bull in a china shop and really don't have much knowledge of what I
> am doing. Thank god I'm not system manager at a critical establishment!
> I hope this helps...
>
> apt.log was unchanged from my last post
>
> Chris
>
> --
> Xubuntu [Gutsy Gibbon] Update Manager Fails
> https://bugs.launchpad.net/bugs/177226
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Mastadon (mastadon1969) wrote :

Thanks, Chris. I think I just sent you an e-mail response to this, but will also post it here. Yeah, I'm pretty new at this and am trashing my own china shop over here. Anyway, declining the partial upgrade and moving on did the trick. So, while I'm under way with a current system, I'm still kind of curious about what that failure meant. Thanks again.

Don

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release, Hardy 8.04.01? Thanks in advance.

Changed in update-manager:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in update-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers