/usr/bin/update-manager:TypeError:<lambda>:on_button_install_clicked:start_install:_start_pane:start:unwind_generator

Bug #1771894 reported by errors.ubuntu.com bug bridge on 2018-05-17
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]

The backend API change made update-manager crash when the updated incompatible backend was loaded to the not updated running update-manager process.

The issue causes crashes upon update-manager updates harming the upgrade experience for users.

The fix avoids lazy loading of the backend modules but still honors the backend selection options.

[Test Case]

1. Start with a fully upgraded system and downgrade a few packages to let u-m upgrade them and also downgrade update-manager to 1:16.04.12 or earlier:
$ sudo eatmydata apt install -y --allow-downgrades gnome-software=3.28.1-0ubuntu4 gnome-software-common=3.28.1-0ubuntu4
$ sudo apt install update-manager=1:16.04.12 update-manager-core=1:16.04.12 python3-update-manager=1:16.04.12

2. Start u-m with:
 $ update-manager --no-update

3. Upgrade update-manager to a still not fixed version to observe the crash:
$ sudo apt install update-manager=1:16.04.14 update-manager-core=1:16.04.14 python3-update-manager=1:16.04.14

... or to the fixed version to a see the crash not happening in step 4:

$ sudo apt install update-manager=1:16.04.15 update-manager-core=1:16.04.15 python3-update-manager=1:16.04.15

4. Press "Install Now" on u-m GUI.
 The fixed u-m will successfully perform the installation, the unfixed one will fail with:
TypeError: commit() missing 1 required positional argument: 'pkgs_remove'

[Regression Potential]

The change to the backend API could cause u-m not able to remove unused kernels, but in my testing this feature still worked.

[Original Bug Text]

The Ubuntu Error Tracker has been receiving reports about a problem regarding update-manager. This problem was most recently seen with package version 1:18.04.11, the problem page at https://errors.ubuntu.com/problem/310b9890e139c17b61faeee8f50078909283794e contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Balint Reczey (rbalint) on 2018-10-05
description: updated

Hello errors.ubuntu.com, or anyone else affected,

Accepted update-manager into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:16.04.15 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Balint Reczey (rbalint) wrote :

Verified with 1:16.04.15 on Xenial.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Changed in update-manager (Ubuntu):
status: New → Fix Released
status: Fix Released → Invalid
Balint Reczey (rbalint) wrote :

Marking the bug as invalid for later releases because we don't exercise this code upgrade path in later releases and in later releases lazy loading of the backend code is fixed in LP: #1795898.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:16.04.15

---------------
update-manager (1:16.04.15) xenial; urgency=medium

  * Keep or delete packages after looping over all of them.
    This prevents the resolver from changing the packages in the loop resulting
    in not keeping some phased packages back from being upgraded. (LP: #1072136)
  * Stop lazy import of InstallBackends.
    Lazy imports made update-manager crash when an update-manager
    update changed the backend API and an updated incompatible backend
    was loaded to the not updated running update-manager process. (LP: #1795898)
  * Cancel transaction on exit only when Cancel button is active.
    Also ignore exception when cancellation fails. (LP: #1790670)
  * Make commit()'s last parameter optional for avoiding crash on upgrade
    (LP: #1771894)

 -- Balint Reczey <email address hidden> Thu, 04 Oct 2018 21:51:10 +0200

Changed in update-manager (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers