software updater presents an empty panel for updating

Bug #1766217 reported by Humphrey van Polanen Petel on 2018-04-23
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

1. software updater alerts me to a small update (<1Mb)
2. click <install>
3. software updater "does its thing"
4. software update presents an empty panel and asks me to install or be reminded later
5. click <install>
repeat

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: update-manager 1:16.04.12
ProcVersionSignature: Ubuntu 4.13.0-38.43~16.04.1-generic 4.13.16
Uname: Linux 4.13.0-38-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.16
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Apr 23 20:55:24 2018
ExecutablePath: /usr/bin/update-manager
GsettingsChanges:
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'window-height' b'592'
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'window-width' b'484'
 b'com.ubuntu.update-manager' b'launch-time' b'int64 1524479931'
InstallationDate: Installed on 2017-12-13 (131 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
InterpreterPath: /usr/bin/python3.5
PackageArchitecture: all
SourcePackage: update-manager
UpgradeStatus: No upgrade log present (probably fresh install)

reboot and run software updater gives the same result
need to click <remind me later> to get out

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed

I was having this same bug and I managed to "fix" it by deleting everything under /var/lib/apt

i.e. sudo apt rm -rf /var/lib/apt/

Then run "sudo apt update" and reboot the system.

I forgot. If after executing those commands now update-manager gets permanently stuck on "waiting for other software managers to quit" (which is kept stuck even after removing the locks in all apt places and closing all software managers), then run:

sudo apt install --reinstall update-manager

It is nice to know that I can fix the symptoms, but it is still a bug that needs to be fixed.

Rhett (rhettlivingston) wrote :

Encountered this. Thank you for the rm directions. It fixed the issue. I did not have to do the reinstall after reboot.

Tommy Trussell (tommy-trussell) wrote :
Download full text (4.6 KiB)

I have been seeing this.
TL;DR: workaround: delete /var/lib/apt/extended_states

INVESTIGATION

I tried reinstalling the update-manager

$ sudo apt install --reinstall update-manager

but that didn't help.

SO I moved the apt directory and created a blank one

$ sudo mv /var/lib/apt /var/lib/apt.orig
$ sudo mkdir /var/lib/apt

then I updated apt

$ sudo apt update
Get:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Get:3 http://archive.canonical.com/ubuntu xenial InRelease [11.5 kB]
...
Get:119 http://us.archive.ubuntu.com/ubuntu xenial-security/multiverse amd64 DEP-11 Metadata [212 B]
Get:120 http://us.archive.ubuntu.com/ubuntu xenial-security/multiverse DEP-11 64x64 Icons [29 B]
Fetched 55.2 MB in 1min 13s (748 kB/s)
AppStream cache update completed, but some metadata was ignored due to errors.
Reading package lists... Done
Building dependency tree... Done
20 packages can be upgraded. Run 'apt list --upgradable' to see them.
$

Now despite the complaint above ("AppStream cache update completed, but some metadata was ignored due to errors.") software-updater works; it lists the upgradeable packages.

The only subdirectory that got recreated under /var/lib/apt is /var/lib/apt/lists (and its subdirectory)

SO I blew away the directory and copied everything except the lists directory and updated again

$ sudo rm -R /var/lib/apt
$ sudo cp -R /var/lib/apt.orig /var/lib/apt
$ sudo rm -R /var/lib/apt/lists/
$ sudo apt update
Get:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Get:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
...
Get:120 http://us.archive.ubuntu.com/ubuntu xenial-security/multiverse DEP-11 64x64 Icons [29 B]
Fetched 55.2 MB in 1min 13s (747 kB/s)
AppStream cache update completed, but some metadata was ignored due to errors.
Reading package lists... Done
Building dependency tree
Reading state information... Done
20 packages can be upgraded. Run 'apt list --upgradable' to see them.
$

I got the same error, HOWEVER Software Updater is blank again.

I tried deleting the /var/lib/apt/periodic directory and updating

$ sudo rm -R /var/lib/apt/periodic/
$ sudo mkdir /var/lib/apt/periodic
$ sudo apt update
Hit:1 http://archive.canonical.com/ubuntu xenial InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:3 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:6 http://us.archive.ubuntu.com/ubuntu xenial-security InRelease
Hit:7 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:5 http://screenshots.getdeb.net xenial-getdeb InRelease
Reading package lists... Done
Building dependency tree
Reading state in...

Read more...

I haven't seen it since, but I also have not seen a fix so IMO it is still a bug that needs to be fixed.

Eric Siegerman (eric97) wrote :
Download full text (3.6 KiB)

I've been seeing this for some time -- probably since July, but I'm not sure. (Just back from a month or so offline, so my memory is fading.)

Thanks to @tommy-trussell for narrowing it down to /var/lib/apt/extended_states. I believe I've narrowed it further; on my system, deleting a few specific entries from that file is enough to make update-manager display the updates again. But *which* specific entries is ... interesting.

Summary
=======

These are the entries that need to be removed:
    linux-signed-image-4.13.0-43-generic
    linux-image-extra-4.13.0-43-generic
    linux-signed-image-4.13.0-45-generic
    linux-image-extra-4.13.0-45-generic
    linux-modules-extra-4.15.0-24-generic

But note that installing the pending kernel updates caused a non-obvious addition to this list.

Details
=======

My system is:
    $ cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=16.04
    DISTRIB_CODENAME=xenial
    DISTRIB_DESCRIPTION="Ubuntu 16.04.5 LTS"

    In case it matters:
      - It's an EFI system
      - Xenial was a clean install, not an upgrade over an earlier version

At the start of my investigation:
    $ uname -a
    Linux shekere 4.15.0-29-generic #31~16.04.1-Ubuntu SMP Wed Jul 18 08:54:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

    The installed packages that appear to be relevant were:
        linux-image-extra-4.13.0-43-generic
        linux-image-extra-4.13.0-45-generic
        linux-modules-extra-4.15.0-24-generic
        linux-modules-extra-4.15.0-29-generic
        linux-signed-image-4.13.0-43-generic
        linux-signed-image-4.13.0-45-generic
    (There were also corresponding versions of linux-image and linux-headers, but those don't seem to matter re. this bug).

    Deleting *all* of the following four entries from extended_states made update-manager work properly:

 Package: linux-signed-image-4.13.0-43-generic
 Architecture: amd64
 Auto-Installed: 1

 Package: linux-image-extra-4.13.0-43-generic
 Architecture: amd64
 Auto-Installed: 1

 Package: linux-signed-image-4.13.0-45-generic
 Architecture: amd64
 Auto-Installed: 1

 Package: linux-image-extra-4.13.0-45-generic
 Architecture: amd64
 Auto-Installed: 1

I then installed the pending kernel-related updates:
    Of the many updates waiting to be installed were these:

        linux-headers-4.15.0-33
        linux-headers-4.15.0-33-generic
        linux-image-4.15.0-33-generic
        linux-modules-4.15.0-33-generic
        linux-modules-extra-4.15.0-33-generic

    I:
        1. reverted to the status-quo-ante version of extended_status (which of course caused update-manager to misbehave again)
        2. manually installed those five packages
        3. tested
        4. rebooted into the new kernel
        5. tested again

    As expected, the reboot made no difference; same results at steps (3) and (5).

    Here's how things stand now:

 $ uname -a
 Linux shekere 4.15.0-33-generic #36~16.04.1-Ubuntu SMP Wed Aug 15 17:21:05 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

 extended_states did *not* acquire any new entries for the -4.15.0.33 packages. (Perhaps this is because I "apt install"ed them, instead of letting dist-upgrade do it?)

 To...

Read more...

Eric Siegerman (eric97) wrote :

Update to my previous comment:

When the updates for Linux 4.15.0-34-generic became available (but before installing them), I retried some of these tests, and could no longer reproduce the problem.

I re-added each of those problematic /var/lib/apt/extended_states entries in turn; in each case, update-manager continued to display the pending updates as it should do.

(I didn't think until too late to try re-adding all of the problematic entries at once -- but then, that hadn't been necessary previously; in my earlier round of testing, any one of them had sufficed to break update-manager.)

Between installing the backlog of updates (as mentioned previously) and then installing quite a few new packages (all user-land stuff -- build dependencies for digikam), I have no idea what perturbed things enough to make a previously solidly reproducible bug go back into hiding. (With the possible exception of kde-pkg-tools, none of those many installs and upgrades was to anything obviously relating to packaging itself.)

Download full text (7.8 KiB)

TL;DR -- today using apt-get autoremove deleted the offensive lines in /var/lib/apt/extended_states and restored the list in software-updater -- though I doubt that will work every time.

Today I saw the blank software-updater list again on this Xenial (Ubuntu 16.04) system.

@eric97's comment caused me to try something OTHER than blow away the file -- I have already installed the latest kernel updates, but apparently didn't get around to removing the outdated ones.

Running apt autoremove worked to restore my updates list. I am not sure whether I had lots of old kernels last time, though I doubt it. I no longer use a separate /boot partition on this machine but back when I USED to I got into the habit of running apt autoremove after kernel updates. (Because it a real PITA when your /boot partition fills up.)

Session transcript (edited lightly):

twt@hostname:~$ sudo apt update
[sudo] password for twt:
Hit:1 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:2 http://archive.canonical.com/ubuntu xenial InRelease
Hit:3 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:5 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:6 http://us.archive.ubuntu.com/ubuntu xenial-security InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
16 packages can be upgraded. Run 'apt list --upgradable' to see them.

twt@hostname:~$ apt list --upgradeable
Listing... Done
chromium-browser/xenial-updates,xenial-security,xenial-security 69.0.3497.81-0ubuntu0.16.04.1 amd64 [upgradable from: 68.0.3440.106-0ubuntu0.16.04.1]
chromium-browser-l10n/xenial-updates,xenial-updates,xenial-security,xenial-security,xenial-security,xenial-security 69.0.3497.81-0ubuntu0.16.04.1 all [upgradable from: 68.0.3440.106-0ubuntu0.16.04.1]
chromium-codecs-ffmpeg-extra/xenial-updates,xenial-security,xenial-security 69.0.3497.81-0ubuntu0.16.04.1 amd64 [upgradable from: 68.0.3440.106-0ubuntu0.16.04.1]
firefox/xenial-updates,xenial-security,xenial-security 62.0+build2-0ubuntu0.16.04.4 amd64 [upgradable from: 62.0+build2-0ubuntu0.16.04.3]
firefox-locale-en/xenial-updates,xenial-security,xenial-security 62.0+build2-0ubuntu0.16.04.4 amd64 [upgradable from: 62.0+build2-0ubuntu0.16.04.3]
initramfs-tools/xenial-updates,xenial-updates 0.122ubuntu8.12 all [upgradable from: 0.122ubuntu8.11]
initramfs-tools-bin/xenial-updates 0.122ubuntu8.12 amd64 [upgradable from: 0.122ubuntu8.11]
initramfs-tools-core/xenial-updates,xenial-updates 0.122ubuntu8.12 all [upgradable from: 0.122ubuntu8.11]
libgit2-24/xenial-updates,xenial-security,xenial-security 0.24.1-2ubuntu0.2 amd64 [upgradable from: 0.24.1-2]
libpam-systemd/xenial-updates 229-4ubuntu21.4 amd64 [upgradable from: 229-4ubuntu21.2]
libsystemd0/xenial-updates 229-4ubuntu21.4 amd64 [upgradable from: 229-4ubuntu21.2]
libudev1/xenial-updates 229-4ubuntu21.4 amd64 [upgradable from: 229-4ubuntu21.2]
systemd/xenial-updates 229-4ubuntu21.4 amd64 [upgradable from: 229-4ubuntu21.2]
systemd-sysv/xenial-updates 229-4ubuntu21.4 amd64 [upgradable from...

Read more...

Scott Palmer (skewty) wrote :

I am having a similar issue where Software Center is showing an empty frame in 18.10. Software Center issues like this originate back in 16.04 days. Much of the same issues exist today.
Desktop support by Canonical seems abysmal now. I guess their IoT and Server farm markets are 99% of their income so Desktop doesn't truly matter to them.

hbchoong (hbchoong) wrote :

Still affecting Bionic & Cosmic also - Confirmed.
I can only hope Scott Palmer (skewty) can eventually be disproved, but to be frank it is getting harder to do so as each day goes by... Please prove me wrong.

Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Will Cooke (willcooke) on 2019-02-05
Changed in gnome-software (Ubuntu):
status: Confirmed → Invalid
hbchoong (hbchoong) on 2019-02-05
Changed in gnome-software (Ubuntu):
status: Invalid → Confirmed
hbchoong (hbchoong) wrote :

...Please prove me (and Scott et al) wrong, NOT right!

This issue has just been confirmed with the latest versions and updates, thought intermittent.
And if any issue is to be deemed invalid, as a courtesy please add justification or references to fix/workarounds.
Otherwise, why allow and waste users' time to report bugs at all?

Will Cooke (willcooke) on 2019-02-05
Changed in gnome-software (Ubuntu):
status: Confirmed → Invalid
Will Cooke (willcooke) wrote :

This is a problem with update-manager, not GNOME Software.

hbchoong (hbchoong) wrote :

Agreed, and thanks for the note.
I have removed GNOME Software from the affected list.

no longer affects: gnome-software (Ubuntu)
Balint Reczey (rbalint) wrote :

@hbchoong If you still see the issue could you please show the output of of "apt list --upgradable" and maybe attach the output of "apt-mark showauto" ?
I can't reproduce it on my VMs but maybe I can with the same package set to upgrade.

hbchoong (hbchoong) wrote :

@rbalint Thanks for looking into this.
I will try to provide the outputs requested when it re-occurs however I'm not sure how they would help - Unfortunately this issue occurs intermittently hence the difficulty in replicating the issue. Upgrades are actually available and upgradeable, just not visible (as per the screen-shots provided by @tommy-trussell).

Meanwhile, you might have some luck referring to @tommy-trussell's output of "apt list --upgradable" above, just in case you missed it...

I just did `sudo apt-get --purge autoremove` and it worked.

To post a comment you must log in.