Scrolled windows in update-manager are too small to read

Bug #1690541 reported by Hrunting on 2017-05-13
262
This bug affects 52 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
High
Unassigned

Bug Description

In update-manager, scrolled windows do not expand properly. Many times, the display will only be one line. I see it on the download progress view, the install details (terminal-like) view, and would-you-like-to-keep-or-replace config differences view. In each one, the details window does not expand to the full height of the window. If the expansion hasn't been done at all, the view will only be one line high, but in the download progress view, it can sometimes be half-height.

Prior reports (https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1623856) indicate that it has been fixed, but that is not the case, and in the prior "fixed" report, the maintainer asked that a new bug be created.

It is very difficult to get screenshots because the window only appears for a short time, but I have attached one such screenshot below.

Versions:
Ubuntu: Zesty
update-manager: 1:17.04.3
aptdaemon: 1.1.1+bzr982-0ubuntu17

Hrunting (ubuntu-hrunting) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Changed in update-manager (Ubuntu):
status: New → Confirmed
anatoly techtonik (techtonik) wrote :

I wonder if Canonical invests into regression tests for user interfaces.

tags: added: zesty
spike speigel (frail-knight) wrote :

Here's another pic. Zesty 17.10 with proposed updates enabled.

spike speigel (frail-knight) wrote :

Forgive me, I meant 17.04

Adolfo Jayme (fitojb) on 2017-06-30
Changed in update-manager (Ubuntu):
importance: Undecided → High
spike speigel (frail-knight) wrote :

Here's another screenshot from today's updating. It appears the issue is intermittent and variable in inner window size. Sometimes it shows one line, sometimes more, bit still doesn't use the entire window space.

James Stevenson (ja7es) wrote :

Here is another screenshot showing that the problem is still happening.

Emanuel de Jesus (emansije) wrote :

Spike, I haven't tested that in a while, but what I recall is that if you expand the details while in the downloading phase, it then expands to a few more lines in the installation phase. Can anyone confirm that? I'll test it and report back, next time I use the updater.

Emanuel de Jesus (emansije) wrote :

I've just confirmed what I stated before, but with a small correction: When expanding the details' area while in the download phase, it uses all the available space, not only a few more lines, and that remains the case during the installation phase. Then, if you happen to close the details' area and open it again, it shows only one line and you can never recover the space, no matter what you do afterwards.

Brian Murray (brian-murray) wrote :

I was able to recreate this bug using the steps in comment #10, after closing the details' area during the download phase and reopening it I saw only one line of the transaction.

Brian Murray (brian-murray) wrote :

When performing another update, after the first one where I closed the details, the size was stuck at one line for only the download phase.

Brian Murray (brian-murray) wrote :

Actually, to be clear it is not the download but installing details that are now stuck at one line.

tags: added: id-597a0a32ed7a7da4a899a20b
PJSingh5000 (pjsingh5000) wrote :

Confirming problem as described in comment #10.

Hrunting (ubuntu-hrunting) wrote :

This problem persists in Ubuntu 17.10 (Artful Aardvark).

tags: added: artful
drunckoder (drunckoder) wrote :

Confirming persistence in Ubuntu 17.10 (Artful Aardvark).

Andy Smith (grifferz) wrote :

Example of this in 17.10 while kernel packages are being updated and trying to see "Details"

Jarno Suni (jarnos) wrote :

Does this occur also when Software Updater is just presenting available updates? Can it show more than 2 rows for details then?

Beren (berencamlost) wrote :

Presenting available updates works as intended. It is the embedded terminal window during applying updates that is broken.

This broken behavior has been present since at least 17.04 alpha/beta, and is present in 17.10 and 18.04. I haven't tried 16.10 but this was working in 16.04.

I have only tested this on Ubuntu Mate, so I don't know if software-updater behaves differently on other flavours.

Cubic PPA (cubic-wizard) wrote :

Also present on "standard" Ubuntu 17.10 using GNOME Shell 3.26.2.

Fredrik Jacobsson (fredrik-o) wrote :

Ahh, yes, the resize output area bug, I remember seeing this some months (a year?) ago. Can't just remember where. Pity you can't browse to see which bugs you have marked as affect you too.

The bug show itself when the program tries to add more visual space vertically. The other way around, resizing down, and resizing horizontally still works.

an screenshot during downloading

and during installing (but there is nothing new)
screenshots are from Ubuntu 17.10.1

Fredrik Jacobsson (fredrik-o) wrote :

Workaround to get some terminal output:

Disable automatic downloads of updated files. The key here is that you need to show details on progress during the download phase as the bug affects the download progress window too, otherwise you'll get the "one-liner".

This bug show itself when:
displaying the download progress area
displaying the terminal output
showing the changes to a configuration file
when doing a Dist upgrade

here the post i made in "ask question" area, with some further description.
https://answers.launchpad.net/ubuntu/+question/663622

clel (clel) wrote :

Also adding an (older) screenshot of the problem. It still exists.

I am not sure, but I think this only happens on upgraded installation, not on new Ubuntu installs. Can someone confirm this?

Unfortunately it seems that Ubuntu does not have much manpower to get such easy but annoying issues fixed fast.

Andy Smith (grifferz) wrote :

No, it still happens for me on a clean install of 17.10.

To post a comment you must log in.