linux-4.4.0-77.98 was a phased update in -updates only and may become partially installed (was: 4.4.0-77-generic breaks internet on 16.04.2)

Bug #1687623 reported by Mark on 2017-05-02
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

Hi as per title today I updated to 4.4.0-77-generic on my Lubuntu 16.04.02 and wifi is not working anymore. When I click on the network manager I see "enable networking" (which is toggled) but no more the option about wifi.

I reported this on ubuntuforum: https://ubuntuforums.org/showthread.php?t=2360216

Where a user suggested to revert to an older kernel and see if this fixes the problem. I managed to revert to 4.4.0-75-generic via grub and everything works perfectly.

Another user reported a similar issue caused by the same upgrade on the same system: https://ubuntuforums.org/showthread.php?t=2360215

Can someone else confirm this bug?

If you need more information I will be happy to provide it (I am a newbie though so please be patient).

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1687623/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
tags: added: regression-update
affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu):
importance: Undecided → High
status: New → In Progress
Changed in linux (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Joseph Salisbury (jsalisbury)
Joseph Salisbury (jsalisbury) wrote :

We would like to collect some additional information about your system. From a terminal, please run the following:

apport-collect 1687623

Mark (mago90) wrote :

I tried that command but it asking me to authorize launchpad to access on my behalf, which does not seem to be a very safe thing to do. What info do you need?

Joseph Salisbury (jsalisbury) wrote :

Could you write the apport data to a file and attach it then? It can be done with:

apport-bug --save /tmp/report.1687623 linux

Joseph Salisbury (jsalisbury) wrote :

At a minimum it would be good to have:

lspci -vvvnn output and dmesg output.

Joseph Salisbury (jsalisbury) wrote :

Also, I started a bisect between 4.4.0-75 and 4.4.0-77. It would require testing about 5 test kernels, but will tell us the exact commit that introduced the regression.

I built the first test kernel up to commit:
6f997d52ab4ccc78727a2ed098db24d685482ed7

It can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1687623/

Can you give this kernel a test and see if it resolves the bug? To install it, you need both the linux-image and linux-image-extra .deb packages.

Thanks in advance!

Mark (mago90) wrote :
Download full text (13.0 KiB)

lspci -vvvnn output:
The apport bug report was attached
---------------------
00:00.0 Host bridge [0600]: Intel Corporation Sky Lake Host Bridge/DRAM Registers [8086:1904] (rev 08)
 Subsystem: Hewlett-Packard Company Skylake Host Bridge/DRAM Registers [103c:80a4]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
 Latency: 0
 Capabilities: <access denied>

00:02.0 VGA compatible controller [0300]: Intel Corporation Sky Lake Integrated Graphics [8086:1916] (rev 07) (prog-if 00 [VGA controller])
 DeviceName: Intel Skylake HD Graphics ULT GT2
 Subsystem: Hewlett-Packard Company Skylake Integrated Graphics [103c:80a4]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 130
 Region 0: Memory at 92000000 (64-bit, non-prefetchable) [size=16M]
 Region 2: Memory at a0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at 5000 [size=64]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: i915_bpo
 Kernel modules: i915_bpo

00:04.0 Signal processing controller [1180]: Intel Corporation Skylake Processor Thermal Subsystem [8086:1903] (rev 08)
 Subsystem: Hewlett-Packard Company Skylake Processor Thermal Subsystem [103c:80a4]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at 94320000 (64-bit, non-prefetchable) [size=32K]
 Capabilities: <access denied>
 Kernel driver in use: proc_thermal
 Kernel modules: processor_thermal_device

00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller [8086:9d2f] (rev 21) (prog-if 30 [XHCI])
 Subsystem: Hewlett-Packard Company Sunrise Point-LP USB 3.0 xHCI Controller [103c:80a4]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 126
 Region 0: Memory at 94300000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: <access denied>
 Kernel driver in use: xhci_hcd

00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Thermal subsystem [8086:9d31] (rev 21)
 Subsystem: Hewlett-Packard Company Sunrise Point-LP Thermal subsystem [103c:80a4]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin C routed to IRQ 11
 Region 0: Memory at 94332000 (64-bit, non-prefetchable) [size=4K]
 Capabilities: <access denied>

00:16.0 Communication controller [0780]: Intel...

tags: added: kernel-key
RobotOfBarr (rwall) wrote :

Wifi the same for me, also screen resolution set to 640 x 480 and no other choice, brightness setting not honoured.

Reverted to -75 kernel, all OK.

Machine: Asus laptop X552CL

Till Straumann (strauman) wrote :

I just upgraded to -77 and (on a 2009 Macbook pro 17") the keyboard/mouse was unresponsive.
Reverting to -75 fixed this.

Joseph Salisbury (jsalisbury) wrote :

I'd like to bisect this issue. Can folks affected by this bug test the kernel posted in comment #6? I'll then build then next test kernel based on testing results.

Joseph Salisbury (jsalisbury) wrote :

Also, Till and RobotOfBarr, can you post your hardware details? See comments 4 and 5.

Stefan Bader (smb) wrote :

Additionally (due to personal experience) it might be worth checking whether linux-image-extra-4.4.0-77* got installed. Not sure how that could happen but it seems update-manager offered to install linux-image and linux-image-signed without any of the other packages which should be installed at the same time (I had no headers either which impacts anything dkms related).
This morning, from an older kernel boot, an "sudo apt-get update; sudo apt-get dist-upgrade" was installing the missing kernel packages.

Tomas (gaslight) wrote :

I have similar issues with 4.4.0-77-generic, except that after the update no hardware is recognized at all. Ubuntu doesn't see my monitors, wired network card, etc. While booting with 4.4.0-75-generic has no such problems.

I have the same issue, no Ethernet, connection and low display resolution which I was unable to change (1024 × 768 I think). Rebooting on .75 kernel resolved the issues. Attached report as suggested in reply #4 (this is done after rebooting to the .75 kernel, if it makes a difference I can reboot to .77 and create a new report).

Stefan Bader (smb) wrote :

@Thomas, Jacob,

and "dpkg -l|grep 4.4.0-77", does that show and linux-image-extra or not? If not, try the manual update I described in comment #12 from the -75 kernel.

@Stefan thanks, that did indeed solve the problem for me. I thought I checked that it was installed before I reported the issue but I must've misread.

Tomas (gaslight) wrote :

@Stefan, thank you. I can also confirm that linux-image-extra was not installed (I used Ubuntu Software Updater to do original upgrade) and running apt dist-upgrade solved the issue.

Kay (ksthiele) wrote :

I also have to revert to 4.4.0-75 from Grub since My resolution changed to 640x480 (I think) and I was stuck in a login loop

Carlo (lewstherin) wrote :

Same issue here, no Wi-Fi or ethernet connection working.
No resolution problems, but when I restarted after the update I noticed the dimension of the Launcher icons was different than usual (it's usually set at 38, after the update it was switched to 48 or something like that).
Getting back to 4.4.0-75 from Grub makes everything go back to normal.
I'd like to help if possible, but I'm a REAL newbie on Ubuntu!

Stefan Bader (smb) wrote :

In general, it seems that for some reason there was a period of time (on a different box update-manager would offer me the complete set of packages) when for some unknown reason update-manager would offer only the minimal kernel and modules. This causes all sorts of HW related issues if the driver modules are either in the extra package or (like in the case of nvidia binary driver) are built on the system after updating the kernel (but that requires the headers).

For a start, when was the kernel update (for the 4.4.0-77 kernel which broke things) being offered? Yesterday at some point? And if anyone can remember, was there any hint shown that this would not be complete (like partial upgrade)?

Andy Whitcroft (apw) wrote :

The linux-4.4.0-77.98 was released to -updates only. It appears that this then lead to it being marked for phased updates. The affected people appear to have phased linux-signed only and not linux and linux-meta. This leads to linux-signed-image-4.4.0-77-generic (and its dependencies) to be installed only. This essentially leaves the user with half a kernel with many drivers missing. This leads to broken internet and the like.

We have phased this update fully to avoid this occurring to any other machines. We have also changed the release process to prevent phased kernel releases in the future. I am creating an update-manager task as this needs to be fixed as there are certainly other packages which could trigger this behaviour.

update-manager should offer a correct fully phased update now once booted into the previous kernel. Also the "apt-get dist-upgrade" solution is valid and will resolve the issue.

summary: - 4.4.0-77-generic breaks internet on 16.04.2
+ linux-4.4.0-77.98 was a phased update in -updates only and may become
+ partially installed (was: 4.4.0-77-generic breaks internet on 16.04.2)
Andy Whitcroft (apw) wrote :

The analysis in the bug below may be of interest when fixing this:
    https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1214482

Frans Ketelaars (frans-2) wrote :

I just updated Ubuntu 16.04.2 kernel 4.4.0-75. New linux-image-4.4.0-77-generic was installed along with the corresponding linux-image-extra and linux-headers. After reboot both WiFi and ethernet work.

RobotOfBarr (rwall) wrote :

Sorry I didn't reply earlier - I'm in UK.
I've just now (1250 UTC on 3 May) used Software Updater from 4.4.0.75 and all is now OK.
Many thanks to all concerned.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu Xenial):
status: New → Confirmed
Changed in update-manager (Ubuntu):
status: New → Confirmed
Stephen Cheong (stephen-mhc) wrote :

Also encountered very similar problem.

I'm using Acer Aspire V7 laptop with Ubuntu 16.04 LTS. An update popped up, but I wasn't quite aware of what the update was about.

Restarted my computer, and then both wifi and ethernet connections stopped working. The situation matches with the bug description. "Enable Networking" checked, but no "Enable Wi-Fi".

Both wireless and ethernet cards were detected, but no kernel modules seemed to be in use.

Also, screen brightness could not be changed. The Logitech wireless mouse and the laptop touch screen stopped working.

Same as what's mentioned, no such problems if after reverting to 4.4.0-75-generic.

Free Beachler (tenacious) wrote :

What a pain! I was affected by this issue and lost all network drivers, wifi and wired. I had to use another computer with functional networking to reckon how to enable the grub boot menu; then boot to kernel v.75; then follow comment #12.

Anybody know who is not affected by this issue, or is everybody affected?

Is there a fix scheduled or is everybody affected by this issue expected to realize how to reboot to kernel 75, then apply the workaround in comment #12?

Mark (mago90) wrote :

I think the issue regards Ubuntu 16.04.2 and its flavor Lubuntu, no idea about the others, I am on 64bit.

I did as #12 suggested will let you know how I does.

Mark (mago90) wrote :

Everything seems to be fixed now!
Don't know if it is still relevant but when the "broken" update came out the system did not show up any warning on potential missing libs or that it was an incomplete update. Thank you!

Bryan Smith (bryan-smith) wrote :

I have also experienced the same fault apparently with kernel linux-image-4.4.0-77. The problems I noted was no wired network connection, no sound and what appears to be a default low resolution video mode. I was able to get the system to work normally by choosing an earlier kernel from grub menu.

Is deleting the offending kernel the long term fix for this problem?

Jos (jackall69) wrote :

@Bryan Smith - dist-upgrade in Terminal should fix the problem, you will get the full kernel. I had this problem on Xubuntu 16.04 (and would have affected anyone on *buntu 16.04 updating through the Software Updater).

Bryan Smith (bryan-smith) wrote :

If I type "dist-upgrade" and press enter I get:
dist-upgrade: command not found.

Do I need to install some additional package to run this command?

Mark (mago90) wrote :

I did: sudo apt-get dist-upgrade and it fixed my issues.

Bryan Smith (bryan-smith) wrote :

I ran the command "sudo apt-get dist-upgrade" and it fixed my issues. (I did not need to run dist-upgrade separately.)

I suspect that a large number of UBUNTU users will have been affected by this issue. Accordingly I think that this fix needs to be published as widely as possible.

Stefan Bader (smb) wrote :

Update-manager is fixed now and as Andy wrote, a change in the process should prevent this from ever happening again. Unfortunately that does not help anybody who is already having the problem (at least not if that means no network connection). And without network it is hard to find any documents about this on the net.

If network is not affected the remaining kernel packages will get offered by update-manager (the same way as the apt-get variant). If it is affected one needs to boot into the previous kernel and I personally wished the grub boot menu were not hidden away by default (pressing left-shift at the exactly right time is something I never manage to do). As long as it is possible to login into the broken system can be enabled by modifying /etc/default/grub (commenting out the two lines with GRUB_HIDDEN_... and uncommenting, if needed, the GRUB_TIMEOUT line, setting it to 5 (seconds)), then "sudo update-grub" and reboot.

Jos (jackall69) wrote :

@Bryan Smith Sorry Bryan I should have been clearer. It is usual when updating/upgrading via the terminal to start with

sudo apt-get update

this downloads the most recent list of packages from the repo, followed by

sudo apt-get dist-upgrade

Apologies for any confusion I may have caused.

Mark (mago90) wrote :

Thanks for the fix Stefan! If I wasn't on dual-boot it would have been a nightmare trying to fix it without internet.

I had no issue with screen resolution so I suppose not everyone is affected in the same way.

Maybe ubuntu admins could post an announce on the home page of the forum to warn users?

tags: added: kernel-da-key
removed: kernel-key
Mike Krall (mkrall-wyo) wrote :

Posting because I ran into what I feel is the same problem between 4.8.0-52 and 4.8.0-53.

4x large login screen... no mouse... no touchpad. Could login. Desktop 4x large. Took me a while to find this thread (had been trying unsuccessfully to catch GRUB-2 Menu with Shift key, also): https://ubuntuforums.org/showthread.php?t=2360292

Followed ajgreeny post #2, #4, #6... appears fixed now.

Frans Ketelaars (frans-2) wrote :

I just ran Software Updater and after reboot I am now running kernel 4.8.0-53-generic without problems.

Changed in linux (Ubuntu Xenial):
status: In Progress → Incomplete
Changed in linux (Ubuntu):
status: In Progress → Incomplete
assignee: Joseph Salisbury (jsalisbury) → nobody
Changed in linux (Ubuntu Xenial):
assignee: Joseph Salisbury (jsalisbury) → nobody
Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers