/usr/bin/update-manager:AttributeError:/usr/bin/update-manager@117

Bug #1681939 reported by errors.ubuntu.com bug bridge on 2017-04-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
munna.ak17
Yakkety
Medium
Brian Murray

Bug Description

Impact
------
Users upgrading from Xenial to Yakkety may experience a crash running update-manager (after the upgrade) if it has been upgraded but python3-gi is not upgraded.

Test Case
---------
This was just a dependency change in update-manager so the python line numbers in the Traceback will not change. Subsequently, viewing the Errors bucket and confirming that the new version of update-manager does not appear in it will be sufficient.

The Ubuntu Error Tracker has been receiving reports about a problem regarding update-manager. This problem was most recently seen with package version 1:16.10.9, the problem page at https://errors.ubuntu.com/problem/78e1b63ebdb0df37a8e0ace381df3f7b2786a2e5 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker you can request it at http://forms.canonical.com/reports/.

Brian Murray (brian-murray) wrote :

Here's the Traceback:

Traceback (most recent call last):
  File "/usr/bin/update-manager", line 117, in <module>
    settings.set_int64("launch-time", int(time.time()))
AttributeError: 'Settings' object has no attribute 'set_int64'

This can happen if update-manager is upgraded but python3-gi is not.

Changed in update-manager (Ubuntu):
status: New → Invalid
Changed in update-manager (Ubuntu Yakkety):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu):
status: Invalid → Incomplete
Jason Pereira (jasondpereira) wrote :

Brian,

It looks like this updated update-manager-core package was not checked into the Trusty repo. I am running Ubuntu 14.04 using the Trusty public archive repos. I am getting the following error when performing a update on update-manager-core.

root@*********:~# apt-get download update-manager-core
E: Can't find a source to download version '1:0.196.22' of 'update-manager-core:amd64'
root@*********:~#

If you need any additional details let me know.

Brian Murray (brian-murray) wrote :

There was an issue getting update-manager version 1:0.196.23 into the archive, this should be resolved now but may take a bit to propagate to your mirror.

Changed in update-manager (Ubuntu):
status: Incomplete → Invalid
Jason Pereira (jasondpereira) wrote :

Brian,

I see that package was added to the repo on 2017-04-05 per the status page for update-manager. I still do not see the package 13 days later. Can you verify the package was added to the repo.

Jason Pereira (jasondpereira) wrote :

Brian,

Thank you for your help everything seems to be working as normal once again.

Hello errors.ubuntu.com, or anyone else affected,

Accepted update-manager into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:16.10.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-manager (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
description: updated
Brian Murray (brian-murray) wrote :

The errors bucket looks good and likely only contains noise.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:16.10.10

---------------
update-manager (1:16.10.10) yakkety; urgency=medium

  * Bump the python3-gi dependency so that set_int64 is available thereby
    avoiding a crash if update-manager is updated but not python3-gi.
    (LP: #1681939)

 -- Brian Murray <email address hidden> Tue, 11 Apr 2017 14:04:31 -0700

Changed in update-manager (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in update-manager (Ubuntu):
importance: Undecided → Medium
status: Invalid → Fix Released
munna.ak17 (munna.ak17) on 2017-06-01
Changed in update-manager (Ubuntu):
assignee: nobody → munna.ak17 (munna.ak17)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers