distribution upgrade buggy(apparent hangs)

Bug #163606 reported by santana on 2007-11-18
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Hi I again tried the distribution upgrade via adept_manager. (a couple weeks ago I tried the pre-release on my laptop it crashed after like 2 minutes leaving my machine with no X11) Is it me or is this the buggiest release of ubuntu ever? This time, during the preparing the upgrade step that application appears to hang, showing no signs of life for long periods of time during the fetch files process. The progress bar is stuck no movement for periods of 5min at a time or longer. No signs of life. I probably would have thought less of this had it not happened on the first file fetch. Also I have probably one of the fastest connections available as I work in a research computing group at a university, we have all gig switches dedicated fiber, and no one is here but me on a saturday night at 6pm. When I see an app that is downloading with no progress bar motion it makes me think crash, deadlock etc.. and I cancel. After a couple of tries I noticed that it would apprently hang for 5 minutes or so then blindingly fast zip through a few more downloads and apparently hang again. I let it go all night, only to have some other issue about not able to verify some packages, my internet connection might be down,(but of course it wasn't) and they were like standard KDE apps so something was up there too. Sorry for the long rant here but my vote is for a later release of a more stable product.

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in adept.

Changed in adept:
importance: Undecided → High
importance: High → Medium
tz (thomas-mich) wrote :

Much the same thing. The whole process is horrible. I've tried 20 times (yes, literally 20 times) so have 20 /tmp/turds all with the same failed program. It used to run partway then timeout, then fail. Each of these attempts take 10-20 minutes. I COULD do "apt-get dist-upgrade", but that is hidden, and now after about 5 minutes it says some packages couldn't be authenticated, but provides LESS information on how to correct the problem than most windows programs. (Some packages could not be authenticated - basically a list of apparently every package - then it does an undo - and it says it is a transient problem).

I could burn a CD or DVD with the entire upgrade, but you don't provide that option either, only system-wipe images. Didn't anyone tell you to put your files in /home? So sorry, you can never downgrade now... Last time, half my hardware broke, so I've imaged the drive.

This is really stupid. Can't anyone there figure out to download the dist-upgrade files ONCE to /var/lib/cache so it doesn't spend 20 minutes downloading the same tools, same lists, same everything when it fails? And not ask the same stupid questions or give the same stupid notifications? You demand a perfect connection for several hours as a condition of upgrading? This is stupid. You download several megabytes per failed attempt. This is also stupid. Yea, if it works perfectly it works, but no one has bothered about gracefully being able to retry. No retrys for any failure (like a loose ethernet plug) is stupid. Maybe a proxy or firewall is blocking something, but never being able to find out is stupid. Not having a way of finding a log - assuming you create one is stupid. There is the "Terminal" but that only gets turned on at the end.

(and yes, the problem might be my wireless connection, which is open, but why I'm upgrading, but my ethernet port which works is firewalled)

I regularly compile kernel modules with modifications, but you bury things so deeply and give NO meaningful feedback that I can't even fix Ubuntu anymore. And if I dare upgrade outside of your official method, everything will probably break completely.

I only have to do the upgrade once. The problem is I'm now on my 23rd try.

Zack Evans (zevans23) wrote :

I have just come here to report the same thing - I was going to tag it wishlist. It does seem suboptimal that the update-manager spends 10 minutes re-downloading the package lists EVERY time you run it... what's wrong with the apt cache, guys, isn't that what it's there for? In fact, how did we end up with a package manager that COULD fail to use the cache?

Since you've already triaged this one I won't raise a new bug but I second this one strongly.

Ahmad Tarek (ahmadtarek) wrote :

I think this problem is no more exist in newer Ubuntu versions - I am working on Natty Beta 2. Please make it new if it still exists.

Changed in update-manager (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for update-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in update-manager (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers