[apport] package update-manager failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): installArchives() failed

Bug #162138 reported by Scott Severance on 2007-11-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

Got this when trying to upgrade to Gutsy from the alternate install CD.

ProblemType: Package
Date: Sun Nov 11 23:01:38 2007
ErrorMessage: ErrorMessage: SystemError in cache.commit(): installArchives() failed

Package: update-manager
SourcePackage: update-manager

Pedro Villavicencio (pedro) wrote :

Thanks for your report, Can you please attach the files in /var/log/dist-upgrade/ ? thanks.

Changed in update-manager:
assignee: nobody → pvillavi
importance: Undecided → Medium
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in update-manager:
status: Incomplete → Invalid

Somehow I missed your request for more information. I'm attaching the files you requested, but since I've now completed the upgrade, some data may have been overwritten.

When I filed the bug, I guessed that it might be incomplete, but I wasn't able to find the relevant log files. Perhaps a note somewhere about the location of the needed files would be appropriate.

Changed in update-manager:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

Try running apt-get update and then the dist-upgrade again, it seems to be a problem with your network connection and not an update-manager bug, thanks.

Changed in update-manager:
status: New → Invalid

I've upgraded by now. I believe that this *is* an update-manager bug, because update-manager crashed. Update-manager shouldn't crash if there's a network problem. Besides, I upgraded from the alternate CD, so any network interaction was minimal.

I understand that sometimes there's not enough information to find a bug in a particular bug report, but blaming a crash on the network and claiming it isn't a bug makes it appear that you haven't really understood the bug report.

Changed in update-manager:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

Leave it as open then, the developer should take a look to it.

Changed in update-manager:
assignee: pvillavi → nobody

Scott, the network issue and the crash are unrelated. The crash occurred at 23:01 and the network issue during the next run which has ended correctly.

I've not seen any recent duplicate about this kind of issue. Have you been able to reproduce it ?

Thanks in advance.

Changed in update-manager:
status: New → Incomplete

I haven't been able to reproduce this issue (I haven't really tried--especially since I don't know a recipe to reproduce it, the machine that experienced the problem is now a pile of parts, and both of my working machines are now running Intrepid). It appears that crucial debugging info might have been lost since I couldn't find the relevant logfiles until Pedro requested them after I'd already completed the upgrade and presumably overwritten key info.

So, given that it's a bit difficult to track down non-reproducible bugs, perhaps the focus of this bug could be shifted to providing better information in apport on what files might be relevant to attach.

Thank you for following up. I'm closing this report because there is no recent duplicate nor user mentioning having the issue on Intrepid and key info have been lost in time.

apport have been greatly improved since this report and now crucial informations are automatically gathered and attached to the report.

Thanks again and don't hesitate to submit any new bug.

Changed in update-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers