HWE upgrade to lts-xenial stack fails if fglrx is installed

Bug #1617448 reported by IbraM on 2016-08-26
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Unassigned
Trusty
High
Brian Murray
xorg-server-lts-xenial (Ubuntu)
Undecided
Unassigned
Trusty
High
Brian Murray

Bug Description

Trying to upgrade from the lts-vivid, lts-utopic, or lts-wily stack to the lts-xenial stack as recommended by hwe-support-status creates a situation the apt problem resolver can not sort out due to fglrx being deprecated in 16.04. update-manager should notify you that fglrx is no longer supported, and xserver-xorg-core-lts-xenial should conflict with fglrx packages so the upgrade can succeed.

Test Case
---------
1) Install fglrx on a 14.04 system
2) Install the lts-wily hwe stack
3) Run sudo apt-get install $(hwe-support-status --show-replacements)

You'll encounter an error message like the following:

The following packages have unmet dependencies:
 libgl1-mesa-glx-lts-xenial : Depends: libglapi-mesa-lts-xenial (= 11.2.0-1ubuntu2~trusty1) but it is not going to be installed
 xserver-xorg-lts-xenial : Recommends: xserver-xorg-input-all-lts-xenial but it is not going to be installed
                           Recommends: xserver-xorg-video-all-lts-xenial but it is not going to be installed
                           Recommends: libgles2-mesa-lts-xenial but it is not going to be installed
                           Recommends: libgles1-mesa-lts-xenial but it is not going to be installed
                           Conflicts: libglapi-mesa (>= 0~)
                           Conflicts: libgles2-mesa (>= 0~)

With the version of xserver-xorg-core-lts-xenial the upgrade should be calculated. Additionally, "hwe-support-status --show-all-unsupported" should list the fglrx that are installed. The messaging from hwe-suuport-status should also mention that the fglrx driver is deprecated.

Original Description
-------------------

The bug is described on the ubuntu forum => https://ubuntuforums.org/showthread.php?t=2333884&p=13536493

ProblemType: BugDistroRelease: Ubuntu 14.04
Package: ubuntu-release-upgrader-core 1:0.220.8
ProcVersionSignature: Ubuntu 3.16.0-77.99~14.04.1-generic 3.16.7-ckt27
Uname: Linux 3.16.0-77-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.14.1-0ubuntu3.21
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: XFCE
Date: Fri Aug 26 23:28:52 2016
InstallationDate: Installed on 2015-07-05 (417 days ago)
InstallationMedia: Xubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
PackageArchitecture: allSourcePackage: ubuntu-release-upgrader
Symptom: dist-upgrade
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.update.manager.release.upgrades: 2016-08-09T22:23:11.744680

IbraM (ibramlab) wrote :
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report the bug. Could you also run "apt-clone clone" and then add the resulting apt-clone.tar.gz as an attachment to this bug report? It'd be really helpful.

affects: ubuntu-release-upgrader (Ubuntu) → update-manager (Ubuntu)
Changed in update-manager (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → High
status: New → Incomplete
IbraM (ibramlab) wrote :

'apt-clone clone' tells
====================================================================
not installable: opera-stable, virtualbox-5.0, linux-headers-3.16.0-58-generic, hplip-data, linux-headers-3.16.0-72, printer-driver-hpcups, xubuntu-default-settings, linux-image-3.16.0-74-generic, libhpmud0, linux-image-extra-3.16.0-74-generic, teamviewer:i386, libsane-hpaio, printer-driver-postscript-hp, linux-headers-3.16.0-72-generic, linux-headers-3.16.0-58, linux-headers-3.16.0-74, linux-headers-3.16.0-74-generic, linux-signed-image-3.16.0-74-generic, dvd+rw-tools, growisofs, hplip
version mismatch:

Note that you can use --with-dpkg-repack to include those packges in the clone file.
====================================================================
offtopic: Seems we have a typo in 'packages' at the last line of apt-clone output.

Changed in update-manager (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu):
status: Incomplete → Invalid
assignee: Brian Murray (brian-murray) → nobody
summary: - update-manager crashes
+ HWE upgrade to 16.04 stack fails if fglrx is installed
summary: - HWE upgrade to 16.04 stack fails if fglrx is installed
+ HWE upgrade to lts-xenial stack fails if fglrx is installed
description: updated
affects: xorg-lts-transitional (Ubuntu) → xorg-lts-xenial (Ubuntu)
Changed in xorg-lts-xenial (Ubuntu):
status: New → Invalid
Changed in xorg-lts-xenial (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)

Hello IbraM, or anyone else affected,

Accepted update-manager into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:0.196.21 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-manager (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Hello IbraM, or anyone else affected,

Accepted xorg-server-lts-xenial into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xorg-server-lts-xenial/2:1.18.3-1ubuntu2.2~trusty3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

affects: xorg-lts-xenial (Ubuntu Trusty) → xorg-server-lts-xenial (Ubuntu Trusty)
Changed in xorg-server-lts-xenial (Ubuntu Trusty):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Setting up python3-update-manager (1:0.196.21) ...
Setting up update-manager-core (1:0.196.21) ...
Setting up update-manager (1:0.196.21) ...
bdmurray@upgrade-trusty-amd64:~$ hwe-support-status

WARNING: Security updates for your current Hardware Enablement Stack
ended on 2016-08-04:
 * http://wiki.ubuntu.com/1404_HWE_EOL

There is a graphics stack installed on this system. An upgrade to a
configuration supported for the full lifetime of the LTS will become
available on 2016-07-21 and can be installed by running 'update-manager'
in the Dash.

The fglrx driver which you have installed was deprecated in 16.04,
if you install the 16.04 Hardware Enablement stack the driver will be
removed. See the wiki page for details.

bdmurray@upgrade-trusty-amd64:~$ hwe-support-status --show-all-unsupported | grep fglrx
xserver-xorg-core-lts-wily fglrx xserver-xorg-video-neomagic-lts-wily
xserver-xorg-video-vesa-lts-wily fglrx-core

That's part of the verification.

Brian Murray (brian-murray) wrote :

With -proposed enabled I was able to use 'sudo apt-get install $(hwe-support-status --show-replacements)' to upgrade to the 16.04 HWE stack even though I had fglrx installed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.196.21

---------------
update-manager (1:0.196.21) trusty-proposed; urgency=medium

  * hwe-support-status: Deal with the fact that fglrx was deprecated in 16.04
    so will not work with the Xenial 16.04 HWE stack. (LP: #1617448)

 -- Brian Murray <email address hidden> Mon, 29 Aug 2016 16:13:22 -0700

Changed in update-manager (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server-lts-xenial - 2:1.18.3-1ubuntu2.2~trusty3

---------------
xorg-server-lts-xenial (2:1.18.3-1ubuntu2.2~trusty3) trusty; urgency=medium

  * Add conflicts for fglrx, fglrx-core, fglrx-updates, and fglrx-updates-core
    because support for fglrx was removed in 16.04. (LP: #1617448)

 -- Brian Murray <email address hidden> Fri, 26 Aug 2016 15:21:51 -0700

Changed in xorg-server-lts-xenial (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers