kernel 4.4.0-31 install broken

Bug #1603845 reported by Tony Mangefeste on 2016-07-18
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Unassigned

Bug Description

Today, I was prompted to install an OS update. I chose to accept. What happened next is wholly unacceptable. If I were a non-techie user, I'd be up a creek trying to fix my problem. See the log below, and scroll down for an explanation:

>>>

Start-Date: 2016-07-16 14:13:23
Commandline: aptdaemon role='role-commit-packages' sender=':1.225'
Install: linux-headers-4.4.0-31-generic:amd64 (4.4.0-31.50, automatic), linux-headers-4.4.0-31:amd64 (4.4.0-31.50, automatic), linux-signed-image-4.4.0-31-generic:amd64 (4.4.0-31.50, automatic), linux-image-4.4.0-31-generic:amd64 (4.4.0-31.50, automatic), linux-image-extra-4.4.0-31-generic:amd64 (4.4.0-31.50, automatic)
Upgrade: libmpx0:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libgcc-5-dev:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), language-pack-gnome-en:amd64 (1:16.04+20160415, 1:16.04+20160627), linux-headers-generic:amd64 (4.4.0.28.30, 4.4.0.31.33), gir1.2-gtk-3.0:amd64 (3.18.9-1ubuntu3, 3.18.9-1ubuntu3.1), linux-libc-dev:amd64 (4.4.0-28.47, 4.4.0-31.50), libnss3-nssdb:amd64 (2:3.21-1ubuntu4, 2:3.23-0ubuntu0.16.04.1), libgtk-3-common:amd64 (3.18.9-1ubuntu3, 3.18.9-1ubuntu3.1), grub-common:amd64 (2.02~beta2-36ubuntu3, 2.02~beta2-36ubuntu3.1), linux-image-generic:amd64 (4.4.0.28.30, 4.4.0.31.33), libgtk-3-0:amd64 (3.18.9-1ubuntu3, 3.18.9-1ubuntu3.1), libgd3:amd64 (2.1.1-4ubuntu0.16.04.1, 2.1.1-4ubuntu0.16.04.2), cpp-5:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), python2.7-minimal:amd64 (2.7.11-7ubuntu1, 2.7.12-1~16.04), binutils:amd64 (2.26-8ubuntu2.1, 2.26.1-1ubuntu1~16.04), libarchive13:amd64 (3.1.2-11ubuntu0.16.04.1, 3.1.2-11ubuntu0.16.04.2), linux-signed-image-generic:amd64 (4.4.0.28.30, 4.4.0.31.33), libitm1:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libpython2.7:amd64 (2.7.11-7ubuntu1, 2.7.12-1~16.04), python2.7:amd64 (2.7.11-7ubuntu1, 2.7.12-1~16.04), grub2-common:amd64 (2.02~beta2-36ubuntu3, 2.02~beta2-36ubuntu3.1), libcilkrts5:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), flashplugin-installer:amd64 (11.2.202.626ubuntu0.16.04.1, 11.2.202.632ubuntu0.16.04.1), libasan2:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), language-pack-en:amd64 (1:16.04+20160415, 1:16.04+20160627), ecryptfs-utils:amd64 (111-0ubuntu1, 111-0ubuntu1.1), libquadmath0:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), upower:amd64 (0.99.4-2ubuntu0.2, 0.99.4-2ubuntu0.3), dkms:amd64 (2.2.0.3-2ubuntu11, 2.2.0.3-2ubuntu11.1), libnss3-1d:amd64 (2:3.21-1ubuntu4, 2:3.23-0ubuntu0.16.04.1), linux-signed-generic:amd64 (4.4.0.28.30, 4.4.0.31.33), gtk2-engines-murrine:amd64 (0.98.2-0ubuntu2, 0.98.2-0ubuntu2.1), gcc-5-base:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), gcc-5-base:i386 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libstdc++-5-dev:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libtsan0:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), grub-efi-amd64-bin:amd64 (2.02~beta2-36ubuntu3, 2.02~beta2-36ubuntu3.1), libgtk-3-bin:amd64 (3.18.9-1ubuntu3, 3.18.9-1ubuntu3.1), libubsan0:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), g++-5:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libgfortran3:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), language-pack-gnome-en-base:amd64 (1:16.04+20160415, 1:16.04+20160627), gcc-5:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libgail-3-0:amd64 (3.18.9-1ubuntu3, 3.18.9-1ubuntu3.1), liblsan0:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libgomp1:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libupower-glib3:amd64 (0.99.4-2ubuntu0.2, 0.99.4-2ubuntu0.3), grub-efi-amd64:amd64 (2.02~beta2-36ubuntu3, 2.02~beta2-36ubuntu3.1), libgnome-menu-3-0:amd64 (3.13.3-6ubuntu3, 3.13.3-6ubuntu3.1), shim-signed:amd64 (1.12+0.8-0ubuntu2, 1.17~16.04.1+0.8-0ubuntu2), language-pack-en-base:amd64 (1:16.04+20160415, 1:16.04+20160627), grub-efi-amd64-signed:amd64 (1.66+2.02~beta2-36ubuntu3, 1.66.1+2.02~beta2-36ubuntu3.1), libpython2.7-minimal:amd64 (2.7.11-7ubuntu1, 2.7.12-1~16.04), libnss3:amd64 (2:3.21-1ubuntu4, 2:3.23-0ubuntu0.16.04.1), libecryptfs1:amd64 (111-0ubuntu1, 111-0ubuntu1.1), libatomic1:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libcc1-0:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libpython2.7-stdlib:amd64 (2.7.11-7ubuntu1, 2.7.12-1~16.04), libstdc++6:amd64 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), libstdc++6:i386 (5.3.1-14ubuntu2.1, 5.4.0-6ubuntu1~16.04.1), linux-generic:amd64 (4.4.0.28.30, 4.4.0.31.33), lightdm:amd64 (1.18.1-0ubuntu1, 1.18.2-0ubuntu1), libnspr4:amd64 (2:4.11-1ubuntu1, 2:4.12-0ubuntu0.16.04.1), liblightdm-gobject-1-0:amd64 (1.18.1-0ubuntu1, 1.18.2-0ubuntu1), gnome-menus:amd64 (3.13.3-6ubuntu3, 3.13.3-6ubuntu3.1)
End-Date: 2016-07-16 14:17:03

Start-Date: 2016-07-17 18:32:16
Commandline: aptdaemon role='role-commit-packages' sender=':1.111'
Remove: rtl8812au-dkms:amd64 (4.3.8.12175.20140902+dfsg-0ubuntu2)
End-Date: 2016-07-17 18:32:42

Start-Date: 2016-07-17 18:38:07
Commandline: aptdaemon role='role-commit-packages' sender=':1.96'
Install: rtl8812au-dkms:amd64 (4.3.8.12175.20140902+dfsg-0ubuntu2)
End-Date: 2016-07-17 18:39:05

Start-Date: 2016-07-17 18:48:18
Commandline: apt-get autoremove
Requested-By: tonym (1000)
Remove: linux-image-4.4.0-21-generic:amd64 (4.4.0-21.37), linux-image-extra-4.4.0-21-generic:amd64 (4.4.0-21.37)
End-Date: 2016-07-17 18:49:31

<<<<

After the update process finished, it prompted me for a restart. I did that. The system restarted without problem. But then, on reboot, the WIFI stopped working. The driver installer reported that another driver was loaded, but using 'modprobe' did not report that the 'rtl8812au' module was not loaded.

I did some poking around, and then decided to do a 'sudo apt-get update', and the system notified me that updates were pending, and then I did a 'sudo apt-get install -f' to install them, followed by 'sudo apt-get autoremove', which point the OS identified 217MB or dependencies that needed to be updated, and then informed me at the end to do a 'update-grub', which I did.

On reboot the WIFI came back to life. The point is that the install of 4.4-31 was not done completely, or did not complete completely, leaving me system in a half-broken state.

Not acceptable, someone should look into what's going on, and when kernel updates happen they should take great care to make sure the entire chain of events completes.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.14
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Sun Jul 17 19:00:56 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-07-04 (13 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: release-upgrade
UpgradeStatus: No upgrade log present (probably fresh install)

Tony Mangefeste (tonym) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
affects: ubuntu-release-upgrader (Ubuntu) → update-manager (Ubuntu)
Changed in update-manager (Ubuntu):
importance: Undecided → High
mhosken (martin-hosken) wrote :

Still a problem in 4.4.0-34

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers