minimal feisty install fails to upgrade to gutsy

Bug #159444 reported by Nathaniel Smith on 2007-11-02
2
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

I was setting up a new machine, and only happen to have feisty net-install set up on the local network, so I figured I would just install a minimal feisty and then upgrade.

The feisty install went fine, and when it asked what metapackages to install (Gnome desktop, KDE desktop, LAMP server, etc.), I just left all the boxes unchecked.

Then I ran
  aptitude update
  aptitude upgrade # This upgraded 'mount'
  aptitude install update-manager-core
  do-release-upgrade

Which downloaded things, etc., as intended, and then blew up on package 'ttf-opensymbol', whose postinst failed.

Re-running dpkg --configure -a, the message is:

Setting up ttf-opensymbol (1:2.3.0-1ubuntu5) ...
Updating fontconfig cache...
/usr/share/fonts: failed to write cache
/usr/local/share/fonts: failed to write cache
dpkg: error processing ttf-opensymbol (--configure):
 subprocess post-installation script returned error exit status 2
<then more failures from openoffice packages that dpkg skips because they depend on ttf-opensymbol>

/var/log/dist-upgrade/apt.log is empty; I'll attach main.log and main_pre_req.log.

Nathaniel Smith (njs) wrote :
Nathaniel Smith (njs) wrote :
Nathaniel Smith (njs) wrote :

Oh, and forgot to mention -- this was all with the amd64 version of ubuntu, on a Thinkpad T61.

Changed in update-manager:
importance: Undecided → Medium
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in update-manager:
status: Confirmed → Incomplete
Nathaniel Smith (njs) wrote :

I'm not sure what "try with the latest release" means on a feisty upgrade path bug, but no, I'm not upgrading from feisty to gutsy anymore. I assume it is still an issue, but I don't think feisty is still supported anyway, so it might as well be closed WONTFIX.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for following up and sorry if that boilerplate message was not totally appropriate. I'm closing this report due to your last comment. Don't hesitate to submit any new bug.

Changed in update-manager:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers